AVS Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter · #1 ·
Hi,


A friend of mine has the following problem with his NEC GP5000 (yes, the huge and heavy 9" beast :) .


When he connect the PJ to power and try to turn it on, the unit won´t power up totally, that means that the vents are running, so the unit get´s power - but the tubes won´t power up (maybe problem with the high-voltage).


On the DEF Board (supposed to be the mainboard) are 2 LEDS (number D023 which is on all the time and number D020 is on when powering up for a short time and goes then off).


I attatched a picture of the service manual where this board is described and where the Leds are shown.


Any help or suggestion is really very welcome :) .


Thanks for your interest.


Take care

Thomas
http://www.heimkino.at/gp50001.gif
 

·
Registered
Joined
·
1,481 Posts
I went through same problem.

PJ went down, both LEDs turned on and my GP5000 seemed dead.

With the service manual and, above all, my friend Romano's help,

I saw that the responsible for everything could be the Toshiba TR 2SC4288A, located on the vertical dissipator on DEF board (it's the biggest one, you really can't miss it!).

Once you located it, check it (a simple multimeter will be adequate) to see if you have EBC short-circuited: 99% is the situation you'll find.

You won't need the original NEC, and a spare transistor, easy to get in stores and on the Internet, will perfectly fit.

Replacing is very simple: raise the board and operate from below, desoldering it very carefully.

The whole operation is a piece of cake, and you'll require no more than 15 minutes to have it done.

BEFORE switching everything on, check soldering and contacts.

Then... ignition!

Good luck, and if you need further assistance, don't hesitate to write!

Ciao,

Andrea
 

·
Registered
Joined
·
251 Posts
I had a similar problem with my GE610 which is the NEC GP5000. Chuck Williams the ISF guru fixed it for me about $80.00 plus shipping. I agree with Andrea I too believe its the same thing. If you have a problem try contacting Chuck or if you like I'm parting one out and can have a board for you. Let me know.


Regards

JohnBoy:p
 

·
Registered
Joined
·
1,481 Posts
JohnBoy,

even if it seems I fixed the problem, could be very interested in a replacement board: tell me how much you'd asking for it, if Thomas, who's obviously in pole position, doesn't need it.

Ciao,

Andrea
 

·
Registered
Joined
·
218 Posts
Discussion Starter · #5 ·
@Andrea


Thanks very much for your help, we´ll try this this weekend.


@Johnboy


A spare board would be great !


Pls. contact me if you would see it or other pieces of this projector.


Thanks for your interest.

Take care

Thomas
 

·
Registered
Joined
·
251 Posts
Hi Andrea and thomas,


I don't think this is the forum to discuss selling anything so if you like e mail me directly at [email protected] I will be out after today untill Monday but I do promise to respond. Figure that I am parting this GE610 with only 1 good tube left on it everything else other than the Green and Blue is working . The cover is also in good shape.


Regards

JohnBoy :)
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top