AVS Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
5,034 Posts
Discussion Starter · #1 ·
Does anyone out there know how to get into service mode on a NEC Mt1020 lcd?


I'm having issues which I originally thought were misaligned panels, but upon further inspection is actually some sort of ghosting of the image.


There is a ghost image, about 10 or more pixels to the left of black edges, that is red/pink and up to 5 or more pixels wide depending on the color it's over.


So much so that I can see a duplicate mouse pointer outline, exactly to the left of the original. The whole screen has a band of red on the far right edge, which is the same in relation to the ghost image. Also there are faint red lines in the picture, that can only be seen in the ghost image.


It's always there, regarless of input or no input and even on internal menu with no input.


Someone suggested i try some clock/phase timing settings in the service mode, but I can't seem to find out how to get into service mode on this.


I've opened the pj and see no physical damage to boards/components, I do see a couple pots on the lcd driver board, but I can't tell what they are either so I'm not messing with them.


Any input appreciated, if you have a service manual, know what the pots are, or know how to get into service mode to try a few things...


Also, it's out of warranty, 98 model, so if there is a shop which would be best to fix this I would like to hear of it as well. NEC referred me to two local shops, but projectors are NOT their specialty and I think they'd be better at replacing burnt components than troubleshooting a digital pj problem.


thanks for any help

Troy
 

·
Registered
Joined
·
18 Posts
I have this same problem with my MT 1020. I have tried different video cards, refresh rates, all the settings in the projector and no luck getting rid of those vertical red lines.

Have you had any other responses with a fix?
 

·
Registered
Joined
·
5,034 Posts
Discussion Starter · #3 ·
Nope. I think I have found a fix for it, there are some pots inside that can be adjusted, but I have to get a copy of the flash rom to repair my "now corrupted" flash before I can get in and try the pots.


If you have an actual 1020 model, and if I sent you the software to connect it to your pc and download the flash, is there any chance you could do that for me? Then I could fiddle with the pots and let you know what the fix is for the original problem.


As it is now mine is just an expensive flashlight. No image projected at all without the flash reprogrammed.


Troy
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top