AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
330 Posts
Discussion Starter · #1 ·
So I just spent all my money on my new hobby :) But I'm having a big issue. I bought the Onkyo 606, Paradigm Monitor 7 fronts, cc-190 center. Using my old sony's for rears and no sub. Those will be upgraded later when I have money again :). TV is a Sony KDF-46E3000.

Now my problem: I use a PS3 for all my playing needs. Blu-ray, dvd, cd, etc. It is connected via hdmi, and I'm having the buzzing problem so many people seem to have. Now without reading 60 pages of talk, is there any known solution to this problem, or should I just give up and go exchange the receiver for a Denon/Sony? I know the speakers are connected properly, the hdmi cable is a very high quality shielded (friend works for BB so I got monster cables at cost). I want to love my new speakers,but with this buzz I just can't.


Any help will be appreciated.
 

·
Registered
Joined
·
474 Posts

Quote:
Originally Posted by jparker36 /forum/post/15445525


in case anyone cares, onkyo has been vindicated. turns out the issue is a cable ground loop (buzz goes away the second I unplug the cable dvr from the onkyo.

I returned my Onkyo for the same exact issue. I have a brand new house and have been using the same circuit to drive my previous setup (10 yr old sony). I put the 606 in and started hearing the hum noise (most noticeable out of my subs). I thought the same thing (ground loop) so I went out and got a power conditioner. Not really any help there. I tried all sorts of different things and then had enough and decided to return it for the HK.


Now the hum is gone. The 606 is a nice unit but I dont want to deal with the issues. I have heard that the 706 has had less problems in that area.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top