AVS Forum banner

Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
2,197 Posts
Discussion Starter · #1 ·
This is a bit of a last resort... I've tried everything and one...


I cannot get my new 5040 to see my home network and broadband connection. Frankly, if I have to go dial up, I just don't think this box is worth it, so this is pretty critical.


I'm using a pretty simple setup with a LinkSys BEFSR41 router ... everything (cable modem, PC, and the Replay) are connected to that.


When the replay starts to setup it is unable to find my router and the DHCP server (which I know is turned on). When I try to enter a static IP address from the next in the DHCP range... no good. I've been all over the SB site regarding the entries you need to make for proper IP config. The only thing I haven't done is open up all the ports needed for interenet sharing because a) I don't have an IP address for the RTV yet and b) it just seemed like I should get this thing activated first.


I've added devices in the past, like my Audiotron from TurtleBeach, that find my router and get an IP from the DHCP there no problem (in fact... that's how I tested the cable I'm using for the RTV).


Anyone have any thoughts or experience this as well??


Also, will I have to use a static IP to file share in the future? IF so, is this possible, given that my cable ISP (optimum online) only gives you one IP address? How can I use static then??
 

·
Registered
Joined
·
2,591 Posts
Well, just for grins, have you tried:


1) Swapping the cables used for the computer and Replay. It may just be a bad cable/port.

2) Check to see that the LEDs on the back of the Replay's network port are lit.

3) Perform the initial setup/connection via the modem and then switch to the network after setup.


You don't need to setup port forwarding yet, but you will when you want to receive shows via the net.


The IP address your ISP gives you is not the same as the IP address your Replay will use. I'm not a networking expect, but I know the IP addresses on your local network are different from the static IP address your IPS gives you. I'm sure someone else around here can explain it better.


Hope this helps.
 

·
Registered
Joined
·
2,197 Posts
Discussion Starter · #3 ·
Yep.. I've got good link lights all around... I've been using this same cable run with an Audiotron for over a year! (I can switch it back to my Audiotron and I'm OK).


I'm going to make a new post with this question so you could answer there or here if you like.


Let's just assume that there something a little funny that I can't get this thing to see my network. Do you think I should go ahead and register via phone modem? I do have a phone line close. Is it easy to change over to ethernet later? What are the odds a Replay software upgrade changes fixes this problem for me, vs. the odds that I've got a bum machine?


I intend to get lifetime activation so if I activate, I'd have to send it in vs. just exchanging this unit at Circuit City.
 

·
Registered
Joined
·
23 Posts
I have experienced a similar situation. I have a 3Com cable/DSL router which I plug into my cable modem. I initially turned DHCP on and tried letting my 5040 get the IP address from the router. This NEVER worked. I then tried manually setting the IP address on the replay, and that didn't work either. The setup program kept reverting back to DHCP, and couldn't get an address. Finally, I turned DHCP off on the router and then retried setup. Only then was I able to get the static IP address entered onto the 5040. Since then, everything has worked like a charm.


I tried turning DHCP back on, but it would make 5040 take forever to boot, even after the static IP was set up. So I've turned DHCP off for good.


I have an audiotron on my network also, and it has no problem with DHCP. But since the replaytv didn't like DHCP, I had to move everything to static, including the audiotron.
 

·
Registered
Joined
·
2,591 Posts
I have heard of people having problems getting the network to work during the initial setup. First connecting through the modem and then switching to ethernet fixed this sometimes. Switching network connection (ethernet to/from modem) is very easy. You just need to go into the setup menu and switch connection types.


I wouldn't activate the unit until you get it working to your satisfaction. Most people like static IP instead of DHCP, but the Replay should work in either mode.
 

·
Registered
Joined
·
805 Posts
I tried everything I knew for about a week trying to get a 4508 running on my network, with no joy. Despite having a home network for over a year that works fine with 3 pc's on the lan side and a cable modem on the wan side, I could not manage to get the 4508 to stay connected to the network -- even the few times that it did manage to take out an ip address [as shown in the dhcp log on the router] it would't stay connected. When it did take an address, I could ping it, but then after some number of minutes or hours, I couldn't ping it any more. Tried with dhcp, without dhcp, with short cable direct to router, by itself on the network, nothing helped. Flakey, flakey, flakey. It's back at CC and I'm back with my 3030.


[I have, over the past year, plugged a whole lot of half-baked hardware into my network, and this is the first piece of harware that didn't come up virtually first try...]
 

·
Registered
Joined
·
2,584 Posts
I think people have posted numerous times about problems between replay and dhcp. Why are you using dhcp at all -- you don't have many devices (from another of your posts I think you said you just had an AT, a Replay and a single PC).


So, disable dhcp on your linksys router and assign a static IP of 192.168.1.100 to your pc, 192.168.1.101 for your AT and 192.168.102 for your replay (you assign these addresses in the devices themselves, not in the router). In each of the devices, make sure to set your gateway to 192.168.1.1 (since you said that was the internal IP of your router) and your subnet mask at 255.255.255.0.


Finally, tell each of your devices (pc, replay and AT) what dns address to use. You can get that by going to your linksys router's status page, where it will tell you what your primary and secondary dns servers are.


By setting things up this way, your pc will boot faster (since it won't need to get assigned a new IP each time) and you'll know for sure what IP is tied to what device (so port forwarding is easier).


Please reprot back here even if this works so other people who read this thread will know how it came out.
 

·
Registered
Joined
·
2,197 Posts
Discussion Starter · #8 ·
You make a good case for disabling DHCP overall. In the end I know that I would have to use static at least for the Replay in order to enable sharing over the internet.


The real reason to use DHCP is simply that this is simply the default when I guy like me sets up a home network (... hey... I'm a banker, not an engineer).


It will take some time (my wife is about to strangle me for spending all weekend on this.. (actually I was ripping another 30 CDs for my Audiotron, but she doesn't need to know that).) :)


I'll start with my AT and PC... make sure I have them working static and then start all over with the Replay.


Thanks for the advice.
 

·
Registered
Joined
·
264 Posts
FYI,


I run a Linksys BEFSR41 with 4 PC's and my 5040 (via an additional 100MBit switch connected to the Linksys Uplink port) all with DHCP and have not had any problems. The 5040 grabs an IP all the networking features work fine (except for extremely slow Internet show transfers but I haven't yet ruled out a slow source for the show).


I wonder if this is another example of poor quality control on SB's part. Some units work fine with DHCP and others don't. There sure seems to be an awful lot of variance in the performance/stability of these 5xxx units. I must admit that I'm quite concerned about it (even though I seem to have a pretty reliable unit so far).


Scott
 

·
Registered
Joined
·
2,584 Posts
Quote:
Originally posted by plyons10
...The real reason to use DHCP is simply that this is simply the default when I guy like me sets up a home network (... hey... I'm a banker, not an engineer).


It will take some time (my wife is about to strangle me for spending all weekend on this.. (actually I was ripping another 30 CDs for my Audiotron, but she doesn't need to know that).) :)...
Ha, I'm a lawyer, not an engineer. But trust me on this (despite my profession)...setting things up for static internal IP is no harder than setting them up for the default dynamic IP.


1. Use your browser (e.g. internet explorer) to navigate to 192.168.1.1 (the linksys router page). Go to the dhcp tab (I think it's in 'advanced settings' and disable dhcp. While your in there, look at the status page and write down the dns primary and secondary addresses. That's all you need to do with your router (although if you prefer, you can at this point fix the router to forward the replay port to the replay ip address as described in the last paragraph of this post).


2. Go to 'network connections' on your pc (you get there in different ways depending on which windows operating system you are using -- it may be right on your start key or on the left pane in 'network neighborhood; if you can't find it, search in the 'help' file on the start key for 'network connection'); in network connections, right click your ethernet card and select properties. Select properties on the 'TCP/IP' setting for your ethernet card, and you will see a dialogue box. Change the IP tab to specify an IP address; then fill in the blanks by giving it an IP of 192.168.1.100 and a subnet mask of 255.255.255.0. Go to the 'Gateway' tab and add as the gateway 192.168.1.1 (the IP of your router). Finally, go to the dns tab, enable dns and add the dns addresses that you got from step 1 above.


3. Go to your AT (you can do this from the front panel or from a browser if you prefer), disable dhcp, designate an IP address of 192.168.1.101, a subnet mask of 255.255.255.0 and the dns addresses you got in step 1.


4. Got to Replay's setup network info, disable dhcp, designate an IP address of 192.168.1.102, a subnet mask of 255.255.255.0 and the dns addresses you got in step 1.


At this point, you will have four ip addresses:

router = 192.168.1.1

pc=192.168.1.100

AT=192.168.1.101

replay=192.168.1.102


The only tricky part is step 2, but if you've set up a network before (as you obviously have), this shouldn't be that bad.


Once you get all that working, it will be easy to go back to your router page, navigate to 'port forwarding' in the advanced settings, and specify whatever replay port you need open for internet sharing as a port that should be forwarded to 192.168.1.102 using tcp/ip.


Good luck.
 

·
Registered
Joined
·
2,197 Posts
Discussion Starter · #11 ·
Just to confirm.. I believe I MUST use the Audiotron browser interface to set up the DNS entries (no biggy there).


And, as far as setting up the Replay... I never get past the first two setup screens, where I tell it my type of connection (modem or ethernet), it looks for a network, can't find one, and then asks me for IP setup. Therefore, I've never been given the opportunity to disable DHCP on the Replay TV (which may be why, even when I've put in good IP / Gateway / etc. info. it still doesn't take). So, from the initial setup wizard (if I can call it that), how do I exit in order to disable DHCP????? This ultimately may be the crux of the problem (for me anyway).


By the way... not sure if I should have mentioned this earlier, but, the Replay sure doesn't waste alot of time looking for the network. I'm not home now, but I do remember one of the screens (not sure if it's before or after I specific IP addresses), coming up with a (2:00) that looked like a counter. But before it ever started counting down (about 5 - 10 secs), it kicked me back and said I had to enter new network info.


I know the AT spends alot longer looking for the network when things aren't setup correctly.


Thanks again for the detailed help.


(Lawyer??? Geeesh.).
 

·
Registered
Joined
·
2,584 Posts
Quote:
Originally posted by plyons10
Just to confirm.. I believe I MUST use the Audiotron browser interface to set up the DNS entries (no biggy there).


And, as far as setting up the Replay... I never get past the first two setup screens, where I tell it my type of connection (modem or ethernet), it looks for a network, can't find one, and then asks me for IP setup...
I may be remembering this incorrectly, but I did think you could set the AT dns addresses from the AT's front plate; but you're right as well that that is easy to do from the browser when you've got everything else up and running.


As for the replay wizard, I don't remember what it says (I only had to suffer it once), but if it's asking you for an IP, I would imagine that means it's already given up on dhcp so I would guess that the wizard has disabled it. Just go with the flow there and see if you can't get beyond the damn wizard, since once you get beyond the wizard the replay has a very simple 'network settings' menu that allows you to enable/disable dhcp, enter the ip address, enter the gateway, enter dns addresses, etc.
 

·
Registered
Joined
·
2,197 Posts
Discussion Starter · #13 ·
Thanks for everyone's help. If anyone finds this thread for help on their problems they should NOT look here.


Basically, it was (and still is) a cabling problem.


The CAT-5 that runs from the AV closet to my router (and which I've been using for over a year to run my Audiotron) is funky. This never came up before because the Audiotron is 10 Mb (it may also have something to do with being duplex or not, but whatever).


So although my Audiotron ran, and continues to run, perfectly fine on this cable, I cannot get a 100Mb machine like the Replay... or a 100 Mb switch for that matter, to work on that cable.


Who'd a thunk it?


After a dozen disconnects and re=boots I finally got the phone line connection to work and I'm up and running. I'd still like to get the ethernet working before I go lifetime, but I don't know if that'll be possible.
 

·
Registered
Joined
·
2,591 Posts
Didn't I suggest the cable 2 days ago?


Oh well, at least you got it working. I'm not sure if it's possible, but just use a different cable to run from your router to your Replay. Even if it's just laying on the floor for a little while, at least you can try out the network and see if you like it.
 

·
Registered
Joined
·
2,197 Posts
Discussion Starter · #15 ·
Hey... I know the cable was obvious.. But like I said, I'd been using this run of cable for over a year and there was no easy way to test it because I don't have a long cable around to run across the floor (it's about a 50 foot run).


I just finally moved half my AV equipment into my office and did it that way.


I'll get a long cable run and see if I can config tomorrow.


Thanks again to everyone.


Especially Ace987 for not saying, "I told you so."
 

·
Registered
Joined
·
9,578 Posts
Quote:
Originally posted by plyons10
I'll get a long cable run and see if I can config tomorrow.
In my experience, as long as the CAT5 cabling hasn't been cut by

snagging on something sharp, 95% of all problems are because

whoever punched down the connectors screwed up the order of

the individual wires/pins or the connection(s) became loose.


While you're getting the long cable run, you might want to also

invest in a simple RJ45 tester which should run around $30-$50.

These are invaluable in debugging wiring problems and you can

purchase from a store with good return policy if you don't feel

you'll need it long term.


Basically it's two components which attach at either end of the

cable run. There are 4 LEDs, one for each of the 4 pairs in the

CAT5 cable. They'll light up green for good, red for reversed

polarity, and if they don't light up then the pair is not connected

properly (either swapped or connection is bad)


You might want to also look inside the RJ45 female jack with a

flash light. Sometimes people will plug in a RJ11 phone plug into

the jack by mistake which may cause pin(s) in the connector to

be bent.
 

·
Registered
Joined
·
2,197 Posts
Discussion Starter · #17 ·
Thanks for the advice... I agree, althought a cursory visual examination of the cable ends (both male) didn't reveal anything out of order.


I doubt I buy a tester since I'm convinced it's the cable. I'd do better buying my own crimping tool at this point... and it still might actually be broken somewhere in the wall.
 

·
Registered
Joined
·
133 Posts
Quote:
Originally posted by plyons10

I'm using a pretty simple setup with a LinkSys BEFSR41 router ... everything (cable modem, PC, and the Replay) are connected to that.


When the replay starts to setup it is unable to find my router and the DHCP server (which I know is turned on). When I try to enter a static IP address from the next in the DHCP range... no good.

I have the same LinkSys router and have had the same problem (posted about it back in February of 2002). You must disable DHCP completely on the LinkSys. Assign all network devices on your network statically.


Another alternative is to try upgrading your LinkSys' firmware. According to some reports I've read here, the ReplayTV will work with DHCP-assigned addresses if you use a certain version of the LinkSys firmware. No one has thoroughly explored which versions work and which do not.
 

·
Registered
Joined
·
9,578 Posts
Quote:
Originally posted by plyons10
Thanks for the advice... I agree, althought a cursory visual examination of the cable ends (both male) didn't reveal anything out of order.


I doubt I buy a tester since I'm convinced it's the cable. I'd do better buying my own crimping tool at this point... and it still might actually be broken somewhere in the wall.
I guess you know what is best for your situation, but unless the cable

is physically damaged behind the wall where you can't see it or it is

wrapped around power lines in parallel, I've never seen the cable as

the problem. It's almost always the connectors. Sometimes the

white-blue and white-green are hard to distinguish. White-orange

and white-brown as well as the solid colors are easier. I can't tell

you how many times I've swapped colors by mistake when crimping

wires and 2 minutes of testing saved hours of network level debugging.


If you are getting a crimper, make sure you get the appropriate

RJ45 male plugs for the best connections. There is one type for

solid-core wires and another for stranded wires. Also stay consistent

either wire T568A on both ends or T568B on both ends. If you mix

and match you'll end up with crossover cable.

http://www.bluemax.net/techtips/netw...estandards.htm
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top