AVS Forum banner

Status
Not open for further replies.
1 - 20 of 29 Posts

·
Registered
Joined
·
1,436 Posts
Discussion Starter · #1 ·
I have created a new filter that reads multiple transport stream files that when used with Leszek's filter create an alterative to DStream.


I am working on creating an application that utilizes this filter but for now I need some feedback as to how well this part working.


To use the filter you must register it like this:


copy the attachment below to c:\\windows\\system then run regsvr32 asyncflt.ax


Then create a filter graph using graph edit that looks like this:


File Source (Multiple Async.) -> Mpeg transport to Source Packets -> AV/C Tape Device.


This filter has worked well in my testing but I need more feedback. It should work with both Hipix and MyHD transport streams but I'm not sure about titantv filenames.


I will monitor this thread for feedback.


--Rick

 

asyncflt.zip 38.15625k . file
 

Attachments

·
Registered
Joined
·
4,037 Posts
Hi Rick,


Thanks for the effort. I tried your filter last night. Well, the result is not too positive I must say. Many of my testing clips ran into the "slow motion stuttering with no sound" problem like I wrote in this thread:

http://www.avsforum.com/avs-vb/showt...0&pagenumber=3


Look toward the end of the page for my post. Dstream latest version solved the problem partly but still has other glitch.


From the last night testing, I'm sad to say your filter seems has even more issue than the latest Dstream.


If possible, please keep up the good work and I'm sure thing can be improved.


Btw, the multiple files reading/playing works.


regards,


Li On
 

·
Registered
Joined
·
1,436 Posts
Discussion Starter · #4 ·
Li On,


I'm not sure what is happening here. This filter mearly loads files. It passes the transport stream unmolested to the TSP2SP filter.


I'll take a look at the dstream code to see if I can figure out what JPELL did to make your life easier.


Also keep in mind that the only content I have is data I have recorded from the hipix. Perhaps if you could send me a sample transport stream that exibits the problem I could be more helpful.


--Rick
 

·
Registered
Joined
·
1,060 Posts
So far from my testing, I haven't seen any stuttering.


When I first tried the filter last night, I was setting up the graph and then saving it. When I attempted to play a stream, it only played the first file and then stopped. I found that if I opened graphedit, constructed the graph, and then selected play without saving it, it plays multiple files?


I am still having issues with output stopping on corrupted streams just like I encounter with Dstream.


I am currently archiving a 2.5 hour movie that dstream kept stopping after 91 minutes with the "walk out the door bug". I let you know how the new filter fairs in the scenario.
 

·
Registered
Joined
·
4,037 Posts
Hi Rick,


Thanks for the update. So the filter is like a front end to TSP2SP with multiple files support. I misunderstanded it as a complete new filter. I'll try to test more tonight.


Btw, what's your DVHS, a US JVC 30kU? Do you have the current hot MyHD card? Because almost all my HD source is from the Japanese BSD system. I'd love to send you some problem clips but you can only play them play via:


- picture and sound, a Japanese JVC 30k/35k DVHS

- picture only, US 30kU recorded via ilink and playback to HTPC via ilink in GraphEdit software playback like the way posted in the forum

- picture only, US 30kU recorded via ilink and playback to HTPC via MyHD card

- picture only, file mode playback via HiPix/MyHD and GraphEdit software playback


I already ordered the MyHD from DC in the powerbuy and hope it has better DVHS support.


Thanks in advance.


regards,


Li On
 

·
Registered
Joined
·
1,436 Posts
Discussion Starter · #7 ·
Li On,


I have the Mits D-VHS unit and a Hipix card. I too have a MyHD card on order.


You should be able to pull a piece of your video from tape using the TSPCAP filter. It will output a transport stream I can playback or re-record to tape.


--Rick
 

·
Registered
Joined
·
1,060 Posts
Rick:


MY 2.5 hour archive failed at the same spot as Dstream. Dstream actually stopped a couple of times earlier in the stream also with the hanging bug. The problem that I am running into right now is a corrupted stream upon dstream and your filter encountering, data transfer is halted.


I have a 9 second clip with the corrupted stream if you would like it? It is about 21mb/15mb normal/zipped. If you have an ftp site, I can upload it.
 

·
Registered
Joined
·
2,961 Posts
Rick,

I tried a 15 minute recording of MYHD files with this filter and it did work.

Played it back from the Mits D-VHS via MYHD.


Looking good.


I am going to record the entire MYHD recording (files on disk) using your filter while I am at work and will report back the results this evening.


Thanks,

Joe
 

·
Registered
Joined
·
311 Posts
Ricka,


I can't seem to get this to work with 720p files. 1080i works pretty well, although I do get an occasional audio dropout.


Regards, Peter
 

·
Registered
Joined
·
1,436 Posts
Discussion Starter · #13 ·
Abq-Pete. I tested it with Alias and it worked very well. What 720p content were you using?


JoeQ. That's normal. It will do that when its done. The VCR gets confused when its done. Playback/restore should be fine.


--Rick
 

·
Registered
Joined
·
311 Posts
Rick,


I think something happened to my Armageddon recording. I just tested some "fresh" ABC recordings and they work fine using your filter. DRAT! I hope they re-broadcast this movie so I can record directly to tape.


Thanks and regards, Peter
 

·
Registered
Joined
·
2,961 Posts
Quote:
Originally posted by ricka


JoeQ. That's normal. It will do that when its done. The VCR gets confused when its done. Playback/restore should be fine.


--Rick
Rick,

There was only about 25 minutes of the Recording on tape and this was a brand new blank D-VHS tape (not S-VHS which do work with MYHD).


I am using a 15' firewire cable. Do you think that could be causing noise?


Thanks,

Joe
 

·
Registered
Joined
·
1,436 Posts
Discussion Starter · #16 ·
Joe Q,


Firewire was designed to work at upto 45 feet so you should be ok. I'm starting to think that bad transport streams are causing the TSP2SP filter fits.


I hope to have another drop today or tomorrow to address the registration issue that fireball listed above and a few other small things. Right now I gotta go pick up my MyHD card. (its' being held hostage at Airborne Express).


--Rick
 

·
Registered
Joined
·
1,534 Posts
Quote:
Originally posted by ricka
Joe Q,


Firewire was designed to work at upto 45 feet so you should be ok. I'm starting to think that bad transport streams are causing the TSP2SP filter fits.


I hope to have another drop today or tomorrow to address the registration issue that fireball listed above and a few other small things. Right now I gotta go pick up my MyHD card. (its' being held hostage at Airborne Express).


--Rick
Rick,


Are you using mine or Joe's (JPELL's) version of the TSP2SP? Joe added a workaround for bad transport streams that seem to work well in a lot of cases. Look at the source code difference between the two and you will see what I mean.


Leszek
 

·
Registered
Joined
·
1,060 Posts
Leszek:


For the transport stream problems I have encountered, both Dstream and Rick's filter experience the same problem.
 

·
Registered
Joined
·
1,060 Posts
Quote:
Originally posted by Joe Q



Rick,

There was only about 25 minutes of the Recording on tape and this was a brand new blank D-VHS tape (not S-VHS which do work with MYHD).


I am using a 15' firewire cable. Do you think that could be causing noise?


Thanks,

Joe
Hi Joe:


Why doesn't MYHD work with S-VHS tapes? How does it know what type of tape is in the VCR, especially if you drill a hole in the S-VHS?
 

·
Registered
Joined
·
1,534 Posts
Quote:
Originally posted by Fireball
Leszek:


For the transport stream problems I have encountered, both Dstream and Rick's filter experience the same problem.
Both Dstream and Rick's filter graph will use the same TSP2SP filter (either mine or JPELL's) depending on which one is currently registered!


So you will get the same problem with either if there is a bad transport stream.


Thanks,

Leszek
 
1 - 20 of 29 Posts
Status
Not open for further replies.
Top