AVS Forum banner

3681 - 3700 of 12122 Posts

·
Premium Member
Joined
·
3,612 Posts
FW Beta 111518

http://www.lumagen.com/testindex.php?module=radiancepro_updates

Beta 111518
Improves or fixes several deficits in image based auto aspect detection.
Fix for sometimes missing MaxCll detection from HDR sources and also cases of not changing the colorspace when HDR/SDR changes occur.
Added another rs232 report for only SDR/HDR under Other: I/O Setup: RS-232 Setup : Report changes.
If set to SDR/HDR 'S' or 'H' will be output on rs232 for SDR or HDR respectively.
Please continue giving us your detailed feedback on issues via email at [email protected] .
Update time ~5 minutes @230k from previous firmware

EDIT:

** NOTE: Don't install 111518 ***

Beta 111618
Fixed saving bug in 111518.
Improves or fixes several deficits in image based auto aspect detection.
Fix for sometimes missing MaxCll detection from HDR sources and also cases of not changing the colorspace when HDR/SDR changes occur which were issues in 1101-111018 firmware.
Added another rs232 report for only SDR/HDR under Other: I/O Setup: RS-232 Setup : Report changes.
If set to SDR/HDR 'S' or 'H' will be output on rs232 for SDR or HDR respectively.
Please continue giving us your detailed feedback on issues via email at [email protected] .
Update time ~5 minutes @230k from previous firmware


Bug with 111518
Saving menu changes caused units to hang and corrupted the configuration.
If you've updated to 111518 already then don't save any configuration changes and to update you'll need to do a bootloader update which means unplugging power, then replugging power and starting the update utility in ~10 seconds.
 
  • Like
Reactions: giomania

·
Registered
Joined
·
251 Posts
Some problems. 1.85 aspect ratio doesn't work anymore, sometimes saving data configuration hangs the Radiance and you have to unplug from AC, image has a permanent black border in top and and bottom.
Tried to restore previous firmware but it hangs while "UsingFPGA loc00". I tried normal and Forced.
Does anybody have an idea how can I restore it to previous firmware?
 

·
Registered
Joined
·
251 Posts
if it can be helpful, here is the log:

Status: Connect to Lumagen Video Processor...
Status: Set communication speed...
Status: Connected
Status: Checking firmware version...
Status: RX fw ver = 1161300, rd:01161300
Status: TX fw ver = 1000900, rd:01000900 txlen=286720
Status: NTX fw ver = 1001200, rd:01001200 txlen=286720
Status: 01001200 SW Rev:111518 Serial:3487 baud rate:115200
This updater is Rev:111018
This updater is Rev:111018
Status: Checking the mode of communication...
Status: We are in normal operation mode
Using FPGA loc:00
Status: erase failed.
 

·
Registered
Joined
·
251 Posts
Now it can't definitely save configuration any more. It always hangs on "Press 'OK' to confirm saving configuration Saving…..please wait"
I have to unplug AC
 

·
Registered
Joined
·
549 Posts
You need to make a bootloader firmware restore.

1. Turn the Radiance power off by unplugging the AC power cord or unplugging the power cord from the back of the Radiance.
2. On the PC double click (run) the download utility.
3. Choose the correct Com port.
4. Plug in the Radiance power cord.
5. Within 10 seconds, click “Start” to begin the download.
6. The firmware update will start updating which can take a couple minutes. The PC
utility will finish and tell you when it’s done.
7. If the utility finishes with and error; just turn the Radiance off, then back on and
rerun the download utility
 

·
Registered
Joined
·
251 Posts
You need to make a bootloader firmware restore.

1. Turn the Radiance power off by unplugging the AC power cord or unplugging the power cord from the back of the Radiance.
2. On the PC double click (run) the download utility.
3. Choose the correct Com port.
4. Plug in the Radiance power cord.
5. Within 10 seconds, click “Start” to begin the download.
6. The firmware update will start updating which can take a couple minutes. The PC
utility will finish and tell you when it’s done.
7. If the utility finishes with and error; just turn the Radiance off, then back on and
rerun the download utility
Thank you Eventidal, you solved it! It downgraded perfectly but I had to reload a configuration backup because colors were completely nonsense like cross-processed film.

Thank you very much for your help.
 

·
Premium Member
Joined
·
3,612 Posts
FW Beta 111618

http://www.lumagen.com/testindex.php?module=radiancepro_updates

Beta 111618
Fixed saving bug in 111518.
Improves or fixes several deficits in image based auto aspect detection.
Fix for sometimes missing MaxCll detection from HDR sources and also cases of not changing the colorspace when HDR/SDR changes occur which were issues in 1101-111018 firmware.
Added another rs232 report for only SDR/HDR under Other: I/O Setup: RS-232 Setup : Report changes.
If set to SDR/HDR 'S' or 'H' will be output on rs232 for SDR or HDR respectively.
Please continue giving us your detailed feedback on issues via email at [email protected] .
Update time ~5 minutes @230k from previous firmware


Bug with 111518
Saving menu changes caused units to hang and corrupted the configuration.
If you've updated to 111518 already then don't save any configuration changes and to update you'll need to do a bootloader update which means unplugging power, then replugging power and starting the update utility in ~10 seconds.
 

·
Registered
Joined
·
251 Posts
Probably I'm unfortunate. I can't no more restore the unit from standy with RS232 PowerOn command. I have to power on with remote control, then if I send StandBy command via RS232 the unit goes in standby but If I send PowerOn command it doesn't wake up. I have to do it via remote control.
 

·
Registered
Joined
·
414 Posts
Probably I'm unfortunate. I can't no more restore the unit from standy with RS232 PowerOn command. I have to power on with remote control, then if I send StandBy command via RS232 the unit goes in standby but If I send PowerOn command it doesn't wake up. I have to do it via remote control.
Email [email protected] with your current config file from your Pro (if you haven't done it before, just use the config utility from our website to get it). Sending '%' via rs232 to power-on the Pro still works so it's either something a bit off about your power-on string your control system is sending or a bug in the Pro with the settings that you have.
 

·
Registered
Joined
·
251 Posts
Email [email protected] with your current config file from your Pro (if you haven't done it before, just use the config utility from our website to get it). Sending '%' via rs232 to power-on the Pro still works so it's either something a bit off about your power-on string your control system is sending or a bug in the Pro with the settings that you have.
Just sent, thank you for the advice.
 

·
aka jfinnie
Joined
·
5,445 Posts
...and if you change aspect ratio it no more sends out an automatic v2 Full Info via RS232. Rev is 111618
I think something must have happened to your config as all RS232 comms are still working fine on mine (auto aspect v2 full info on rs232); but I never saved any settings with 1115.
 

·
.NET Solution Architect
Joined
·
979 Posts
Unplug AC power supply for about a minute, plug it in back and repeat procedure this will work 100÷ as I had similar issues you've described. You cannot brick Lumagen as you can always boot this in safe mode
Probably I'm unfortunate. I can't no more restore the unit from standy with RS232 PowerOn command. I have to power on with remote control, then if I send StandBy command via RS232 the unit goes in standby but If I send PowerOn command it doesn't wake up. I have to do it via remote control.
Sent from my ONEPLUS A6003 using Tapatalk
 

·
Premium Member
Joined
·
3,612 Posts

·
aka jfinnie
Joined
·
5,445 Posts
Fix for rs232 report change messages not getting sent out usb port when active.
I'd seen this behaviour a couple of months ago and assumed it was by design, so started to use the RS232 for auto aspect notifications...! Nice one.
 

·
Registered
Joined
·
348 Posts
Hi, is the auto aspect function so fast that it can be used in films with different aspects ?
 

·
Premium Member
Joined
·
3,612 Posts
I thought this would be of interest to Lumagen owners.

From
NEW JVC RS3000/NX9 RS2000/N7 RS1000/N5 Native 4K Projectors Anticipation Thread
https://www.avsforum.com/forum/24-d...ors-anticipation-thread-399.html#post57301166


Originally Posted by doctormyeyes View Post
Well, yes, ... I would agree that tone mapping to adapt HDR to our projectors is necessary, as for many of us, limited brightness is our problem. However, that should be largely achievable with a single fixed HDR calibration for your projector. My point being that dynamic tone mapping within the projector will become less important once standards are more uniform. So... choose your projector based on its basic image rather than its HDR processing capability.

The system built into the Panasonic 820, and it appears the new JVC's, seem less designed to make HDR possible than to make it more consistent from source to source. My RS540 looks great with HDR, once it has been 'tuned in'. Its problem is the source variability, requiring re-tuning for many presentations.

If I'm wrong, there will undoubtedly be a Panasonic 820 or other brand successor, AVR or other device, less costly than a Lumagen and less complicated than a PC, that is capable of processing HDR for all your devices.

Mind you, I am sure the new JVC's will be great projectors. I just wouldn't make its HDR tone mapping paramount in my decision to purchase.
.......
You might actually have a point here.. When I was demoeing the N5 at my local dealer, they have uploaded their custom HDR curve to the projector instead of using the ready made HDR tone mapping. I asked them why they did that when all they have to do is set to the auto tone mapping.. they said that their curve is far superior to the built in HDR auto tone mapping for ALL content they tested it on.. and they tested it on many UHD disks...

I then switched between the auto tone mapping and what they did and the difference were astounding... their own custom curves were soooo good... images were totally popping... while the auto tone mapping looked anaemic in contrast.. it's not that it's bad.. but in comparison not even in the same ball park...
 

·
aka jfinnie
Joined
·
5,445 Posts
Hi, is the auto aspect function so fast that it can be used in films with different aspects ?
No, it is not. Switching can take a couple of seconds, more if the bars aren't very black.

What is your interest in this? Do you:
1) have a 16:9 screen with top and bottom masking you want to drive?,
2) want to zoom into the 2.35:1 sections to fill a 16:9 screen, or
3) want to zoom out of the 16:9 sections to fit within a 2.35:1 screen?

2) & 3) would be abominations in my mind as you'd be massively changing the framing intent of the movie. 1) I have sympathy with (I have top / bottom electric masks) but the mask system noise and lag ends up being more of a distraction than benefit - . You could only really achieve it with a preprogrammed set of movements which got the masks to the right place at the right time.
 

·
Premium Member
Joined
·
1,771 Posts
Does anyone know why the auto aspect feature only works on some films? I can't seem to find a patter but many of my 2.35:1 movies aren't recognized by the feature.
 
3681 - 3700 of 12122 Posts
Top