AVS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
I just got my PS3 today (80GB) and everything was going fine until I tried to update to firmware 2.41. It went through the wi-fi download fine until the end. It said that the system would restart automatically after the update was complete but the screen went blank after the progress bar read 100% and has stayed that way for over 20 minutes. The power light is a solid green and it when I tried to turn it off it just beeped. Is my player ruined, or is another explanation? Any help would be appreciated?
 

·
Registered
Joined
·
9,457 Posts
Did you buy it locally? At least it happen now vs 2 months later. Simply take it back and replace if you can.

If anything, did you flip the switch in the back of the console?
 

·
Registered
Joined
·
9,457 Posts

Quote:
Originally Posted by Hoosier1 /forum/post/14306078


I bought it at Best Buy locally.

I would just simply switch it out even if you did get it back up and running IMO.
 

·
Registered
Joined
·
1,663 Posts
Flip the switch on the back, turn it on again and see what happens.


That happened with me for one update, and it worked fine after flipping the switch and turning the system back on.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #7

Quote:
Originally Posted by Protopet /forum/post/14307738


Flip the switch on the back, turn it on again and see what happens.


That happened with me for one update, and it worked fine after flipping the switch and turning the system back on.

Thanks. I did reset the power switch in the back, and it worked, despite the fact that the manual tells you NOT to do that.
 
1 - 7 of 7 Posts
Top