AVS Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone bought the 910 and it plays some dvd fine others will flutter in the exact spot every time (no disc damage that I can see) ( All 3 of the Star Wars series), take the same dvds and they all runs fine on both of my new PC dvd readers.

This is hocked up (S video) to a hitachi picture tube television in non progressive scan mode :mad:
 

·
Registered
Joined
·
1,684 Posts
Sorry no one else responded,just post a one word extra response"bump" when you don't get a reply.


This player sounds defective, I would call Denon on the number in your owners manual.
 

·
Registered
Joined
·
75 Posts
lol could be. have a backup dvd player ? or borrow a friend's real quick and play those same parts and see if the problem still exists.


ur scaring me tho, I'm anxiously awaiting my 910 I got on eBay real cheap and I am using a Hitachi RPTV. it is a 2003 model tho =) S500 all the way !!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
I think all try it on the GF brothers brand new TV


Just thought it was weird that only some do it and on my PC they all play perfect on like a 40$ dvd player:rolleyes:
 

·
Registered
Joined
·
725 Posts
Mine kind of stuttered on Monsters Inc. for a few seconds, almost froze. DVD is pristine, never gave me any trouble on my JVC SA-70...


Strike one...


P.S. I really miss the gamma and tint adjustments on the JVC, the Denon is just utilitarian in comparison...Thank goodness it has dcdi to redeem it...
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top