AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4,185 Posts
Discussion Starter · #1 ·
Hello-


I first bought an Nforce 2 motherboard with the Soundstorm on-board Dolby Digital encoder. Now, I have several other Nforce boards (Nforce 3, Nforce 4, Nforce 430/Geforce 6150), and the sound has a problem on the Nforce 4 board. I cannot get Dolby Digital 5.1 sound from my HDTV tuner on the NF4 board, but it is fine on the NF430 at least. Both machines have the following items:


AMD Athlon 64 CPUs (one is 3800, the other is X2 4200)

Windows Media Center 2005

Nvidia Purevideo decoder

Kworld USB HDTV tuner

Latest Realtek audio and Nforce drivers (6.86)

5.1 speaker systems connected via S/PDIF digital audio output


The Nforce 430 board is a Foxconn/WinFast 6150K8MD, the Nforce 4 board is an ECS Nforce4M-A.


MCE has a speaker setup "wizard" that will send sound to all five speakers and the subwoofer. It works fine on the NF430 board (with Realtek HD Audio), and while the test is running the Purevideo decoder shows "Dolby 5.1" as the audio format. On the Nforce 4 board (with Realtek AC97 audio) during the same test, sound only comes from the front stereo speakers, and viewing the decoder properties shows it is only in Dolby 2.0 mode. I have tried two add-on sound boards with this computer (Yamaha DS-XG YMF744 chip, and Turtle Beach Riviera; both have optical digital audio outputs as well), with the same results.


Another note: When playing DVDs on either computer, Dolby Digital 5.1 works fine through Media Center.


My question then is, is my problem possibly from the Nforce chipset? That is, do some Nforce 4 versions include Dolby Digital 5.1 encoding and others lack it (or only have 2.0)? Can anyone tell me of a Web site that may have these details listed? I tried to look at Nvidia's descriptions of the various chipsets, but they were neither clear nor consistent.


Thank you for any help.
 

·
Registered
Joined
·
4,185 Posts
Discussion Starter · #2 ·
Well, i have had no luck learning any more about this problem, so I will try the "brute force" method of fixing the problem. I bought another motherboard that also has the Nforce 430 chipset and Realtek HD Audio... We shall see if it handles Dolby Digital properly. Time to rip apart my HTPC (again)...
 

·
Registered
Joined
·
2,385 Posts
Something doesn't jive you should be able to get 5.1 with an external card using pass through, so it doesn't sound like a chipset issue but rather an OS/bios setting issue. Did you try a reinstall of MCE, sometimes things can get screwy with first time installs. It sounds like MCE is ignoring the commands and is stuck in a 2 CH state for some odd reason. Maybe MCE needs to be connected to a 5.1 source while installing the OS?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top