AVS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi All-


I am sure I have something set wrong, and to be honest I have not done a LOT of trouble shooting yet, but maybe somebody here can save me some headaches. As the title says I am not getting any bass from my sub when I am watching bluRays. I do get Bass just fine from just OTA TV. I'll break down my setup.

Hardware

TV: Samsung LN46B650

BluRay: Samsung BD-1500

Receiver: Pioneer VSX-917K

Sub: JBL SCS145.5

connections are set up:

BluRay --- HDMI --- HDMI Switch --- HDMI --- TV

TV --- Fiber Optic --- Pioneer VSX

Pioneer VSX --- Sub Preout --- LTE input

Settings

BluRay --- bitstream

Pioneer --- Digital + Dolby ProLogic II

TV --- External Speaker


Any thoughts or advice would be appreciated.
 

·
Registered
Joined
·
29,195 Posts
Because when you run blu ray to your TV and then out thru the TV's optical output you're only getting 2 channel stereo. However when your using the TV's built in OTA tuner you can get Dolby Digital 5.1.


Connect your blu ray player directly to the receiver with an optical cable. It'll convert TrueHD and DTS-MA audio to Dolby Digital 5.1 and DTS 5.1. Make sure the audio ouptut on the Samsung is set to Bitstream (Re encode)


When you say "BluRay --- HDMI --- HDMI Switch --- HDMI --- TV" what does that mean? Do you have an external HDMI switcher or are you using the HDMI ports on the 917?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
Hey Afro-GT


Thanks for the response. I have an external HDMI switch that I am using. Not the one on the pioneer.


I have:


BluRay--


Xbox360-- HDMI -- Switch -- TV


MediaPC--


And then using the Optical from the TV back to the receiver. What your telling me is that the TV is downgrading the HDMI Audio from the BluRay (and other sources I assume) to Stereo when its sent back to the Receiver, but the OTA audio is maintaining the proper 5.1 audio. Is that accurate?
 

·
Registered
Joined
·
2,268 Posts

Quote:
Originally Posted by Stryker908 /forum/post/18242620


What your telling me is that the TV is downgrading the HDMI Audio from the BluRay (and other sources I assume) to Stereo when its sent back to the Receiver, but the OTA audio is maintaining the proper 5.1 audio. Is that accurate?

That is correct. You should run optical from your BluRay player directly to your receiver. Configure your BluRay player for optical audio out.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
This fixed the problem! Thanks for the help.


Anyway to set the TV to just pass the sound back to the receiver with out changing it to stereo ? My Pioneer only has 2 optical inputs....
 
1 - 6 of 6 Posts
Top