AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
449 Posts
Discussion Starter · #1 ·
I have a problem with an mkv not playing the surround sound through my receiver, only stereo audio. It has a 6 channel audio track, and I converted the mkv back to DVD to verify. When I play the DVD through Win7 Media Center I get full surround sound, but when I play the mkv I only get stereo audio.


My HTPC is connected via hdmi only. Obviously it can output surround through this connection, but not with mkv's at the moment. I am currently using Shark Codec Pack (x64) and everything works great, just no surround through mkv's. I tried changing the audio settings to 5.1 speakers and it still won't work. Can anybody help? I am really confused.
 

·
Registered
Joined
·
3,653 Posts
I'd suggest hitting up the Shark007 forum. There are some settings you have to set to get the DD 5.1 to work (and it varies from installation to installation). If I remember correctly for me I had to diable the Windows Media Foundation, enable h264 to use the Divx codec, set the AC3 to passthru and a couple others I can't remember. Once you do get it set and working though use Shark's save profile ability so that when you upgrade you can load up your old settings so things work again. I made that mistake as I didn't know it was available and I spend an hour getting DD to work again.


And of course 64 bit is different.


Good luck.
 

·
Registered
Joined
·
449 Posts
Discussion Starter · #3 ·
Wow, that shark guy is really helpful. We figured out the problem, and it was fixed by enabling spdif passthrough (never though I would use this as I didn't use an spdif cable for audio) and disabling the Microsoft audio decoder.
 
1 - 3 of 3 Posts
Top