AVS Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
12,914 Posts
Discussion Starter · #1 ·
I have an Nvidia GTX670 card on my HTPC. I recently stumbled upon the 0-255 dynamic range toggle that is available on the newest Nvidia drivers and thought this fixed the problem.
Not really - with further use I figured out it just gets rid of all the black detail and makes the overall picture darker - it's not better, just darker.


PS3, PS4, Xbox360 - all look great as sources - my cheap sony bluray player too. My expensive HTPC - nope. Blacks are either washed out on the 16 to 235 setting, or too black on the 0-255 setting.


No video calibration done on the Panasonic AE8000. IMO it looks good out of the box on all my other sources - just not HTPC.


What am I doing wrong - I've struggled with this black level thing on my HTPC for years, through several decent video cards (460, 560), and through a couple different projectors Panasonic AX200U, Epson 8350.
 

·
Registered
Joined
·
366 Posts
I have an Nvidia GTX670 card on my HTPC. I recently stumbled upon the 0-255 dynamic range toggle that is available on the newest Nvidia drivers and thought this fixed the problem.
Not really - with further use I figured out it just gets rid of all the black detail and makes the overall picture darker - it's not better, just darker.


PS3, PS4, Xbox360 - all look great as sources - my cheap sony bluray player too. My expensive HTPC - nope. Blacks are either washed out on the 16 to 235 setting, or too black on the 0-255 setting.


No video calibration done on the Panasonic AE8000. IMO it looks good out of the box on all my other sources - just not HTPC.


What am I doing wrong - I've struggled with this black level thing on my HTPC for years, through several decent video cards (460, 560), and through a couple different projectors Panasonic AX200U, Epson 8350.
If you use the 0-255 setting on the HTPC, then you would have to set the AE8000 to accept the full range (HDMI Signal Level->Expand on AE4000, should be similar on AE8000).
 

·
Registered
Joined
·
12,914 Posts
Discussion Starter · #3 · (Edited)
Thanks for the suggestion - though I tried that. I feel like that's a sum zero difference. My black levels go back to inferior when I try this combination, IMO.


0-255 on NVidia card
Expanded HDMI signal level on Panasonic.


I also set the Onkyo pre/pro to 'through' meaning it isn't supposed to be doing anything to the HDMI signal.


Looks pretty similar to 16-235 in Nvidia and normal HDMI signal level on Panasonic.


By the way, unless I choose full screen videos from the bottom drop down on the driver control panel - 0-255 with expanded looks really washed out on everything.
 

Attachments

·
Registered
Joined
·
366 Posts
I have an AMD setup, so I'm not that familiar with Nvidia, so hopefully someone who is will chime in. I'm not sure what the "digital vibrance" is doing. Also, you might want to show screen shots of the "adjust video color settings" and "adjust video image settings". I would also suggest trying to connect directly to the projector to rule out that the Onkyo is doing anything funny.
 

·
Registered
Joined
·
12,914 Posts
Discussion Starter · #7 ·
My new AMD Fury X and Windows 10 upgrade have recently fixed this completely.

My black levels on the PC are now fantastic! Not sure what specifically fixed it - since I don't have the 670 card anymore and upgraded to windows 10 about the same time as acquiring the Fury X --- but this long standing problem is resolved.
 

·
Registered
Joined
·
3,127 Posts
NVIDIA defaults to 16-235 for video playback for some reason.
That setting should always be at 0-255 no matter what your display is. It's a video decoder setting, not the HDMI output level setting.
It's in the advanced section of the "adjust video color settings" section of the control panel.
 

·
Registered
Joined
·
12,914 Posts
Discussion Starter · #9 ·
That never really worked for me. I fixed it by going to AMD. My previous card I bought in the fall fixed it - the AMD 285 and my current card the Fury X looks every bit as good as bluray played off a PS4.

I never got the image quality I wanted off the nvidia cards I've had in the past. 0-255 on the Nvidia cards just made everything darker. I don't want everything darker - just the blacks need to be black and not gray. AMD looks perfect with no futzing around.
 

·
Registered
Joined
·
7,909 Posts
NVIDIA defaults to 16-235 for video playback for some reason.
That setting should always be at 0-255 no matter what your display is. It's a video decoder setting, not the HDMI output level setting.
It's in the advanced section of the "adjust video color settings" section of the control panel.
That's not true. The output from the playback device and the playback device (TV) should match. All of my devices are set to limited (16-235) with D-Nice calibration, and look amazing.
 

·
Registered
Joined
·
3,127 Posts
That's not true. The output from the playback device and the playback device (TV) should match. All of my devices are set to limited (16-235) with D-Nice calibration, and look amazing.
I think you're misunderstanding the situation here.
There are two places you can set the levels: the video card output, and the video decoder output.
The video card output is where you should set whether the output is 16-235 or 0-255 to match your display.
The video decoder should always be set to 0-255.

If the video decoder is set to 16-235, the video card is set to 0-255, and the display is set for 0-255, you end up with a washed-out image on the display since the video is played back at 16-235 instead of 0-255.
If the video decoder is set to 16-235, the video card is set to 16-235, and the display is set for 16-235, you end up with a washed-out image on the display because the levels end up compressed to 30-218 instead of 16-235.

Whether your display expects a 16-235 or 0-255 signal, the video decoder should always be set to 0-255.
 

·
Registered
Joined
·
12,914 Posts
Discussion Starter · #14 · (Edited)
I think you're misunderstanding the situation here.
There are two places you can set the levels: the video card output, and the video decoder output.
The video card output is where you should set whether the output is 16-235 or 0-255 to match your display.
The video decoder should always be set to 0-255.

If the video decoder is set to 16-235, the video card is set to 0-255, and the display is set for 0-255, you end up with a washed-out image on the display since the video is played back at 16-235 instead of 0-255.
If the video decoder is set to 16-235, the video card is set to 16-235, and the display is set for 16-235, you end up with a washed-out image on the display because the levels end up compressed to 30-218 instead of 16-235.

Whether your display expects a 16-235 or 0-255 signal, the video decoder should always be set to 0-255.

My experience in the past is that with NVidia cards (even with my current 1080TI) it's either washed out when I set the PC NVidia's driver to 16-255 and the Pansonic AE-8000U projector to the same limited 16-255, or the blacks are crushed (too dark and loss of detail) with 0-255 set on both. If I use the PS3 video playback as the judge on the physical bluray, and then compare it to a ripped copy of that bluray that is 1:1 played from the HTPC - the NVidia cards do NOT look at good for black level contrast. Ever...

The AMD cards look identical to the PS3 bluray playback contrast level without any adjustment. (well J-River's madvr codec implementation makes the actual picture quality even better!)


My current setup is a 1080TI -> Denon AVR X7200WA -> Panasonic AE-8000U projector at 1080P - and I'm back to this same dang problem after leaving AMD cards for more performance with the NVidia cards. It annoys me to the point I don't even use my projector from the HTPC anymore.

I read the linked above article that acts like it's just fixed with 0-255, but I've never been able to replicate the default quality of AMD cards with my various NVidia cards and messing around with it. And I don't want AMD for gaming right now - because I have a nice G-Sync monitor and Nvidia's simply better for gaming with their drivers and tech and stability, and anyone who tells you otherwise is just not being square.


My video card progression in the last 4-5 years on my personal machine:
Nvidia GTX 560TI
Nvidia GTX 670
AMD 285
AMD Fury X
AMD Radeon
NVidia GTX 1080TI

I'll try again with the tips the article suggests, but the one thing I hadn't considered is my media player might have a bearing on it. I use J-River for HTPC - anyone have any idea where that setting is in J-River? I suspect that's not my problem because I can even see the contrast lacking or too crushed on just he desktop with the 1080TI. Perhaps it's just my particular AVR/Projector combo... But I started this thread with a different projector and AVR combo and the exact same problem has bugged me with NVidia cards for almost a decade now.

@desertdome
 
1 - 14 of 14 Posts
Top