AVS Forum banner

2721 - 2740 of 2922 Posts

·
Registered
Joined
·
1,064 Posts
Officially an anthem owner. Not to knit pick these package has been thru some turbulent times. I can stick my finger in the hole and can clearly see and touch the processor. I do not feel any styrofoam at all. Hope its all good inside. My 5 channel MCA arrives at the end of the week, hope it is in better shape than this. Would you guys open this or take it back . Its hammered pretty good on the other side as well. I am not blaming Anthem ( should there not be styrofoam protecting it on all sides.
It’s basically suspended in the center of the box by a foam cage. Whether or not it should be fully surrounded is a debate. It should also be wrapped in plastic, you shouldn’t be able to touch the unit through the hole.

Right now that impact hit an air gap and wouldn’t have transferred force. If foam were there, it would be less damage to the box due to foam reinforcement, but it could also transfer the force to the unit to a degree as it is behind and reinforcing the foam.

This is probably better for mild to medium bumps. At some amount of force though the box would crumple too far and the impact would hit the unit directly.
 

·
Registered
Martin logan, Anthem
Joined
·
15 Posts
I just downloaded and started down the rabbit whole of rew. Figure I might as well align my subs myself instead of waiting on anthem.
Did a quick measurement, then decided to turn arc off and then remeasure. Measurement was 100% the same. I thought the arc not turning off bug was fixed. I cycled arc on/off and switched inputs. I can get the arc light to cycle on/off, but no change to speaker responce.
Is this still an issue for everyone else?
 

·
Registered
Joined
·
248 Posts
It’s basically suspended in the center of the box by a foam cage. Whether or not it should be fully surrounded is a debate. It should also be wrapped in plastic, you shouldn’t be able to touch the unit through the hole.

Right now that impact hit an air gap and wouldn’t have transferred force. If foam were there, it would be less damage to the box due to foam reinforcement, but it could also transfer the force to the unit to a degree as it is behind and reinforcing the foam.

This is probably better for mild to medium bumps. At some amount of force though the box would crumple too far and the impact would hit the unit directly.
Thanks for the explanation, there is no plastic that I can feel. Have to take risks just that anything at this price is usually double boxed.
 

·
Registered
Anthem AVM 70, LG 55C7, NAD M27, Apple TV 4K, Auralic Altair G1, OPPO UDP-203, MA Gold, PC13-Ultra
Joined
·
756 Posts
Discussion Starter · #2,724 ·
Thanks for the explanation, there is no plastic that I can feel. Have to take risks just that anything at this price is usually double boxed.
Did it come from your dealer like that?
 

·
Registered
Joined
·
16 Posts
Well finally.....AVM70 hits Australian shores!!

Had a call from my dealer today. They are in the country and expected to arrive late today or early tomorrow!!

Already blocked out my diary for the 30 min trip from office to dealer on my lunch tomorrow 😁

Let’s see what the difference is stepping up from my Yamaha CX-A5200 to the AVM70. Expecting great things!
 

·
Registered
Joined
·
248 Posts
That's disappointing, hopefully they will remember that's how it was treated if you ever have any issues with it.
I think I should take it back and show it to them. Just my luck with receivers. Anthem should double box every thing. Now that I have given more thought. I have sent an email to Anthem just moments ago and lets see how this progresses. There is a gash on the other side as well, and another hole on top. I like upgrading my equipment all the time, it would bother me to send a box like this to a potential buyer in the future.
 

·
Registered
Joined
·
131 Posts
still having sound issues. transformers 4k disk only the rear heights were playing. display was showing ATMOS fine i thought something was missing so i killed off my 5-channel amp powering my mains and only the rear heights were running.

i seem to only get ATMOS through Apple4K box for my streaming services. but even that seems hit or miss.
 

·
Registered
Joined
·
248 Posts
Just an update from my previous post. I received an email from Anthem this morning, with a direct line to one of the managers there. He spent a lot of time with me on the phone and resolved my speaker issues as well. Great service from Anthem.
 

·
Registered
Joined
·
14 Posts
Ordered an AVM70 through Crutchfield a couple weeks ago with expected ship date of 4/5/21...which was then changed yesterday to "unknown". Anyone else having any luck with Crutchfield?
 

·
Registered
Joined
·
557 Posts
still having sound issues. transformers 4k disk only the rear heights were playing. display was showing ATMOS fine i thought something was missing so i killed off my 5-channel amp powering my mains and only the rear heights were running.

i seem to only get ATMOS through Apple4K box for my streaming services. but even that seems hit or miss.
You’re talking about the first Bay Transformers movie right? I had a weird sound issue with this one a few weeks ago. Ended up restarting my bluray player and it was fine. But of all the discs I’ve thrown at the AVM70 this is the only one to act up.
 

·
Registered
Joined
·
38 Posts
Well my AVM 70 is sold and shipped. I realized I would never add 4 more speakers, or even 2 for that matter so I figured I'd try something else. Arcam fmj 860 should be here a few days, now I get to play with dirac live. Thanks for all the good info!
 

·
Registered
LG C6 / Anthem AVM 70 / Oppo UDP-203 / Focal Aria 936 / Monolith 5x / Outlaw 5000
Joined
·
11 Posts
Just received my avm70 this last Friday and really happy coming from denon. Any recommendations concerning RCA vs XLR?
I don’t have any long runs but I have one amp that only has RCA so also wondering if mixing xlr with rca is ok.
 

·
Registered
Joined
·
557 Posts
Just received my avm70 this last Friday and really happy coming from denon. Any recommendations concerning RCA vs XLR?
I don’t have any long runs but I have one amp that only has RCA so also wondering if mixing xlr with rca is ok.
Mixing XLR and RCA is fine. Just note that the XLR connections will be 6db louder but you can even this out via ARC or manual calibration.

I personally prefer XLR even in short runs because the connections are more solid.
 

·
Registered
Joined
·
5,766 Posts
Just received my avm70 this last Friday and really happy coming from denon. Any recommendations concerning RCA vs XLR?
I don’t have any long runs but I have one amp that only has RCA so also wondering if mixing xlr with rca is ok.
definitely dont be using any adapters or converters or anything. just hook up RCA to RCA and XLR to XLR :)
 

·
Registered
Joined
·
131 Posts
You’re talking about the first Bay Transformers movie right? I had a weird sound issue with this one a few weeks ago. Ended up restarting my bluray player and it was fine. But of all the discs I’ve thrown at the AVM70 this is the only one to act up.
yes that's the disk. ok so maybe it's on their end. Will try some more disks tonight.
 

·
Registered
Joined
·
186 Posts
Having issues with hum from the AVM70 and Anthem hasn't responded to any of my e-mails. 15 days and counting :(. They used to reply within a day or two. Anyone having similar issues contacting them?
I have gone thru the usual diagnostics steps and fairly certain the hum is coming from the AVM70.

  • All my components are grounded to the same source. I checked to make sure they were all tight and making good contact.
  • I disconnected all inputs (HDMI, network, subwoofers, triggers, etc..) the hum is still there.
  • I tried putting it on mute, the hum doesn't go away
  • If I disconnect the AVM70 from the amps (XLR) the hum goes away.
  • Tried replacing the XLR with RCA and that didn't help.
The hum is pretty loud. I can hear it during quite sections of content being played.

Anything else I should try?
Sounds like a ground loop issue. Are you using Xfinity or cable tv? If so, try a ground loop isolator. It solved a humming issue i had.
 

·
Registered
Joined
·
157 Posts
Sounds like a ground loop issue. Are you using Xfinity or cable tv? If so, try a ground loop isolator. It solved a humming issue i had.
Thanks! Will give that a try.
 

·
Registered
Joined
·
186 Posts
Thanks! Will give that a try.
So i had Dish Network for years. Got my 70 and all my new av equipment (about 2 months ago). Everything sounded great. Last week i went from Dish to Xfinity, hum through speakers. I did a bunch of reading an posting things here and there.
or

These two seem to be the most popular. I actually purchased both, they both did the job, now i have one as a back up.
 
2721 - 2740 of 2922 Posts
Top