AVS Forum banner

2741 - 2760 of 2922 Posts

·
Registered
Joined
·
157 Posts
Thanks! I don't think my issue is with Xfinity. I did not have the STB connected when the problem started. Also, I am getting the hum even when nothing is connected to the 70. Still trying a few more things while I wait for Anthem to reply.
 

·
Registered
Joined
·
16 Posts
Picked up my AVM70 last night!! I may be one of the first in Australia to get one 😁

The guy at the dealer said I was lucky to get one. Only 30% of total order for the Australian distributor arrived.

Went through connections and setup with no issues. Only thing I had to do was unplug LAN cable and plug back in as it was saying disconnected. Update appeared straight away after that. Takes a while but went through without a hitch.

Set up my inputs, speaker distances and levels. Also got Harmony remote set up really easily.

After initial testing, I’m VERY pleased!! Tested Nvidia shield, 4K player, Apple TV and Bluesound. All worked perfectly and sounded brilliant!!

I’m nervous about doing ARC, especially as I’ve EQd my PB16 Ultra already....

What’s people’s thoughts on Arc vs non Arc? Just don’t want to screw anything up considering the setup went so smoothly.
 

·
Registered
Joined
·
13 Posts
Picked up my AVM70 last night!! I may be one of the first in Australia to get one 😁

The guy at the dealer said I was lucky to get one. Only 30% of total order for the Australian distributor arrived.

Went through connections and setup with no issues. Only thing I had to do was unplug LAN cable and plug back in as it was saying disconnected. Update appeared straight away after that. Takes a while but went through without a hitch.

Set up my inputs, speaker distances and levels. Also got Harmony remote set up really easily.

After initial testing, I’m VERY pleased!! Tested Nvidia shield, 4K player, Apple TV and Bluesound. All worked perfectly and sounded brilliant!!

I’m nervous about doing ARC, especially as I’ve EQd my PB16 Ultra already....

What’s people’s thoughts on Arc vs non Arc? Just don’t want to screw anything up considering the setup went so smoothly.
For some reason ARC works better for me. Have 2 SVS PC-4000, and ARC makes them tighter and removes all rattling and booming. I know ARC doesn't fully support multiple subs properly, but it works for me.
 

·
Registered
Joined
·
16 Posts
For some reason ARC works better for me. Have 2 SVS PC-4000, and ARC makes them tighter and removes all rattling and booming. I know ARC doesn't fully support multiple subs properly, but it works for me.
Ok maybe worth trying then. Any simple tricks to making sure it works smoothly?
 

·
Registered
Joined
·
13 Posts
Ok maybe worth trying then. Any simple tricks to making sure it works smoothly?
not really, just run it. I did set distances before running it. Also, trust the suggestion it gives you for SUB levels. It looked to me that subs level are way too high, but somehow it works. No clipping or rattling in the room.
 

·
Registered
Joined
·
227 Posts
Picked up my AVM70 last night!! I may be one of the first in Australia to get one 😁

The guy at the dealer said I was lucky to get one. Only 30% of total order for the Australian distributor arrived.

Went through connections and setup with no issues. Only thing I had to do was unplug LAN cable and plug back in as it was saying disconnected. Update appeared straight away after that. Takes a while but went through without a hitch.

Set up my inputs, speaker distances and levels. Also got Harmony remote set up really easily.

After initial testing, I’m VERY pleased!! Tested Nvidia shield, 4K player, Apple TV and Bluesound. All worked perfectly and sounded brilliant!!

I’m nervous about doing ARC, especially as I’ve EQd my PB16 Ultra already....

What’s people’s thoughts on Arc vs non Arc? Just don’t want to screw anything up considering the setup went so smoothly.
I’m using the AVM 70 with a PB16 and PB13. I used REW and the MiniDSP to time align and EQ my subs - sounds sublime as does the AVM.

I haven’t even opened up the ARC mic or touched ARC. Until it’s “ready” I’m afraid it will mess things up. Shame as ARC along with the promise of independent dual sub phase and EQ was a major reason for my purchase.

My substantial bug list is annoying but I’m patiently waiting for Anthem to do the right thing and provide a firmware update to address bugs along with the promised ARC functionality. If it didn’t sound so good there is no way I would have stayed the course so long. Hopefully my faith isn’t in vain.
 

·
Registered
Joined
·
16 Posts
I’m using the AVM 70 with a PB16 and PB13. I used REW and the MiniDSP to time align and EQ my subs - sounds sublime as does the AVM.

I haven’t even opened up the ARC mic or touched ARC. Until it’s “ready” I’m afraid it will mess things up. Shame as ARC along with the promise of independent dual sub phase and EQ was a major reason for my purchase.

My substantial bug list is annoying but I’m patiently waiting for Anthem to do the right thing and provide a firmware update to address bugs along with the promised ARC functionality. If it didn’t sound so good there is no way I would have stayed the course so long. Hopefully my faith isn’t in vain.
Thanks for the info. Would you mind sharing your bugs list?

Would a miniDSP be any good for a single PB16 ultra?

I EQd it with REW and the built in PEQ functions, but wondering if I’d get better results with miniDSP...
 

·
Registered
Joined
·
227 Posts
Thanks for the info. Would you mind sharing your bugs list?

Would a miniDSP be any good for a single PB16 ultra?

I EQd it with REW and the built in PEQ functions, but wondering if I’d get better results with miniDSP...
In my opinion the MiniDSP is the only way to go...should provide much more tweak ability and capability even with one sub. REW can provide filter sets which are directly uploadable into the MiniDSP outputs. Plus you can easily use it to load customize preloaded BEQ files (optimized for specific movies) on its inputs making even the most bass anemic movies more fun. Best $200 I spent on my system. Ever.

Here is my bug list. Your mileage may vary.:)

My AVM 70 Bug List (must fix):

-center channel doesn't always play on some content (missing center channel)
-automatically upmixes content to the Atmos ceiling speakers despite selecting "none" in the current and input sound mode (supposed to play the native format without upmixing when “none” is selected
-LFE crossover keeps reverting back to 120 hz no matter how many times it's changed
-Selects the eARC input when receiving any remote power on codes when "CEC Control" is on
-occasional crackling noise/static when selecting speakers in level calibration menu (also some lag between speakers when playing speakers)
-promised ARC with dual, independent sub phase and delay settings is still non-existent

Minor annoyances (nice to fix):

-piercing blue power light Illuminates the entire room and cannot be turned off or dimmed
-difficult to control screen dimming from UI & remote; not intuitive and can't turn both setting and wake to zero (completely off) without fumbling through the UI (for which the volume and dimming are on separate pages); remote doesn't control both dimming modes
-UI needs a dark mode (super annoying and bright to control even with phone)
-both volume and dim settings should be on the same UI page
-the UI needs to keep track of what input is assigned to make remote programming easier (no input numbers are listed in the UI for streaming, bluetooth, phono, analog, etc but are required to switch remotely)
-no real useful manual; not clear what does what even with the revised online version
-limited promised streaming functionality, seems limited to low resolution Chromecast and not sure if they will provide hi-rez options like Tidal, Qobuz, forthcoming Spotify HiFI et.; also no unfolding MQA for Tidal.
 

·
Registered
Joined
·
646 Posts
In my opinion the MiniDSP is the only way to go...should provide much more tweak ability and capability even with one sub. REW can provide filter sets which are directly uploadable into the MiniDSP outputs. Plus you can easily use it to load customize preloaded BEQ files (optimized for specific movies) on its inputs making even the most bass anemic movies more fun. Best $200 I spent on my system. Ever.

Here is my bug list. Your mileage may vary.:)

My AVM 70 Bug List (must fix):

-center channel doesn't always play on some content (missing center channel)
-automatically upmixes content to the Atmos ceiling speakers despite selecting "none" in the current and input sound mode (supposed to play the native format without upmixing when “none” is selected
-LFE crossover keeps reverting back to 120 hz no matter how many times it's changed
-Selects the eARC input when receiving any remote power on codes when "CEC Control" is on
-occasional crackling noise/static when selecting speakers in level calibration menu (also some lag between speakers when playing speakers)
-promised ARC with dual, independent sub phase and delay settings is still non-existent

Minor annoyances (nice to fix):

-piercing blue power light Illuminates the entire room and cannot be turned off or dimmed
-difficult to control screen dimming from UI & remote; not intuitive and can't turn both setting and wake to zero (completely off) without fumbling through the UI (for which the volume and dimming are on separate pages); remote doesn't control both dimming modes
-UI needs a dark mode (super annoying and bright to control even with phone)
-both volume and dim settings should be on the same UI page
-the UI needs to keep track of what input is assigned to make remote programming easier (no input numbers are listed in the UI for streaming, bluetooth, phono, analog, etc but are required to switch remotely)
-no real useful manual; not clear what does what even with the revised online version
-limited promised streaming functionality, seems limited to low resolution Chromecast and not sure if they will provide hi-rez options like Tidal, Qobuz, forthcoming Spotify HiFI et.; also no unfolding MQA for Tidal.
Have you found a work around when the center channel does not work? I have the same problem! Going to try unplugging HDMI and or changing sound modes!

I will add to the list for me at least
- when uploading ARC (windows 10) to 70 it uploads fine, but deletes the "DSP Version" and sets it all to 00000! End result no sound, so you have to reload DSP from USB (have to get it from Anthem)
100% agree on the blue light - and its back lit so you can shade it eiher.
 

·
Registered
Joined
·
646 Posts
In my opinion the MiniDSP is the only way to go...should provide much more tweak ability and capability even with one sub. REW can provide filter sets which are directly uploadable into the MiniDSP outputs. Plus you can easily use it to load customize preloaded BEQ files (optimized for specific movies) on its inputs making even the most bass anemic movies more fun. Best $200 I spent on my system. Ever.

Here is my bug list. Your mileage may vary.:)

My AVM 70 Bug List (must fix):

-center channel doesn't always play on some content (missing center channel)
-automatically upmixes content to the Atmos ceiling speakers despite selecting "none" in the current and input sound mode (supposed to play the native format without upmixing when “none” is selected
-LFE crossover keeps reverting back to 120 hz no matter how many times it's changed
-Selects the eARC input when receiving any remote power on codes when "CEC Control" is on
-occasional crackling noise/static when selecting speakers in level calibration menu (also some lag between speakers when playing speakers)
-promised ARC with dual, independent sub phase and delay settings is still non-existent

Minor annoyances (nice to fix):

-piercing blue power light Illuminates the entire room and cannot be turned off or dimmed
-difficult to control screen dimming from UI & remote; not intuitive and can't turn both setting and wake to zero (completely off) without fumbling through the UI (for which the volume and dimming are on separate pages); remote doesn't control both dimming modes
-UI needs a dark mode (super annoying and bright to control even with phone)
-both volume and dim settings should be on the same UI page
-the UI needs to keep track of what input is assigned to make remote programming easier (no input numbers are listed in the UI for streaming, bluetooth, phono, analog, etc but are required to switch remotely)
-no real useful manual; not clear what does what even with the revised online version
-limited promised streaming functionality, seems limited to low resolution Chromecast and not sure if they will provide hi-rez options like Tidal, Qobuz, forthcoming Spotify HiFI et.; also no unfolding MQA for Tidal.
by the way I sent this list to Anthem!!
 

·
Registered
Joined
·
227 Posts
Have you found a work around when the center channel does not work? I have the same problem! Going to try unplugging HDMI and or changing sound modes!
You can change to a different sound mode and sometimes get the center but currently no solution from Anthem. Believe they are aware of the issue

First time Anthem owner and the complete silence and lack of updates is causing me to re-think my options. Either they are trying to fix everything at once, don’t know how, or don’t care. I know they are busy and challenged with the current times but I’ve received no responses or solutions via email or phone calls with their support. Super disappointing. Will try to be patient a bit longer.
 

·
Registered
Joined
·
646 Posts
You can change to a different sound mode and sometimes get the center but currently no solution from Anthem. Believe they are aware of the issue

First time Anthem owner and the complete silence and lack of updates is causing me to re-think my options. Either they are trying to fix everything at once, don’t know how, or don’t care. I know they are busy and challenged with the current times but I’ve received no responses or solutions via email or phone calls with their support. Super disappointing. Will try to be patient a bit longer.
Ive been a long time Anthem owner (D2v, AVM60 and now 70). There have always been some "issues", most minor with work arounds, and as the product aged there have always been updates etc. I must admit however that I have spent more time on this 70 (and I know what im doing Anthem wise), than should have to be spent! Im hoping for a update soon.
 
  • Like
Reactions: BRAC

·
Registered
Joined
·
227 Posts
I posted this previously but you can purchase some 100% blocking LightDim material (available on Amazon) and, using a standard hole punch, punch a hole through the LightDim material (works best punching from behind to avoid stretching the material) leaving enough surrounding material around the punched out hole to adhere and cover the surrounding area around the power button. Then just fit the punched out hole over the power button and adhere the surrounding material to the AVM around the button.

Blocks nearly all that bright blue light around the power button if you punch a clean hole and carefully fit.
 

·
Registered
Joined
·
131 Posts
i'm also a long time anthem owner. (avm20ii / D2 / MRX310 / now AVM70 when i first got my D2 there were issues, Nick at anthem was great and would send out beta updates all the time, some making things worse, some better. I'd rather wait for a finished non-beta update. i 100% believe they will sort everything out.
 

·
Registered
Joined
·
646 Posts
i'm also a long time anthem owner. (avm20ii / D2 / MRX310 / now AVM70 when i first got my D2 there were issues, Nick at anthem was great and would send out beta updates all the time, some making things worse, some better. I'd rather wait for a finished non-beta update. i 100% believe they will sort everything out.
Yea Nick was great!
 
  • Like
Reactions: Yonettes

·
Registered
Joined
·
35 Posts
@richsto what is the conditions your center channel stops working ? I have not had this issue in the couple weeks I've had my avm70.

I also tested bad boys for life with IMAX DTS.. my subs work fine. Movie is a UHD ripped copy I play through Plex and an odroid c4. But IMAX DTS lights up on the AVM and plays through subs..
 

·
Registered
Joined
·
646 Posts
@richsto what is the conditions your center channel stops working ? I have not had this issue in the couple weeks I've had my avm70.

I also tested bad boys for life with IMAX DTS.. my subs work fine. Movie is a UHD ripped copy I play through Plex and an odroid c4. But IMAX DTS lights up on the AVM and plays through subs..
Just happen again tonight center channel! So, on Dolby Surround, the center channel does not work, if i change to Dolby Digital, the Center works!! Interesting that in the inputs section there is no selection for DD only Dolby Surround!
 

·
Registered
Joined
·
227 Posts
@richsto what is the conditions your center channel stops working ? I have not had this issue in the couple weeks I've had my avm70.

I also tested bad boys for life with IMAX DTS.. my subs work fine. Movie is a UHD ripped copy I play through Plex and an odroid c4. But IMAX DTS lights up on the AVM and plays through subs..
I don't typically have problems with Atmos or DTS mixes on physical media. Most often it occurs on cable or streaming, usually with Dolby Surround/Digital signals. I haven't isolated but certain channels and programming (PBS seems to be a constant problem) seem to not play through the center channel. Have to select one of the alternate sound modes to get the center channel to work. Strange and a bit frustrating but not always consistent.

More frustrating to me is the automatic upmixing of non ATMOS source material to the ceiling speakers. Selecting "none" should play the native format.
 

·
Registered
Joined
·
35 Posts
I don't typically have problems with Atmos or DTS mixes on physical media. Most often it occurs on cable or streaming, usually with Dolby Surround/Digital signals. I haven't isolated but certain channels and programming (PBS seems to be a constant problem) seem to not play through the center channel. Have to select one of the alternate sound modes to get the center channel to work. Strange and a bit frustrating but not always consistent.

More frustrating to me is the automatic upmixing of non ATMOS source material to the ceiling speakers. Selecting "none" should play the native format.
And I'm the opposite. I spent a ton of dough to build, install and power ceiling speakers. I want them playing as often as possible.
I stream from Netflix, Prime and Disney. Haven't had any issues, no cable here though. Will continue to test though.
Thanks for the reply.
 

·
Registered
Joined
·
227 Posts
And I'm the opposite. I spent a ton of dough to build, install and power ceiling speakers. I want them playing as often as possible.
I stream from Netflix, Prime and Disney. Haven't had any issues, no cable here though. Will continue to test though.
Thanks for the reply.
I spent way too much on Atmos speakers myself but the processor should not decide for you to alter the native signal.

Also, my system is complicated enough without having to constantly check that the surround format is correct, that the center channel is playing correctly and having to reset the LFE crossover every time. Combine that with having to flop back and forth between tabs on the UI to turn brightness completely off and check volume levels and it’s several minutes into the movie before all is up and running correctly. Also no way my significant other feels comfortable playing a movie by herself.

Just frustrating...I will quit complaining now. It DOES sound really good (and I’m obsessively critical). :)
 
2741 - 2760 of 2922 Posts
Top