AVS Forum banner

14641 - 14660 of 19971 Posts

·
Registered
Joined
·
317 Posts
man power supply went out on my 5040ub. Check out the replacement they sent me...:eek::eek::mad::rolleyes:
Count me in. I did a get a 6040UB second replacement unit with the same issue as yours! this also failed with less than 180 hrs. Right now running on third RMA unit now every time I switch I offer a small prayer that it doesn't fail on me :rolleyes:


Hope you get a good replacement projector from Epson. It's frustrating to setup everything again so I'm running with default settings for now.


Hope you get a good replacement projector.
 

·
Premium Member
Joined
·
645 Posts
Give it a shot and revert back, it wont hurt. If you still have sync problems, I would start looking at the HDMI settings in your AVR to see if something is off.
Juiced you called it on the head, I had the HDMI I/P scaler on my Marantz enabled...Things are working better now, I must have inadvertently changed the setting when I was in the AV Menu. Thank you kind sir.

Peace and blessings,

Azeke
 
  • Like
Reactions: Uppsalaing

·
Registered
Joined
·
1,137 Posts
#8 is up. (6040) My dealer talked me into giving it another try. NIB it seems, and no immediate issues noticed. Supposedly my dealer talked to the epson "technical director", who told him this one would be all new components and inspected. I'm not sure if "all new" means just "new in the box" as before, or if these have newer replacement components, alleviating past power supply issues. We'll see.
 

·
Banned
Joined
·
1,471 Posts
#8 is up. (6040) My dealer talked me into giving it another try. NIB it seems, and no immediate issues noticed. Supposedly my dealer talked to the epson "technical director", who told him this one would be all new components and inspected. I'm not sure if "all new" means just "new in the box" as before, or if these have newer replacement components, alleviating past power supply issues. We'll see.
The dealer is full of bologna. Epson is not pulling 5040s out of the box, gutting them with new components and then reinserting them into distribution. It's going to come down to your individual unit. Hopefully you get a good one.
 

·
Registered
Joined
·
832 Posts
Juiced you called it on the head, I had the HDMI I/P scaler on my Marantz enabled...Things are working better now, I must have inadvertently changed the setting when I was in the AV Menu. Thank you kind sir.

Peace and blessings,

Azeke
Great news. Using any sort of scaling/video conversion within the AVR will cause issues for sure. Also turning HDMI ARC on in the AVR may have some side effects as well. Glad to hear it is working better for you. I was also wrong on my FW version. I was looking through my files, I have a bunch of different Linker FWs saved on my computer. I havent had time to connect to my Linker. But I may actually be using FW 25 GUI 21. The 21 was the GUI version which I got mixed up with .
 

·
Registered
Epson 5040UB projector, Denon 6300, 7.1.4 setup, M&K THX speakers and SVS subwoofer
Joined
·
3,127 Posts
Hoping a 5050/6050 announced at CEDIA 9/2018 with 18 GB HDMI chipset so no need for Linker/etc.
 

·
Registered
Joined
·
1,137 Posts
The dealer is full of bologna. Epson is not pulling 5040s out of the box, gutting them with new components and then reinserting them into distribution. It's going to come down to your individual unit. Hopefully you get a good one.


Naw, my dealer has been great. Shipped/installed all 7 of my returns, taking pictures and workin through epson support to try and keep me a happy customer, which they have! They just relayed to me what they were told by epson, not trying to convince me of the unit havin brand new sourced components. I suspect as you surmise, that the units are just new, not new sourced.
 

·
Banned
Joined
·
1,471 Posts
Naw, my dealer has been great. Shipped/installed all 7 of my returns, taking pictures and workin through epson support to try and keep me a happy customer, which they have! They just relayed to me what they were told by epson, not trying to convince me of the unit havin brand new sourced components. I suspect as you surmise, that the units are just new, not new sourced.
I commend you for your patience. I would not be a happy customer after 7 warranty replacements. If the problem is not fixed by the time your warranty expires, you will be left with a non-working unit which is not fair to you as the customer. I hope that does not become the case.
 

·
Registered
Joined
·
1,863 Posts
Naw, my dealer has been great. Shipped/installed all 7 of my returns, taking pictures and workin through epson support to try and keep me a happy customer, which they have! They just relayed to me what they were told by epson, not trying to convince me of the unit havin brand new sourced components. I suspect as you surmise, that the units are just new, not new sourced.
You are a good fellow and must be exhausted installing that many projectors,there needs to be a no lemon law on these projectors,sorry your having so much trouble! I'm just waiting for mine to go bad,Im a old [email protected] so its hard for me to install a projector
 

·
Registered
Joined
·
46 Posts
Well, just had another power fail with the projector. This one lasted just over a year. The first power fail was after about 45 days of use and I received a new one from Crutchfield (within their 60day warranty period). This time, this replacement will be a re-furbished from Epson and should be here tomorrow. How have the refurbished ones been for people? Any issues? Will they have the most up to date firmware?
Thanks
 

·
Registered
Joined
·
846 Posts
Well, just had another power fail with the projector. This one lasted just over a year. The first power fail was after about 45 days of use and I received a new one from Crutchfield (within their 60day warranty period). This time, this replacement will be a re-furbished from Epson and should be here tomorrow. How have the refurbished ones been for people? Any issues? Will they have the most up to date firmware?
Thanks
Some refurbs have had issues. My first refurb had a dust blob (which resulted in a fuzzy red spot on the lower left of my screen). The replacement for that unit had some color uniformity issues, but I honestly couldn't see any issues in normal viewing, so I kept that one, and it has been performing well for the past six months or so. I think mine had the latest firmware at the time.

Just make sure to thoroughly check performance in all modes before accepting a refurbished unit. Epson is really good about replacing defective units right away. I had taken photos of the dust blob issue I had to show them the issue, but they took my word for it and shipped me another unit right away.
 

·
Registered
Joined
·
317 Posts
Naw, my dealer has been great. Shipped/installed all 7 of my returns, taking pictures and workin through epson support to try and keep me a happy customer, which they have! They just relayed to me what they were told by epson, not trying to convince me of the unit havin brand new sourced components. I suspect as you surmise, that the units are just new, not new sourced.
Just wow. My dealer told me to deal with Epson directedly for quick response time. 7 returns is one too many hope you get lucky the 8th time. By the time I took down and installed the third one I was done.

I wonder even EPSON bothers with this issues any more. Their service has been great so far, quick replacements by overnight. By not having an option to save the settings to external devices, it's a time consuming process redo the setup again and again. I gave up on calibrating the projector :(
 

·
Registered
Joined
·
317 Posts
Well, just had another power fail with the projector. This one lasted just over a year. The first power fail was after about 45 days of use and I received a new one from Crutchfield (within their 60day warranty period). This time, this replacement will be a re-furbished from Epson and should be here tomorrow. How have the refurbished ones been for people? Any issues? Will they have the most up to date firmware?
Thanks
Oh dear. 12 months and failure :(.


One of my RMA units came with new firmware and a dust blob so it depends on your luck :(
 

·
Registered
Joined
·
317 Posts
Hoping a 5050/6050 announced at CEDIA 9/2018 with 18 GB HDMI chipset so no need for Linker/etc.
Hope they don't transfer the power failure technology. :p
 

·
Registered
Joined
·
317 Posts
#8 is up. (6040) My dealer talked me into giving it another try. NIB it seems, and no immediate issues noticed. Supposedly my dealer talked to the epson "technical director", who told him this one would be all new components and inspected. I'm not sure if "all new" means just "new in the box" as before, or if these have newer replacement components, alleviating past power supply issues. We'll see.

As some avs members say Trust but verify.
Good luck with this projector
 

·
Registered
Joined
·
317 Posts
You are a good fellow and must be exhausted installing that many projectors,there needs to be a no lemon law on these projectors,sorry your having so much trouble! I'm just waiting for mine to go bad,Im a old [email protected] so its hard for me to install a projector
I hope it doesn't go bad for you.
 

·
Registered
Joined
·
62 Posts
HDR on Epson 5040ub in Auto (Bright) Mode

I just upgraded my firmware to 7YL28RMV111. Is this the right firmware load? I have tried to go to Epson.com and the website is offline. I found this from another site. In any case with this firmware, I now have the Auto (Bright) mode for HDR. However I have gone to both Netflix 4K HDR (Jessica Jones) and what used to be HDR in Amazon Prime (Goliath) and not only do they show up SDR in the Projector status under Info but if I force it to go to HDR1, they still have a status of SDR.

Are people able to get HDR to show up when they check the Info on the Epson for any Netflix or Amazon streaming videos?
 

·
Registered
Joined
·
846 Posts
I just upgraded my firmware to 7YL28RMV111. Is this the right firmware load? I have tried to go to Epson.com and the website is offline. I found this from another site. In any case with this firmware, I now have the Auto (Bright) mode for HDR. However I have gone to both Netflix 4K HDR (Jessica Jones) and what used to be HDR in Amazon Prime (Goliath) and not only do they show up SDR in the Projector status under Info but if I force it to go to HDR1, they still have a status of SDR.

Are people able to get HDR to show up when they check the Info on the Epson for any Netflix or Amazon streaming videos?
Are you saying you were previously able to get HDR from Netflix and Amazon? The projector firmware version shouldn't affect whether you receive HDR from these services.

Getting HDR from Netflix with this projector depends on which streaming device you are using. Some devices (like the Roku Premiere+/Ultra) require an HDFury Linker or Vertex to convert the signal to 8-bit. You also can't force the signal coming into the projector to be HDR just by changing that projector setting. The Info menu on the projector always tells you what kind of signal is being received at the projector, regardless of what you have that setting on.
 

·
Registered
Joined
·
62 Posts
Are you saying you were previously able to get HDR from Netflix and Amazon? The projector firmware version shouldn't affect whether you receive HDR from these services.

Getting HDR from Netflix with this projector depends on which streaming device you are using. Some devices (like the Roku Premiere+/Ultra) require an HDFury Linker or Vertex to convert the signal to 8-bit. You also can't force the signal coming into the projector to be HDR just by changing that projector setting. The Info menu on the projector always tells you what kind of signal is being received at the projector, regardless of what you have that setting on.
Thanks for the reply. I thought I was able to previously get HDR from my Roku Ultra that I use to stream Netflix and Amazon. Maybe I just assumed that because the source material said HDR, it was getting though to the projector. However I'm wondering if maybe the Roku has a setting which was changed as I've used it for travel and connecting to other display devices than my 5040UB. I will check on that. I also called Epson and they directed me to the latest firmware so I just upgraded that from the one I found on randomly on the net.
 
14641 - 14660 of 19971 Posts
Top