AVS Forum banner

5421 - 5440 of 5456 Posts

·
Registered
Joined
·
129 Posts
Okay I'm really thinking something is up with my receiver unless I'm really not understanding something with ARC. I'm trying to switch my devices like xbox and playstation to be directly connected to the TV rather than through the receiver and use ARC to get audio back to my receiver. Will be doing this because of the new HDMI 2.1 VRR etc needs and possibly upgrade receiver to do full eARC lossless audio etc but none the less just trying to get this to work today in preparation.

I've tested two TV's (LG CX and Sony 940D) and multiple HDMI cables. Simply I connect up HDMI ARC on the TV's to the Marantz 7012 HDMI Out ARC Monitor 1 Port. A Roku or Xbox plugged into another port on the TV. The TV's seems to detect the receiver hook up as it'll switch from TV audio to External Speaker and I can change the volume of the receiver with any controller but I get no sound. I have HDMI control and ARC on the receiver as you can see my settings image below. Is there something I'm missing or possibly an issue with my receiver? Again I've tried multiple known working HDMI cables and two different TV's now I'm kind of at loss here.

IMG_3453.jpg
 

·
Premium Member
Joined
·
88,992 Posts
Okay I'm really thinking something is up with my receiver unless I'm really not understanding something with ARC. I'm trying to switch my devices like xbox and playstation to be directly connected to the TV rather than through the receiver and use ARC to get audio back to my receiver. Will be doing this because of the new HDMI 2.1 VRR etc needs and possibly upgrade receiver to do full eARC lossless audio etc but none the less just trying to get this to work today in preparation.

I've tested two TV's (LG CX and Sony 940D) and multiple HDMI cables. Simply I connect up HDMI ARC on the TV's to the Marantz 7012 HDMI Out ARC Monitor 1 Port. A Roku or Xbox plugged into another port on the TV. The TV's seems to detect the receiver hook up as it'll switch from TV audio to External Speaker and I can change the volume of the receiver with any controller but I get no sound. I have HDMI control and ARC on the receiver as you can see my settings image below. Is there something I'm missing or possibly an issue with my receiver? Again I've tried multiple known working HDMI cables and two different TV's now I'm kind of at loss here.
Try doing a "soft reset" of the AVR and TV by powering both off and unplugging their respective power cables and the HDMI cable that connects them for 10 minutes. Connect all cables. Power on the TV first. If the AVR is not automatically switching to the "TV Audio" source when it powers ON, then it's apparently not receiving a signal from the TV. The work around would be to connect an optical cable from the TV --> AVR which would at least pass DD/DTS 5.1 but not DD+ nor HD audio.
 

·
Registered
Joined
·
86 Posts
I had problems getting sound through ARC with LG nan90 na sr7012 too (eARC didn't work at all); seems LG's implementation of e/ARC isn't exactly best. I got it working after several restarts, power offs of both the TV and AVR and enabling disabling it in AVR settings and adding and removing the avr in TV settings. Not sure exactly what made it work and after it did, I didn't have any further problems. Since I wasn't happy with the picture quality, I sent the LG back and bought a Sony x900h. Sony did a much better job with ARC, all I needed to do was enable it on the TV and AVR and it works, it even switching automatically between arc (when AVR is turned on) and built in speakers if I turn the AVR off.
 

·
Registered
Joined
·
129 Posts
Well my sony 940d has the same issue cant get it to work period. I ended up ordering a new SR8015 so see this week if that works fine with full eARC. Praying it does then ill just sell my SR7012 and MM7025.

Also did try the soft reset a couple times on both TV’s. No luck ever getting the 7012 to switch to “TV Audio”
 

·
Registered
Joined
·
86 Posts
Is it possible to change the volume steps for the SR7012? My TV doesn't recognize half steps and because I use cec and sony remote to change volume it would be nice if TV and AVR volume could stay in sync.
 

·
Registered
Joined
·
8 Posts
I have the sr5012 and ever since the last few firmware updates when I airplay apple music from iphone or ipad to the sr5012 and i choose to go to next song i get a loud click before the song starts.Very annoying.Only happenes with apple music and not cd or any other streaming device or app. If i listen on iphone or ipad and do not stream it doesn't happen. Has to be something with airplay or airplay2. Any one else have this problem.It has happened on ios 13 and 14. Contacted Marantz about the issue a year or so ago and still no fix. All they tell me is no one has reported this and if it bothers me to downgraed the firmware to original which I end up doing after each firmware update.
Thanks for any insight.
 

·
Premium Member
Joined
·
88,992 Posts
I have the sr5012 and ever since the last few firmware updates when I airplay apple music from iphone or ipad to the sr5012 and i choose to go to next song i get a loud click before the song starts.Very annoying.Only happenes with apple music and not cd or any other streaming device or app. If i listen on iphone or ipad and do not stream it doesn't happen. Has to be something with airplay or airplay2. Any one else have this problem.It has happened on ios 13 and 14. Contacted Marantz about the issue a year or so ago and still no fix. All they tell me is no one has reported this and if it bothers me to downgraed the firmware to original which I end up doing after each firmware update.
Thanks for any insight.
Try doing a Network Reset to see if that resolves the issue ...

3041873
 

·
Registered
Joined
·
8 Posts
Will try that when I get home from work but this morning i did a firmware reset to original firmware and that solves the problem but does not give me airplay2.So will have to reinstall latest firmware.
 

·
Premium Member
Joined
·
88,992 Posts
Will try that when I get home from work but this morning i did a firmware reset to original firmware and that solves the problem but does not give me airplay2.So will have to reinstall latest firmware.
If still no joy after the Network Reset, and if no one responds to your post indicating they are experiencing the same issue, a microprocessor reset would be the next troubleshooting step. And if yet still no joy, you may want to consider purchasing an Apple TV and stream to it instead.
 

·
Registered
Joined
·
8 Posts
I have done a microprocessor reset and it does not solve the issue.I have a apple tv but easier to just pull out my phone and stream from there.I hate the apple tv remote.Thanks for the input.Will give your suggestions a go.
 

·
Registered
Joined
·
8 Posts
I updated firmware. Still get annoying click when going to next song manually on airplay. Reset
Network. No change. Reset microprocessor. No change. Reverting back to original shipped firmware and click is gone. Been dealing with this for a long time so time to move on and maybe get a new avr. Scared to get a another maranantz as I bought the Marantz so I could use AirPlay. I have changed routers and have tried wired and WiFi. Nothing has helped .Thanks for the help and suggestions.
 

·
Premium Member
Joined
·
88,992 Posts
I updated firmware. Still get annoying click when going to next song manually on airplay. Reset
Network. No change. Reset microprocessor. No change. Reverting back to original shipped firmware and click is gone. Been dealing with this for a long time so time to move on and maybe get a new avr. Scared to get a another maranantz as I bought the Marantz so I could use AirPlay. I have changed routers and have tried wired and WiFi. Nothing has helped .Thanks for the help and suggestions.
Contact Marantz with your issue. The AVR has a 3 year warranty from Marantz so you may want to consider warranty repair.
 

·
Registered
Joined
·
132 Posts
Marantz SR6012 owner

I've been having HDMI issues lately. Basically the avr will switch inputs but nothing will appear on the screen unless I rotate the input selector knob several times before it will finally show on the screen. This happens maybe 50% of the time I try switching inputs.

I've already swapped cables with no results and tried to pull up the settings menu when the screen is blank with no results. Has anyone had this problem or is there a fix?

I'd assume factory reset will be a suggestion. Can anyone verify that the SAVE feature does in fact restore all settings including Audyssey EQ settings (distance, levels,etc).

Thanks
 

·
Premium Member
Joined
·
88,992 Posts
Marantz SR6012 owner

I've been having HDMI issues lately. Basically the avr will switch inputs but nothing will appear on the screen unless I rotate the input selector knob several times before it will finally show on the screen. This happens maybe 50% of the time I try switching inputs.

I've already swapped cables with no results and tried to pull up the settings menu when the screen is blank with no results. Has anyone had this problem or is there a fix?

I'd assume factory reset will be a suggestion. Can anyone verify that the SAVE feature does in fact restore all settings including Audyssey EQ settings (distance, levels,etc).

Thanks
Before doing a full microprocessor reset, you can try doing a "soft reset" by simply powering OFF the AVR and unplugging the power cable for 10 minutes resulting in no loss of settings, otherwise, a SAVE does indeed save the Audyssey EQ settings.
 

·
Registered
Joined
·
396 Posts
Marantz SR6012 owner

I've been having HDMI issues lately. Basically the avr will switch inputs but nothing will appear on the screen unless I rotate the input selector knob several times before it will finally show on the screen. This happens maybe 50% of the time I try switching inputs.

I've already swapped cables with no results and tried to pull up the settings menu when the screen is blank with no results. Has anyone had this problem or is there a fix?

I'd assume factory reset will be a suggestion. Can anyone verify that the SAVE feature does in fact restore all settings including Audyssey EQ settings (distance, levels,etc).

Thanks
I had a similar issue several weeks ago. if the a 1080 source was selected and then AVR turned on, I had a picture. If I changed to a 4K source, blank screen. I tried everything short of a microprocessor reset. I finally let the unit install the latest firmware, and that solved the issue. I also updated the firmware on my TV at the same time.
 

·
Registered
Joined
·
2,645 Posts
I was thinking of possibly bi amping my front (lf and rf)speakers. Wondering if anyone has done this with the sr7012 if resulted with any real benefit.. also if do bi amp is it necessary to
Re run audessy.. thanks


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15,943 Posts
Bi-amping (the variety discussed in consumer audio properly called "passive bi-amping") is worthless.

Active bi-amping is an entirely different thing, but the Marantz doesn't offer it for the main speakers so it is off topic.
 
5421 - 5440 of 5456 Posts
Top