AVS Forum banner

41 - 60 of 962 Posts

·
Registered
Joined
·
78 Posts
Hi, I just purchased a Pioneer LX503 and have been trying to get Dolby Atmos to work via ATV 4K. Unfortunately, all Dolby streams result in no sound being processed.
I've checked all the settings and updated all devices, unplugged the HDMI cables, but nothing seems to work. I am able to run Atmos through the receiver from the Xbox without any problems. Has anyone been able to get Atmos to stream through the TVos12 ATV 4K on this receiver yet? If not, I'm wondering if it will require a firmware update from Pioneer to work properly.
This is the exact same thing that is happening to me word for word. Hooked the same Apple TV 4K up in my bedroom to my pioneer vsxlx301 and it fires up Dolby Atmos as it should. Changed wires, inputs, downloaded all available firmwares/updates and the problem still persists. The receiver will show an input of 2.1 pcm on the 503 while not playing a sound while in a movie that is coded for Atmos. Non Atmos movies play sound normally. The only way to get Atmos codes movies to play now is to turn Atmos off within the atv4k menu and then it will input a 7.1 pcm signal to the 503. On the 301, all functions as intended and input shows 5.2.2 and an output of 5.2.2. Trying to decide if I should give up on this 503 and return, but limited on 9.2 in the $1k range.
 

·
Registered
Joined
·
7 Posts
This is the exact same thing that is happening to me word for word. Hooked the same Apple TV 4K up in my bedroom to my pioneer vsxlx301 and it fires up Dolby Atmos as it should. Changed wires, inputs, downloaded all available firmwares/updates and the problem still persists. The receiver will show an input of 2.1 pcm on the 503 while not playing a sound while in a movie that is coded for Atmos. Non Atmos movies play sound normally. The only way to get Atmos codes movies to play now is to turn Atmos off within the atv4k menu and then it will input a 7.1 pcm signal to the 503. On the 301, all functions as intended and input shows 5.2.2 and an output of 5.2.2. Trying to decide if I should give up on this 503 and return, but limited on 9.2 in the $1k range.
I have contacted Pioneer and am hoping they can track down the cause. So far, no luck but will let you know what I find out. Would encourage you to do the same as they initially were stating that this issue must be with the ATV 4K.
 

·
Registered
Joined
·
78 Posts
It is most definitely not an issue with Apple. I have two atv4k units. Both work flawlessly on the 301, not so much with the 503. You wouldn’t think a new format would work with an older receiver and not on the brand new unit.
 

·
Registered
Joined
·
78 Posts
Just got off the phone with pioneer. Of course not being home in front of the devices, he couldn’t “help” me diagnose the issue. However, I can clearly see they are going to blame Apple right now. It is clearly not an Apple problem for my situation.
 

·
Registered
Joined
·
78 Posts
As of 7:30 pm yesterday, they claim they have had multiple calls regarding this issue and assured me that they are in fact working on a solution. Of course they are blaming Apple for the communication error between the devices. Apples software works perfectly fine with a 301 from 2017. I wonder if this years denons are having issues. Might have to swap it out and try a different brand.
 

·
Registered
Joined
·
7 Posts
As of 7:30 pm yesterday, they claim they have had multiple calls regarding this issue and assured me that they are in fact working on a solution. Of course they are blaming Apple for the communication error between the devices. Apples software works perfectly fine with a 301 from 2017. I wonder if this years denons are having issues. Might have to swap it out and try a different brand.
Seems like they should be able to get an ATV and hook it up to see for themselves. Its good to hear that they are working on it. I'll try calling them again next week and see where things stand and to keep up the pressure for a solution.
 

·
Registered
Joined
·
78 Posts
Seems like they should be able to get an ATV and hook it up to see for themselves. Its good to hear that they are working on it. I'll try calling them again next week and see where things stand and to keep up the pressure for a solution.[/QUOTE]

Have you been having any luck using arc? Mine worked until I updated to the current firmware on the 503 and now I can’t get my tv to communicate with it anymore.
 

·
Registered
Joined
·
5 Posts
Hey Guys!

I've been a headphone guy pretty much all my life and I'm recently branching out to home theater/music setups. Thinking about picking up either a Marantz SR5013 or this Pioneer LX503. I'll be looking to drive a pair of Kef Q350's, mostly for music via streaming and CD.

I'm leaning towards the Pioneer due to the Chromecast being built in (heavily invested into Google products), but I seem to find that most prefer the Marantz for music and Pioneer for movies.

Anyone willing to persuade me towards the Pioneer? I've been reading through numerous threads, regarding MCAAC and no more class D amps being used. MCAAC doesn't seem to be that big of a deal, as I can adjust to my liking, but for those long term Pioneer users... are the lack of D amps causing that much of a difference?

I just can't seem to find too much information, reviews, etc. on the LX503 (plenty on the LX502 though).

Will I be satisfied with either for music? Am I overthinking it here?

Thanks in advance! :D
 

·
Registered
Joined
·
78 Posts
Well, yesterday I made the choice to return the 503 and picked up a Denon avrz4500h. Of course it was not in the same price range, but it does in fact work with the Apple tv4k.
 

·
Registered
Joined
·
5 Posts
Well, yesterday I made the choice to return the 503 and picked up a Denon avrz4500h. Of course it was not in the same price range, but it does in fact work with the Apple tv4k.
Outside of the issues with the Apple devices, any other reason why you made the jump? If you don't mind me asking.
 

·
Registered
Joined
·
78 Posts
Well, yesterday I made the choice to return the 503 and picked up a Denon avrz4500h. Of course it was not in the same price range, but it does in fact work with the Apple tv4k.
Outside of the issues with the Apple devices, any other reason why you made the jump? If you don't mind me asking.
I was also having issues with arc also, which was not the fault of the 503. I was pleased with the 503 outside of the Apple issue. I do feel that the Denon has better sound, but that could just be that I want to believe it was worth the extra cost. Doubtful that it was, but the Denon does have IMAX, lol!!!
 

·
Registered
Joined
·
7 Posts
I was also having issues with arc also, which was not the fault of the 503. I was pleased with the 503 outside of the Apple issue. I do feel that the Denon has better sound, but that could just be that I want to believe it was worth the extra cost. Doubtful that it was, but the Denon does have IMAX, lol!!!
Fsuhammond, after spending a bunch of time with the Pioneer folks, we were unable to resolve things. They believed it was an issue with the ATV. Finally gave up and returned the 503 yesterday. Got a great deal on a Marantz 7012, works awesome.
 

·
Registered
Joined
·
78 Posts
I was also having issues with arc also, which was not the fault of the 503. I was pleased with the 503 outside of the Apple issue. I do feel that the Denon has better sound, but that could just be that I want to believe it was worth the extra cost. Doubtful that it was, but the Denon does have IMAX, lol!!!
Fsuhammond, after spending a bunch of time with the Pioneer folks, we were unable to resolve things. They believed it was an issue with the ATV. Finally gave up and returned the 503 yesterday. Got a great deal on a Marantz 7012, works awesome.
I’m willing to bet that you changed nothing within the atv settings and just connected to the Marantz and it worked properly. Is that about right?
 

·
Registered
Joined
·
7 Posts
I’m willing to bet that you changed nothing within the atv settings and just connected to the Marantz and it worked properly. Is that about right?
Yep, no changes on the ATV side. Worked as expected with the Marantz. Pioneer said they tested it with the 501 and 303, both worked with the ATV, but I still had no luck. I've moved on and really happy with the Marantz.
 

·
Registered
Joined
·
78 Posts
I’m willing to bet that you changed nothing within the atv settings and just connected to the Marantz and it worked properly. Is that about right?
Yep, no changes on the ATV side. Worked as expected with the Marantz. Pioneer said they tested it with the 501 and 303, both worked with the ATV, but I still had no luck. I've moved on and really happy with the Marantz.
Glad you found a solution to your issue also. Just sucks because I’m really happy with my old 301 and wanted to stick with pioneer again, but that’s just the way it works sometimes.
 

·
Registered
Joined
·
113 Posts
Fsuhammond, after spending a bunch of time with the Pioneer folks, we were unable to resolve things. They believed it was an issue with the ATV. Finally gave up and returned the 503 yesterday. Got a great deal on a Marantz 7012, works awesome.
Thanks for posting this. I'm shopping for my first Atmos receiver, and the 303 and 503 were at the top of my list because I can get a really good price on them through work. But I'm buying to get Atmos, and if it doesn't work with one of my main sources that is a deal breaker.

I'm wondering if the Onkyo models have the same issue, as they are basically the same under the hood? Looks like Denon and Marantz will shift to the top of my list. They are more expensive in NZ, and I can't get a better discount by buying through work, but at least they work.
 

·
Registered
Joined
·
3 Posts
LX503 7.1.4 with external amps

I am looking to replace my VSX-33 with the VSX-LX503. Page 55 of the manual indicates that by using a 2 channel external amp for the for the back surrounds you can connect 2 pairs of height speakers for 7.1.4 sound. I would just like to confirm this and also confirm that I can actually use 7 channels of external power (pre-outs) for the L/C/R and LS/RS and Back LS/RS and then connect the 4 ceiling speakers directly to the LX503 for 7.1.4.

Has anyone done this to confirm?

An Onkyo representative indicated that this can’t be done and that I would need the SC-LX801 for 11 channel processing. Even though page 55 of the manual say 7.1.4 is possible and the AVR description says “By adding an external amplifier, the 9.2ch AV receiver can be expanded to decode 11ch to drive the 7.2.4ch configuration of the latest theater sound platform, Dolby Atmos®.”

Thanks
 

·
Registered
Joined
·
2,572 Posts
@sgrosz I read the same thing in another Pioneer based thread, but bottom line, the lx303/503 are 9.2 channels max so you cannot add an external amp for 2 more channels. The Denon x4400 and maybe sister Marantz SR6012 are the only two receivers that I know that have 9 channels but can expand to 11.2 with an external amp. I don't own either of those, so someone who owns one might be able to confirm 100%.
 

·
Registered
Joined
·
3 Posts
Eriksells916, thanks for the response. I did purchase the LX503 last week along with 4 Polk Audio MC60’s and completed the install. (11 hours to install 4 ceiling speakers 😊 ). The LX503 does in fact expand to 7.1.4 with the addition of external amps.

I have an Emotiva XPA-3 for my L/C/R and an Emotiva UPA-500 for my LS/RS/BLS/BRS both connected to the pre-outs on the LX503. I then have 4 MC60’s connected directly to the Height 1 and Height 2 speaker connections on the LX503. Running MCACC, the AVR recognizes 11 independent channels.

I have watched Solo, Ant-man and the Wasp, Infinity War, Spiderman: Homecoming, Black Panther and several episodes of Westworld and they sound amazing. Westworld and Spiderman are particularly incredible.

Just FYI for anyone else wanting to give this setup a try.

Thanks
 
41 - 60 of 962 Posts
Top