AVS Forum banner

1021 - 1040 of 1205 Posts

·
Registered
Joined
·
820 Posts
Discussion Starter #1,021
My REL Stadium III have been in the shop for 5 months. REL no longer supports this legacy product! They have left me out in the cold. I have the Stadium at Ft. Worth Audio and they are now having a hard time finding some FET Output Devices. We need 2 each of Exicon 20N20 and Exicon 20P16. Evidently these are from England. Anyone know of a good source for parts for subwoofers here in the USA? Thanks
Were you able to get anything done on this?
 

·
Registered
Joined
·
559 Posts
Anyone here has their Rel subwoofer connected to a Nad avr through high level input?


Thanks.
 

·
Registered
Joined
·
559 Posts
Hi,
Not sure if necessary, but the LFE cable ground wire is connected to the receiver screw and the rel ground screw.
Hi,

good u solved the issue, my room is almost ready & plan to add another Rel to my setup which has the Nad t758 v3.

Wondering if connecting only the high level input from the Rel to the Nad with the Primary way mentioned by Rel will give me a hum?

Or do i have to use an LFE cable like you are using with a ground wire? the audio quest one? if you disconnect your LFE cable from your setup do you get a HUM?

Let me know as i m paranoid if i should order another subwoofer cable or not.


Thanks a ton.
 

·
Registered
Joined
·
113 Posts
Hi,

good u solved the issue, my room is almost ready & plan to add another Rel to my setup which has the Nad t758 v3.

Wondering if connecting only the high level input from the Rel to the Nad with the Primary way mentioned by Rel will give me a hum?

Or do i have to use an LFE cable like you are using with a ground wire? the audio quest one? if you disconnect your LFE cable from your setup do you get a HUM?

Let me know as i m paranoid if i should order another subwoofer cable or not.


Thanks a ton.
No hum for me!
 

·
Registered
Joined
·
95 Posts
Complicated! :frown:

High-Level connection! But to AMP!
How do you like the center/ sub combination to create a full range center? How did you set the crossover and levels to get a (I hope) seamless match? Do you intend to use the same technique for your mains as well?

I’ve been thinking about trying this with my center as a possible first step to making the change across the board.
 

·
Registered
Joined
·
1,117 Posts
Hi,



good u solved the issue, my room is almost ready & plan to add another Rel to my setup which has the Nad t758 v3.



Wondering if connecting only the high level input from the Rel to the Nad with the Primary way mentioned by Rel will give me a hum?



Or do i have to use an LFE cable like you are using with a ground wire? the audio quest one? if you disconnect your LFE cable from your setup do you get a HUM?



Let me know as i m paranoid if i should order another subwoofer cable or not.





Thanks a ton.


Not sure. I know that since it is for movies and music I have both LFE and high level connected.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15 Posts
Hi,

good u solved the issue, my room is almost ready & plan to add another Rel to my setup which has the Nad t758 v3.

Wondering if connecting only the high level input from the Rel to the Nad with the Primary way mentioned by Rel will give me a hum?

Or do i have to use an LFE cable like you are using with a ground wire? the audio quest one? if you disconnect your LFE cable from your setup do you get a HUM?

Let me know as i m paranoid if i should order another subwoofer cable or not.


Thanks a ton.
FWIW, I have my REL connected to an integrated amp via high level connection with the black wire going to ground on the amp. I also have an LFE cable connected to my AV receiver but left the ground wire disconnected. I have no hum for my system and I also use an audioquest LFE cable. Its possible you may introduce a ground loop if you just connect the LFE cable as the outer ring of the LFE cable may be grounded. if you do get a hum, I would then just disconnect the high level black wire to signal ground.
 

·
Registered
Joined
·
32 Posts
I'd be interested to hear one of the HT1508's for theatre stuff next to my 212SE...although looking at the specs it seems like the 212 still plays lower. For the price though, the 1508 seems pretty decent! If I've read correctly, though, it wouldn't be very great for a 2ch/HT combo setup as it doesn't have the Neutrik connector to run the high-level input for 2ch?
 

·
Registered
Joined
·
10 Posts
Hi Guys... need some advice...

I’ve had a T9i for several months now.. to go along with my B&W 703s2. Love the set up. The sub is so sweet but I always wanted to “upgrade” to the S/3 SHO.. since it goes down much deeper -6db 22HZ.. and has a 400w amp vs the 350w of the T9i..

I have now gone through 2x S/3s (bought one and returned it cause I though it was bad)

I have been doing a ton.. I mean a ton of research.. and I am very disappointed in the S/3.

I honestly thought it was going to be a huge improvement from the T9i.. I mean it’s almost 2x the price.

The sub is hardly audible... it is extremely weak!! I went through the entire process of breaking in over 3-4 days.. followed RELs instructions and I can hardly even tell it’s there.. it sounds flat, no depth at all.

Even in HT mode, watching movies... it’s weak, I had to plug the T9i back cause it was not enjoyable.

The T9i have is much much louder and deeper... both are hooked up the same and I have to turn the gain on the S3 to 100% and still not that loud... the t9i is set at 45% and I have to turn it down sometimes cause it’s so loud.

Anyone else think their S3s lack volume levels?
 

·
Registered
Joined
·
820 Posts
Discussion Starter #1,033
It sounds like a phase issue. When it's playing, are the cones moving, especially at high volume? Is it placed in the same spot as your T9i?
 

·
Registered
Joined
·
50 Posts
Hey all. I will be getting a pair of Monitor Audio PL100's or a pair of dynaudio special 40's which will be in a room which is 11'5ft x 16'6ft and the ceilings are 7'10ft. This gives me a total area of 189 sq ft and a total volume of approx 1480 cubed ft. Using the rel subwoofer finder it suggests an s/3 SHO sub. I am under the impressions that this sub will overload my room and cause problems due to its output. Can you please confirm if I should indeed buy the s/3 SHO or instead go with a pair of smaller subs such as the t5i or t7i? My system is 100% music and I am only concerned about musical integration between the subs and the mains. Thanks for the insight.
 

·
Registered
Joined
·
559 Posts
Hey all. I will be getting a pair of Monitor Audio PL100's or a pair of dynaudio special 40's which will be in a room which is 11'5ft x 16'6ft and the ceilings are 7'10ft. This gives me a total area of 189 sq ft and a total volume of approx 1480 cubed ft. Using the rel subwoofer finder it suggests an s/3 SHO sub. I am under the impressions that this sub will overload my room and cause problems due to its output. Can you please confirm if I should indeed buy the s/3 SHO or instead go with a pair of smaller subs such as the t5i or t7i? My system is 100% music and I am only concerned about musical integration between the subs and the mains. Thanks for the insight.
dual subs is always better, best is to shoot a mail to REL Customer Care & they will be the right people to guide you & clear your thoughts .They are indeed very helpful.

Cheers.
 

·
Registered
Joined
·
50 Posts
dual subs is always better, best is to shoot a mail to REL Customer Care & they will be the right people to guide you & clear your thoughts .They are indeed very helpful.

Cheers.
Just sent them off an email. Thanks!
 

·
Registered
Joined
·
10 Posts
It sounds like a phase issue. When it's playing, are the cones moving, especially at high volume? Is it placed in the same spot as your T9i?
Yes Sir, exact same spot and even tried positioning it in opposite corners. Played with the different phase settings and then even turned on auto phasing (had it previously off) on my AVR. No change.

Yes the cone moves but not that much.. after several more days of “breaking in”.. it’s gotten a little better.. but still not any where close to the output level of my t9i.

It’s so weird.. I can’t seem to figure out if I’m doung something wrong or it it’s meant to be like this.

As I mentioned, if I swap out the S/3 with the T9i and make no tweaks and use the exact same cables, exact same set up.. the t9i is 2x more output.
 

·
Registered
Joined
·
37 Posts
One thing I'm surprised by is the lack of comparative reviews to other manufacturers.

I mean, has anyone compared to the REL T5i to popular sealed subs like the SVS SB1000? Or the T7i / T9i to the SB3000?

Both have good returns policies, so I guess I could try both. And see if the SVS is HUGELY better for HT and if the REL is HUGELY better for music.

I get the sense that REL owners only consider REL. And that most of "the home theater internet" thinks REL must be overpriced based on specs, and therefore not worth considering for music or movies.

Both views are short sighted in my opinion. All OEMs deserve an unbiased comparison.
 

·
Registered
Joined
·
1,291 Posts
One thing I'm surprised by is the lack of comparative reviews to other manufacturers.

I mean, has anyone compared to the REL T5i to popular sealed subs like the SVS SB1000? Or the T7i / T9i to the SB3000?

Both have good returns policies, so I guess I could try both. And see if the SVS is HUGELY better for HT and if the REL is HUGELY better for music.

I get the sense that REL owners only consider REL. And that most of "the home theater internet" thinks REL must be overpriced based on specs, and therefore not worth considering for music or movies.

Both views are short sighted in my opinion. All OEMs deserve an unbiased comparison.
The fact of the matter is that they are way overpriced compared to other ID subs and not to mention, are far outclassed. It is a head scratcher to me.
 
1021 - 1040 of 1205 Posts
Top