AVS Forum banner

4041 - 4060 of 4117 Posts

·
Registered
Joined
·
3 Posts
guys so i just got the lg c9 and i have this bluray player but every time i load saving private ryan on a UHD 4k disk in this bluray player i just get a black picture. Also it glitches every time i try and view netlfix and youtube because it loads dolby vision on those apps as well and not sure why. I have tried everything myself and even went and bought high quality hdmi cables that cost me allot. Im fair fed up with it and was wondering if anyone has the pre dolby vision firmware for this bluray player as i cant find it anywhere on the net at all. I can watch all my other blurays and UHD discs without issues its only the dolby vision ones so i have given up watch dobly vision content at all on this player. Is there a solution? Or should i just sell the bloody thing all together and get something different?
 

·
Registered
Joined
·
35 Posts
These 'old' BR players are facing expired licenses and not to mention streaming is now the dominant format for 4k/hdr viewing.
 

·
Registered
Joined
·
2,734 Posts
guys so i just got the lg c9 and i have this bluray player but every time i load saving private ryan on a UHD 4k disk in this bluray player i just get a black picture. Also it glitches every time i try and view netlfix and youtube because it loads dolby vision on those apps as well and not sure why. I have tried everything myself and even went and bought high quality hdmi cables that cost me allot. Im fair fed up with it and was wondering if anyone has the pre dolby vision firmware for this bluray player as i cant find it anywhere on the net at all. I can watch all my other blurays and UHD discs without issues its only the dolby vision ones so i have given up watch dobly vision content at all on this player. Is there a solution? Or should i just sell the bloody thing all together and get something different?

You need to turn off DV in the X700 settings menu.

Cost of a cable doesn't indicate it's ability to pass 4K HDR signals. Also there may be other devices, such as a receiver, that's causing the problem.
 

·
Registered
Joined
·
440 Posts
Okay, I'm about done with Netflix on this player. I will get into netflix and within moments of scrolling through the menu or trying to search the display just goes dark and wash, rinse, and repeat for up to 5 minutes. This behavior does not occur while using Vudu or Prime, just Netflix.

The Netflix also does not do this when playing from the TV's onboard app.

This is incredibly frustrating. Any others experiencing this? It doesn't resolve when I power cycle the player and the app appears to be up to date.
 

·
Registered
Joined
·
3 Posts
You need to turn off DV in the X700 settings menu.

Cost of a cable doesn't indicate it's ability to pass 4K HDR signals. Also there may be other devices, such as a receiver, that's causing the problem.
yeah have done that same thing im getting as old mate just said even with DV turned off in the settings. Netflix just keeps glitching all the time so i just watch netflix through the c9 itself now.

Does anyone have the previous firmware release before DV was introduced? I dont want to use DV on this player anymore. I just want it back to the way it was before the last firmware update. Is this possible?
 

·
Registered
Joined
·
22 Posts
Okay, I'm about done with Netflix on this player. I will get into netflix and within moments of scrolling through the menu or trying to search the display just goes dark and wash, rinse, and repeat for up to 5 minutes. This behavior does not occur while using Vudu or Prime, just Netflix.

The Netflix also does not do this when playing from the TV's onboard app.

This is incredibly frustrating. Any others experiencing this? It doesn't resolve when I power cycle the player and the app appears to be up to date.
Blu Ray players are made specifically for playing discs, whether they be CDs, DVDs or Blu Ray. The streaming apps are, basically, just added as a sales gimmick to get you to buy them. Doesn't matter to the manufacturer how well they work. Get yourself a REAL streaming device. I recommend Roku, or, if you can afford it, Nvidia Shield. You'll be a lot happier with the results and it will increase the life of your player.
 

·
Registered
Joined
·
2,734 Posts
Blu Ray players are made specifically for playing discs, whether they be CDs, DVDs or Blu Ray. The streaming apps are, basically, just added as a sales gimmick to get you to buy them. Doesn't matter to the manufacturer how well they work. Get yourself a REAL streaming device. I recommend Roku, or, if you can afford it, Nvidia Shield. You'll be a lot happier with the results and it will increase the life of your player.

I disagree. The streaming capabilities of the X700 are very good and it can play streaming 24hz content at HDR 12bit 4:4:4 2160P, which many other streaming devices can't do. I have no problems playing Netflix on my X700. There is no inherent reason why a BD player can't be a good streaming device, if it has the desired apps.
 

·
Registered
Joined
·
2,734 Posts
Okay, I'm about done with Netflix on this player. I will get into netflix and within moments of scrolling through the menu or trying to search the display just goes dark and wash, rinse, and repeat for up to 5 minutes. This behavior does not occur while using Vudu or Prime, just Netflix.

The Netflix also does not do this when playing from the TV's onboard app.

This is incredibly frustrating. Any others experiencing this? It doesn't resolve when I power cycle the player and the app appears to be up to date.
That sounds like a configuration issue. My Netflix via the X700 is solid and glitch free.
 

·
Registered
Joined
·
2,734 Posts
What config things should I be looking at? Not sure where to start.

Sent from my LM-G820 using Tapatalk
First - cooling, Is the X700 in a well ventilated area with good standoff from other components?

Is the X700 getting a solid internet connection?

What is the cable lengths and devices between the X700 and the display?

What does the display state for incoming signal parameters from the X700?
 

·
Registered
Joined
·
82 Posts
I have not read through all of the pages on the thread but has anyone had any issues where the UBP-X700 just randomly exits the Apps (mainly Netflix/Vudu) and goes back to the main menu and keeps doing this every time you try to go into the Apps? The only way I can fix this is by unplugging and replugging it after powering down - as powering on and off won't fix it.

The other issue i have had my player randomly factory reset on me 3 times (not frequent) but maybe once a week or a month
 

·
Registered
Joined
·
440 Posts
First - cooling, Is the X700 in a well ventilated area with good standoff from other components?

Is the X700 getting a solid internet connection?

What is the cable lengths and devices between the X700 and the display?

What does the display state for incoming signal parameters from the X700?
Thanks, Dun...appreciate the reply and suggestions.

Solid wireless connection.
Cable length - 3ft for audio to the AVR; and 8ft for video to the TV (both Monoprice Premium Certified)

This problem only occurs with Netflix, though. Vudu, Prime, Hulu all work perfect and that's what is frustrating. Typically, the problem occurs during the first 5 minutes following start-up and then the app works fine.
 

·
Registered
Joined
·
2,734 Posts
Thanks, Dun...appreciate the reply and suggestions.

Solid wireless connection.
Cable length - 3ft for audio to the AVR; and 8ft for video to the TV (both Monoprice Premium Certified)

This problem only occurs with Netflix, though. Vudu, Prime, Hulu all work perfect and that's what is frustrating. Typically, the problem occurs during the first 5 minutes following start-up and then the app works fine.
So is the X700 connected directly to the TV for video? If not then test a direct connection to the TV, bypassing the receiver.
 

·
Registered
Joined
·
440 Posts
So is the X700 connected directly to the TV for video? If not then test a direct connection to the TV, bypassing the receiver.
Yes; I am using both outputs on the X700 - one HDMI from the X700 to the AVR for audio; and one HDMI from the X700 directly to the TV. Sorry, I wasn't clear about that.
 

·
Registered
Joined
·
2,144 Posts
I have not read through all of the pages on the thread but has anyone had any issues where the UBP-X700 just randomly exits the Apps (mainly Netflix/Vudu) and goes back to the main menu and keeps doing this every time you try to go into the Apps? The only way I can fix this is by unplugging and replugging it after powering down - as powering on and off won't fix it.

The other issue i have had my player randomly factory reset on me 3 times (not frequent) but maybe once a week or a month
I have only ever used it for playing discs. I have streaming devices for running apps.
 

·
Registered
Joined
·
131 Posts
I have not read through all of the pages on the thread but has anyone had any issues where the UBP-X700 just randomly exits the Apps (mainly Netflix/Vudu) and goes back to the main menu and keeps doing this every time you try to go into the Apps? The only way I can fix this is by unplugging and replugging it after powering down - as powering on and off won't fix it.

The other issue i have had my player randomly factory reset on me 3 times (not frequent) but maybe once a week or a month
Sounds faulty if it's resetting like that. Can you do a warranty claim?
 

·
Registered
Joined
·
82 Posts
Sounds faulty if it's resetting like that. Can you do a warranty claim?
Hmm I don't remember how long it has been since i bought it... definitely over a year, maybe 2-3? Bought at frys so I think it is past the warranty claim. As i stated it randomly happens but not too often, but it is still annoying to have to update and adjust settings again lol.
 

·
Registered
Joined
·
53 Posts
Mine does weird things with Netflix App. Prime App works fine. Youtube works fine. Those are the only apps I use, can't install Disney+ on it.

What happens is I'll start Netflix, screen will come up, start showing previews then blank out, pause for a few seconds, come back play some more, pause etc.

As I scroll through movies, the screen will blank out, play, come back, etc. Totally unusable.

I too have just decided to use it to play back 4K UHD and BD discs and leave streaming to my Samsung 65Q7DR and my Firecube 4K Gen 2 and my Stream+ for GooglePlay Movies and TV.

They work much more solidly.
 
4041 - 4060 of 4117 Posts
Top