AVS Forum banner

42761 - 42780 of 64785 Posts

·
Registered
Joined
·
74 Posts
If you've read my previous posts you'll know that I, along with several others on this forum, am having a problem with the screen freezing. You have to turn the TV off and on again to resume what you're watching and often it just freezes up again within minutes. It's INCREDIBLY annoying, and not acceptable for a $100 TV, let alone one that costs more than $2000. I've exchanged the TV once already and the replacement has the same problem. I'm expecting a second replacement on Friday directly from Vizio, and I'm HOPING that this one is fine. It seems like the vast majority of owners have not experienced this issue. There are several other technical problems people are experiencing (seemingly mostly related to ARC) but I don't think that any of them are as disruptive as what I'm dealing with.

In terms of picture quality, there is NO WAY you're going to touch the P series for the price with any other panel. Closest thing for the price would be the Samsung KS8000 series but many have complained about issues related to the edge-lit panel, plus no Dolby Vision. The LG OLEDs will outperform the P series in most categories, but of course they cost double (at least here in Canada). Some have experienced abnormal banding and excessive DSE with the P, and yes, you may get a dud panel and need to exchange it. And NONE of the panels are "perfect" (nor are any other manufacturer's panels all perfect) but if you get a good one, its imperfections are rarely noticed in regular viewing.

In summary, if you get a unit that has no technical problems and has an average to good panel (in terms of defects), it's the best value out there right now.

That being said, the first time my third unit freezes I'm going to open up the chassis, take a big dump inside, seal it back up, and return it to Vizio. :D
Haven't read this all yet, as I'm too angry and annoyed right now to, but my Vizio froze again tonight multiple times. I'm calling Vizio tomorrow and asking for a replacement. This is unacceptable.

I got a Best Buy warranty as well. You guys think I should call Vizio or Best Buy?
 

·
Registered
Joined
·
8,208 Posts
Haven't read this all yet, as I'm too angry and annoyed right now to, but my Vizio froze again tonight multiple times. I'm calling Vizio tomorrow and asking for a replacement. This is unacceptable.

I got a Best Buy warranty as well. You guys think I should call Vizio or Best Buy?
What source are you using? What is your connection setup?

If they have the p75 at your best buy it may be the quickest but if not, I'd probably go straight to Vizio with it.
 

·
Registered
Joined
·
74 Posts
What source are you using? What is your connection setup?

If they have the p75 at your best buy it may be the quickest but if not, I'd probably go straight to Vizio with it.
So it's frozen on multiple sources now. Tonight it froze originally on Spectrum cable (connected via HDMI to the TV), and then froze later on when using my Xbox One (also connected to the TV via HDMI). It originally froze using a Roku Stick and then later that day through the SmartCast tablet source. The Vizio rep thought it might be the Roku, but since that day I've disconnected the Roku Stick from the TV.

Only other thing I've had hooked in is my Vizio soundbar connected through the optical TV input (am not using a receiver).

I have a Vizio P65. It wasn't available in any local Best Buy when I bought it last week, so I'm sure it still isn't. Ugh. I'm assuming if they replace it they come out and do it for you, etc.

Sad part is I love it otherwise, but it's an incredibly disruptive problem.
 

·
Registered
Joined
·
3,459 Posts
So it's frozen on multiple sources now. Tonight it froze originally on Spectrum cable (connected via HDMI to the TV), and then froze later on when using my Xbox One (also connected to the TV via HDMI). It originally froze using a Roku Stick and then later that day through the SmartCast tablet source. The Vizio rep thought it might be the Roku, but since that day I've disconnected the Roku Stick from the TV.

Only other thing I've had hooked in is my Vizio soundbar connected through the optical TV input (am not using a receiver).

I have a Vizio P65. It wasn't available in any local Best Buy when I bought it last week, so I'm sure it still isn't. Ugh. I'm assuming if they replace it they come out and do it for you, etc.

Sad part is I love it otherwise, but it's an incredibly disruptive problem.
I guess it could be a bad set if the problem is resolved with your BB replacement. If not, something in your configuration is off. Good luck.
 

·
Registered
Joined
·
74 Posts
I guess it could be a bad set if the problem is resolved with your BB replacement. If not, something in your configuration is off. Good luck.
I hope it's a bad set. I've run all the equipment extensively with other TVs other than the Roku Stick, which I've used a little with other TVs. Only new element is the Spectrum cable box which was just installed as I just moved into a new apartment.
 

·
Registered
Joined
·
8,208 Posts
I hope it's a bad set. I've run all the equipment extensively with other TVs other than the Roku Stick, which I've used a little with other TVs. Only new element is the Spectrum cable box which was just installed as I just moved into a new apartment.
The first thing I would try is a factory reset of the P65 through the SmartCast App.
 

·
Registered
Joined
·
8,208 Posts
Alright, I'll try that tonight. Should i then wait for another freeze to happen before calling support?

I just go into Reset and Admin and then hit Reset to Factory Settings?
Correct..... Yes I would wait....

So you have an Xbox One (non S?) And the spectrum box.

HDMI 5 and HDMI 1 respectively? You didn't enable subsampling right?

Sent from my ZTE A2017U using Tapatalk
 

·
Registered
Joined
·
74 Posts
Correct..... Yes I would wait....

So you have an Xbox One (non S?) And the spectrum box.

HDMI 5 and HDMI 1 respectively? You didn't enable subsampling right?

Sent from my ZTE A2017U using Tapatalk
Xbox One (non-S) in 5, Spectrum box in 2 (1 said ARC, which I figured was normal HDMI, but put it in 2 just in case). Optical I'll switch off between Vizio soundbar and Astro A50s (I want to make sure I get ideal audio settings once TV gets straightened out, so I'll probably have more future questions about this setup).

Looking back there now, I did notice I plugged in the Astro MixAmp so that it charges using the TV. Could this cause a freeze? Seems annoying they'd give me the option to use that feature if it doesn't work....

I don't even know what subsampling is. Only settings I've messed with are changing picture mode and switching Digital Audio Out to "Bitstream" from "Auto" (I saw this somewhere online to make sure you were getting proper surround sound pass through for, say, my Astro headset).

Did the reset just now.
 

·
Registered
Joined
·
61 Posts
I think one of the recent updates enabled DD+ over ARC while before it just sent regular DD. Regular DD still seems to work for me but many of the main casting sources like Netflix and Vudu use DD+ which results in constant audio dropouts in my setup (Denon X3300W AVR). My AVR decodes DD+ fine from other sources so I'm not sure why there is so much trouble with DD+ from my P50 over ARC. There are some users that say DD+ over ARC works fine with their P-series, so I don't know why it works for some owners and not for others. Maybe some AVRs are more finicky than others? I have tried several premium certified HDMI cables including three different 6ft cables from BJC so I am confident that my cables aren't the problem. Hopefully a firmware update from Vizio or the AVR manufacturers will solve these issues. For now I have just given up on it and use optical audio from the TV.
I'm really frustrated with these ARC issues. This TV has been out for over a year now with constant firmware updates, and it's still flaky. I want to buy a new receiver, but I'm not going to do that if I'm not sure it will fix my ARC issues.

Someone above seems to be able to get ATMOS over ARC, but you are not able to get and DD+.
 

·
Premium Member
Joined
·
3,355 Posts
I'm really frustrated with these ARC issues. This TV has been out for over a year now with constant firmware updates, and it's still flaky. I want to buy a new receiver, but I'm not going to do that if I'm not sure it will fix my ARC issues.

Someone above seems to be able to get ATMOS over ARC, but you are not able to get and DD+.
I've never had any issues getting DD+ or Atmos (which is imbedded in a DD+ stream) from my P75 over ARC and I've used it with a Denon X4200W and (currently) a Marantz SR6010.

I know that doesn't help those with issues, but there is hope...
 

·
Registered
Joined
·
61 Posts
I've never had any issues getting DD+ or Atmos (which is imbedded in a DD+ stream) from my P75 over ARC and I've used it with a Denon X4200W and (currently) a Marantz SR6010.

I know that doesn't help those with issues, but there is hope...
Just so we are all on the same page. Is this ARC from a Casting app on the tv or pass through ARC?

also, when did you swap AVR's because another user had trouble with a comparable Denon recently.

My Denon is rather old 1613, and I can't get it to work with DD+ over ARC.
 

·
Premium Member
Joined
·
3,355 Posts
Just so we are all on the same page. Is this ARC from a Casting app on the tv or pass through ARC?

also, when did you swap AVR's because another user had trouble with a comparable Denon recently.

My Denon is rather old 1613, and I can't get it to work with DD+ over ARC.
It's ARC from casting. I swapped AVRs maybe 3-4 months ago, but I wouldn't expect the Denon to behave differently than the Marantz since they're practically the same receiver.
 

·
Registered
Joined
·
13 Posts
Correct..... Yes I would wait....

So you have an Xbox One (non S?) And the spectrum box.

HDMI 5 and HDMI 1 respectively? You didn't enable subsampling right?

Sent from my ZTE A2017U using Tapatalk
Xbox One (non-S) in 5, Spectrum box in 2 (1 said ARC, which I figured was normal HDMI, but put it in 2 just in case). Optical I'll switch off between Vizio soundbar and Astro A50s (I want to make sure I get ideal audio settings once TV gets straightened out, so I'll probably have more future questions about this setup).

Looking back there now, I did notice I plugged in the Astro MixAmp so that it charges using the TV. Could this cause a freeze? Seems annoying they'd give me the option to use that feature if it doesn't work....

I don't even know what subsampling is. Only settings I've messed with are changing picture mode and switching Digital Audio Out to "Bitstream" from "Auto" (I saw this somewhere online to make sure you were getting proper surround sound pass through for, say, my Astro headset).

Did the reset just now.
Hope the reset works for you. I've done them multiple times with no lasting effect.
 

·
Registered
Joined
·
30 Posts
He has a X3300 so maybe this is a Denon issue that was fixed after that generation?
I have a P65 (3.0.14) with an AVR X3300 and still have ARC issues while casting Netflix (I haven't tried it with anything else). The P65 will pass DD+ to the AVR but will have constant dropouts making the video unwatchable. I've tried all the different output settings on the P65 and the only thing that works consistently is PCM.
 

·
Registered
Joined
·
236 Posts
I have a P65 (3.0.14) with an AVR X3300 and still have ARC issues while casting Netflix (I haven't tried it with anything else). The P65 will pass DD+ to the AVR but will have constant dropouts making the video unwatchable. I've tried all the different output settings on the P65 and the only thing that works consistently is PCM.

I have a P55 and Denon X1200W and haven't had any ARC issues. I know it shouldn't matter, but do you have any video processing enabled on your X3300?
 
42761 - 42780 of 64785 Posts
Top