AVS Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I live in durham north carolina and just now, hours after the hurricane has gone past, the power blinked. I was watching my 3 week old Sony 34HS510


Now the sides of the pictures are a greenish tint?!??!?!?!?


I have the television plugged into a surge protector too!


Did I just ruin my BRAND NEW television?!?
 

·
Registered
Joined
·
184 Posts
Hey neighbor, which local retailer did you buy your tv at? I'm in raleigh(next to the fairgrounds), in the middle of the same storm, i know nothing about if your new tv is messed up or not, but figured i'd say hi, since we live min. away from each other.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
well hello, i actually purchased it in raleigh at now audio video on 70.


hope this thing is ok ....
 

·
Registered
Joined
·
493 Posts
Not sure if this will help, but make sure you don't have any magnetic equipment near your tv, like unshielded speakers for example. Unshielded speakers will distort the colors in a tube television.


I know you've been watching your tv for three weeks. However, I'm just making sure you didn't recently put some floor standing speakers or something next to your tv. And then coincidently think it was the storm that caused the discoloration. Please pardon me if that's not the case.
 

·
Registered
Joined
·
64 Posts
anxious,


This sounds very similar to a post I read in another forum.


I'd post the link for you, but I'm new and I am not allowed to post links yet.


Visit agoraquest.com and select "Forums" from the main menu.

Then under "Sony Troubleshooting" select "Television Troubleshooting".

In that forum click the kv-24hs510 post, posted by "smma".


HTH!


Saydee
 

·
Registered
Joined
·
4,528 Posts
anxious,


I have the 40XBR and experienced exactly was you described during one of our frequent Florida thunderstorms. I also have a surge protector, and my TV reacted the same as yours. Here's the fix I used...I simply unplugged the set from the power source for about an hour, replugged, turned it on & heard the degauss click, and everything came on perfectly without the discoloration. Let me know if this works for you.
 

·
Registered
Joined
·
3,963 Posts

Originally posted by Saydee

anxious,


This sounds very similar to a post I read in another forum.


I'd post the link for you, but I'm new and I am not allowed to post links yet.


Visit agoraquest.com and select "Forums" from the main menu.

Then under "Sony Troubleshooting" select "Television Troubleshooting".

In that forum click the kv-24hs510 post, posted by "smma".


Saydee-


That was 34hs510. You had me excited there...I am lookin' for a 24" analog of excellence !:confused:
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top