AVS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I'm just wondering, who else has had their Onkyo 605 receiver repaired for the popping sound when playing something in surround sound? Mine has been at the repair shop for over a month. They have been working with Onkyo and have yet to find the cause of the issue, but can reporduce it. The service place said they have 4 other receivers with the same issue, all waiting on Onkyo for the fix.


Dom
 

·
Registered
Joined
·
153 Posts

Quote:
Originally Posted by ddiascro /forum/post/13053832


So no one on here has had their 605 repaired for the popping issue?

Well, I returned a Denon AVR-688 that had popping when switching formats for the Onkyo 605. I have no popping or clicking, but my unit has the latest firmware. I did my research before swapping out for the Onkyo, and it appears that the latest firmware seems to clear up the issue, at least in some cases. If you have the serial number of your unit, you can go to the onkyo site and use the support page to check if your unit needs a firmware update. You might also call the repair center and see if they have updated your receiver to the latest.

They should already have tried that, but on the off chance they haven't, it might help.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I did check on Onkyo's website. My receiver has the latest Firmware update and didn't require an upgrade.


Going on about 2 months now since I've had my unit, and still no word on when it will be fixed. Time to contact Onkyo about getting a replacement?
 

·
Registered
Joined
·
4,486 Posts
I would say it's past time. Document how long they have had it and any contact with them since. Be nice but let them know that you have been more than patient enough. Ask for a response within 48 hours or you will contact the State Attorney General and file a complaint with the BBB.
 
1 - 5 of 5 Posts
Top