AVS Forum banner
1 - 4 of 4 Posts

· Registered
38 Posts
Discussion Starter · #1 ·
Hi all, I am regretting my choice to go HDMI instead of tried and true component. HDMI is giving me what appears to be a sync issue.

I have a cablebox, Blueray player LGBD390, and Roku connected to an Onkyo PR-SC886 receiver , then to a brand new Panasonic TV (TC-P50V10) all HDMI connections with premium cables.

CableBox works perfectly, set to 1080i, never a problem. Movie playback on dvd works fine, but when i try to watch Netflix or Youtube from the device's main menu the screen goes to a white static image. It seems like an hdmi sync issue. I think the device tries to switch resolutions when you select the youtube player and one of the hdmi devices in the chain does not like this.

Also, the roku does not seem to work at all. When i select it's source, the screen just goes black. If i unplug and replug the HDMI cable a few times eventually I can get a picture, but it has never worked on the first try. The onkyo is not getting the input. It seems to work more often when the roku is in it's 'SD 16:9' mode.

I was wondering if this is a known issue or if there is any fix or workaround.

The Onkyo is able to upscale sources, but it is currently set to passthrough mode. I have tried every possible mode and the only way to get the Youtube player to work is to put the onkyo into '720p' mode. Auto and passthrough result in an hdmi static screen. The 720p mode does not help Roku at all.

I've also tried changing out the HDMI cables, no luck. DVD player and Roku are updated and running the latest firmwares. There is no Onkyo firmware update that I know of.. The Panasonic is my second one, the first one died on the first day, and had this same problem.

Any suggestions for figuring this out would be much appreciated. I've emailed Onkyo tech support about this, but they just tell me to factory reset the unit.


· Registered
1 Posts

I have got an used onkyo pr-sc886 and I think i have the same problem.

Panasonic assistance told me that is a firmware problem but i think i have he last one

MAIN: 87 1.05/09116A

DSP1: SR9061 08919A

DSP2: SR9062 08605C

DSP3: SR9063 08506A

HDMI: 1.00/08627A

VIDEO: 08703E01293

Please help me!!
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.