AVS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi friends i´m from Spain and i have an onkyo tx-nr 905 purchased in the USA, the problem that i have is that when i conected the receiver in my home the stanby light stays in red and when i press the power on button i only hear a "click" but nothing happens it doesn´t turn on.

I know that it works with 120v and in Spain we work with 220v but i have a very good converter that i used to use with my old onkyo 505 purchased in usa too.

I really don´t know what to do, can anyone help me please?

Thanks and sorry about my poor english.
 

·
Registered
Joined
·
7,608 Posts

Quote:
Originally Posted by Aurones /forum/post/14266039


Hi friends i´m from Spain and i have an onkyo tx-nr 905 purchased in the USA, the problem that i have is that when i conected the receiver in my home the stanby light stays in red and when i press the power on button i only hear a "click" but nothing happens it doesn´t turn on.

I know that it works with 120v and in Spain we work with 220v but i have a very good converter that i used to use with my old onkyo 505 purchased in usa too.

I really don´t know what to do, can anyone help me please?

Thanks and sorry about my poor english.

Your english is better than mine ,did you make sure that your speaker wires

are not touching anything other than their designated posts also try a hard

reset its in your manuel.
 

·
Registered
Joined
·
3,153 Posts

Quote:
Originally Posted by Aurones /forum/post/14266039


Hi friends i´m from Spain and i have an onkyo tx-nr 905 purchased in the USA, the problem that i have is that when i conected the receiver in my home the stanby light stays in red and when i press the power on button i only hear a "click" but nothing happens it doesn´t turn on.

I know that it works with 120v and in Spain we work with 220v but i have a very good converter that i used to use with my old onkyo 505 purchased in usa too.

I really don´t know what to do, can anyone help me please?

Thanks and sorry about my poor english.

Have You selected any speakers in the setup ?
 
1 - 5 of 5 Posts
Top