AVS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am trying to get Zone 2 working on my Onkyo TX-NR626 receiver. I currently have a 5.1 audio setup and I've just bought some new speakers so I can set up a Zone 2.

I've plugged cables into the Zone 2 "L" + "R" connectors and connected the other end to a speaker. I've tried it with Powered Zone 2 turned on in the settings and turned off, but in either case I can't get any sound to come out of the speaker. Does anyone know how to get this working?

I've attached a photo of the speaker outlets I'm plugging into at teh back of the receiver in case I'm using the wrong ones.
 

Attachments

·
Registered
Joined
·
358 Posts
The zone 2 can only play from analog inputs. Are you trying to use HDMI? The terimals on the left are indeed the right ones. Also, in the setup you have to turn "Powered Zone 2 -> On" and I believe there is also a setting to make the output variable instead of fixed. I'm not sure what the default is.

If you are bi-amping the front speakers or using the surround back channels, I believe the powered zone 2 is disabled, but you should consult the manual to make sure that's accurate.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
The zone 2 can only play from analog inputs. Are you trying to use HDMI? The terminals on the left are indeed the right ones. Also, in the setup you have to turn "Powered Zone 2 -> On" and I believe there is also a setting to make the output variable instead of fixed. I'm not sure what the default is.
I'm only connecting analogue, but only because that's the only option. So that means on-board audio such as the AM/FM tuner and built-in internet apps such as Spotify and internet radio stations. I would really like to be able to Chromecast from my Android phone to Zone 2, but the Chromecast connects via HDMI. I'll ask about this in a different thread.

If you are bi-amping the front speakers or using the surround back channels, I believe the powered zone 2 is disabled, but you should consult the manual to make sure that's accurate.
Turns out I was being a right dufus. I'd looked and looked at the back of the receiver for Zone 2 pole connectors just like the ones to other speakers because I wanted to do a direct connection from receiver to Zone 2 speakers (no bi-amping). I couldn't see them anywhere - then when I looked in the manual this morning I saw a diagram of them and sure enough they were there all along. Doh! So now I've connected them they're working fine. I've posted an annotated diagram from the manual which will hopefully help someone else looking in future.

As you say, you have to make sure the settings are correct in Setup:
- For bi-amped where you're connecting the Onkyo to another amp which in turn has the Zone 2 speakers connected to it, you set Powered = No.
- For a direct connection from the the Onkyo to the Zone 2 speakers with speaker cable, you set Powered = Yes (because the speakers are being powered by the Onkyo).
 

Attachments

·
Registered
Joined
·
40 Posts
I'm only connecting analogue, but only because that's the only option. So that means on-board audio such as the AM/FM tuner and built-in internet apps such as Spotify and internet radio stations. I would really like to be able to Chromecast from my Android phone to Zone 2, but the Chromecast connects via HDMI. I'll ask about this in a different thread.
Ever find out anything about how to route this? I just set up a 2nd zone not really considering the possibility of this limitation and it seems all I can play is the NET source... Since it has an HDMI out I thought at least it would be able to mirror some HDMI inputs.
 

·
Registered
Joined
·
1 Posts
Ever find out anything about how to route this? I just set up a 2nd zone not really considering the possibility of this limitation and it seems all I can play is the NET source... Since it has an HDMI out I thought at least it would be able to mirror some HDMI inputs.
I've had some partial success with my Onkyo TX-NR6100 receiver. I should mention I have 5.1 setup and an HDMI cable connected to the SUB/ZONE 2 HDMI output connection which feeds into a Polk soundbar (which in turn has wireless speakers and a subwoofer attached to it).

Here's what I did to get output to the second zone:
(1) Click on the gear button on the Onkyo remote control to get into configuration settings
(2) Choose INPUT/OUTPUT ASSIGN - option 1.
(3) Choose 1.1 TV / OUT OSD
(4) Change the first setting HDMI OUT to MAIN + ZONE 2
(5) Change ZONE 2 HDMI set to USE

This appears to successfully output through the SUB/ZONE 2 HDMI to my Polk soundbar and through all the speakers. If you want the SUB/ZONE 2 to output the same audio as the main, click on the ZONE 2 button, change the input source to match the main source. I end up the original 5.1 surround speakers which are wired, plus the Polk soundbar, the two wireless speakers and the subwoofer. Essentially adding another four speakers to my setup. You might find a slight echo or delay in the sound output. You can correct this by cycling through the MOVIE/TV, MUSIC, GAME buttons on the Onkyo remote control until you find a mode that sounds best and has no echo. Sometimes DIRECT is a good choice, although others work as well.

Now here's the catch: This works perfectly (that is to say, sound outputs to Zone 2) for the NET input on the receiver. I also seem to have it working great for my DVR - Cable/Satellite HDMI 3 input. It works for Blu-Ray on HDMI 2. But it does not work with my streaming Chromebox on HDMI 4, and it doesn't seem to work for the streaming apps within the DVR on cable/satellite. And it doesn't work for the Smart TV apps either. I feel like it might be needing to change the audio options for streaming apps, maybe.

In short, I can get Zone 2 output for NET, Blue Ray, and my Cable box, but haven't figured out how to get it to work for streaming apps yet. So close...Anyways, I hope this helps you.

Some key search terms for anyone else with this problem: Onkyo zone 2 sub has no audio for certain inputs cannot play zone 2 for streaming apps
 

·
Registered
Joined
·
51 Posts
The zone 2 can only play from analog inputs. Are you trying to use HDMI? The terimals on the left are indeed the right ones. Also, in the setup you have to turn "Powered Zone 2 -> On" and I believe there is also a setting to make the output variable instead of fixed. I'm not sure what the default is.

If you are bi-amping the front speakers or using the surround back channels, I believe the powered zone 2 is disabled, but you should consult the manual to make sure that's accurate.
In trying to expand the zone 2 possibilities. I currenty run a powered zone 2, but I have more receivers and speakers lying around if I feel the need to go to unpowered.

I finally figured out that if I have a digital audio source for say the BD input, all I need to do to make BD "zone 2 eligible" is add an RCA connection in addition to the digital output and viola-- the BD input will run analog in zone 2, and digital in zone 1. That's good.

What I cant seem to figure out is how to make the AUX input "zone-2-eligible". All there is an HDMI in for AUX. I am using all the other inputs (I have many TVs), but I am not using all the RCA inputs. Is there a way to play with the assignments to make it work?
 
1 - 6 of 6 Posts
Top