AVS Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I got optoma gt750 projector since months ago, but it's the first time this happens. i used it yesterday, it worked fine like always, but today when I tried to use it, most of the functions were disabled. I can only enter the menu, however, some of the options are gone and also the Display section in the menu, it wont let me press it, it skips to the next section. other than the menu button on the remote, nothing else works. I tried pressing everything I could think of, but nothing is happening! the projector is only showing the green background but it's blank. I turned it on and off several times, its the same. I unplugged it completely for hours, didn't work.
I connected several devices to it, the only thing that worked was the yellow video port. it showed the contents of the PS3 right away, but then when I use the hdmi again, nothing happens.
I can't think of something that somehow caused this to happen. I do have a 2 year warranty but for the time being I'm outside the UK (where I bought it).
any suggestions please help with this. I'm holding in my tears well so far. this is depressing. :crying:
any idea you have, I wanna know.
Thanks a lot.
 
1 - 1 of 1 Posts
Top