AVS Forum banner

901 - 920 of 971 Posts

·
Registered
Joined
·
229 Posts
Are you using the correct trigger wire? Some mini plug cable terminators are stereo and some are mono. That could be one reason. If this happens to be it, there are male-to-female converters that can be purchased.

Thanks for the replay. Iam using the wire that came with the outlaw amp.



Just an update, I purchased the Emotiva ET-3 trigger box and put it between my XMC-1 and 7000X and voila it works like it should, why it won't with just the XMC-1 to 7000X is beyond me as all amps and gear I have had and the new ET-3 box work fine ??
 

·
Registered
Joined
·
68 Posts
If anyone out there is a penny pincher like me, b-stock model 5000 and 7000x are back in stock....
Used to be, I never had luck with B-Stock with Outlaw.
 

·
Registered
Joined
·
202 Posts
Just an update, I purchased the Emotiva ET-3 trigger box and put it between my XMC-1 and 7000X and voila it works like it should, why it won't with just the XMC-1 to 7000X is beyond me as all amps and gear I have had and the new ET-3 box work fine ??
Thanks for the info. I may try this out with my denon 8500 to see if it works. Very strange that the outlaw trigger doesn't work plugged directly into a receiver or press amp.
 

·
Registered
Joined
·
15 Posts
RR2150 driving my computer speakers here. Exodus Kit61 and dual Emotiva 12" subs.



I also have an Outlaw 1070 that I've never put to work. Meant to use it to drive a surround system for my PC that never materialized.


For funsies I hooked up the RR2150 to my Legacy towers. That didn't go so well. Amp got pretty hot quickly and just didn't have the oomph to rock out.
 

·
Registered
Joined
·
791 Posts
Thanks for the info. I may try this out with my denon 8500 to see if it works. Very strange that the outlaw trigger doesn't work plugged directly into a receiver or press amp.

I think it's hit or miss on this issue. I have the 7000x and have had no problems with the trigger on many preamps and receivers I have tested it with (6 plus preamps/receivers easily).
 

·
Premium Member
Joined
·
2,663 Posts
I haven't had any trouble with any of my Outlaw Audio amps (7900, 7700, 7140, and 4 2200s) trigger working either. These have been plugged into various Yamaha receivers and prepros. One would hope that these 12v trigger circuits would follow some kind of standard and be compatible. Seems that may not be the case.
 

·
Registered
Joined
·
1,335 Posts
My 7000x trigger works as expected driven by a Pioneer Elite VSX-LX504...
 

·
Registered
Joined
·
439 Posts
My 7000x trigger works as expected driven by a Pioneer Elite VSX-LX504...
Both of my triggers work also. One of them is split from the receiver using cheap belkin splitters to the triggers on onkyo m-282s. The other is coming directly from the receiver and works fine. Both units were b-stock but work perfectly.
 

·
Registered
Joined
·
7,684 Posts
I have a M200 that has a trigger issue i think, the LED goes yellow, no sound....i play around with the trigger selector and it will work ok for awhile
It will also toggle back and forth between yellow and green........
I’d like to get it fixed and sell off all 7
 

·
Registered
Joined
·
22 Posts
Anyone have 2200's and an ATI made 200WPC Outlaw AMP?

I presently have an OUTLAW 7500 (200X5). I was considering picking up some 2200's if I can find someone selling them for the right price. But I wondered if anyone has both and could give an opinion on how similar or difference they sound. Both 200WPC but one is a monoblock and type G? My guess is it's a lateral purchase.

Thanks
 

·
Premium Member
Joined
·
2,663 Posts
Anyone have 2200's and an ATI made 200WPC Outlaw AMP?

I presently have an OUTLAW 7500 (200X5). I was considering picking up some 2200's if I can find someone selling them for the right price. But I wondered if anyone has both and could give an opinion on how similar or difference they sound. Both 200WPC but one is a monoblock and type G? My guess is it's a lateral purchase.

Thanks
I used 4 2200s with my 7900 for several years but since the 7900 powered the 7 bed channels and I used the 2200s for the 4 presence channels I can't really provide any sort of sound comparison. I can say that the 2200s worked flawlessly and sounded great. I replaced the 2200s with a 7700 a couple of years back and now am using just 2 of the 2200s with my RX-A3080 in the den for its two front L&R channels and have been very happy with the setup.
 

·
Registered
Joined
·
22 Posts
I used 4 2200s with my 7900 for several years but since the 7900 powered the 7 bed channels and I used the 2200s for the 4 presence channels I can't really provide any sort of sound comparison. I can say that the 2200s worked flawlessly and sounded great. I replaced the 2200s with a 7700 a couple of years back and now am using just 2 of the 2200s with my RX-A3080 in the den for its two front L&R channels and have been very happy with the setup.
Thanks for sharing. Tell me about that 7900 vs your 7700? Can you tell one vs the other? I have the 7500 which I would assume is exactly the same as 7700 with 2 fewer channels. Wondering if the 7900 was worth the bump. Wish there were more used ones of those out there for good prices but you don't see them come up very often.
 

·
Registered
Joined
·
216 Posts
Just curious, any users out there for the original 750, not 7500, the 750?


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,663 Posts
Thanks for sharing. Tell me about that 7900 vs your 7700? Can you tell one vs the other? I have the 75000 which I would assume is exactly the same as 7700 with 2 fewer channels. Wondering if the 7900 was worth the bump. Wish there were more used ones of those out there for good prices but you don't see them come up very often.
I can't really give you a direct comparison between the two amps. The 7900 drives the bed channels and different speakers than the 7700 which is used only for the 4 presence channels. My bed channel speakers are full range Revel speakers (i.e. large) and my presence are NHT bookshelf speakers.

I can say, that both amps have been flawless over the years and I am quite happy with them.
 

·
Registered
Joined
·
229 Posts
Thanks for the info. I may try this out with my denon 8500 to see if it works. Very strange that the outlaw trigger doesn't work plugged directly into a receiver or press amp.
I think it's hit or miss on this issue. I have the 7000x and have had no problems with the trigger on many preamps and receivers I have tested it with (6 plus preamps/receivers easily).
I haven't had any trouble with any of my Outlaw Audio amps (7900, 7700, 7140, and 4 2200s) trigger working either. These have been plugged into various Yamaha receivers and prepros. One would hope that these 12v trigger circuits would follow some kind of standard and be compatible. Seems that may not be the case.
My 7000x trigger works as expected driven by a Pioneer Elite VSX-LX504...
Both of my triggers work also. One of them is split from the receiver using cheap belkin splitters to the triggers on onkyo m-282s. The other is coming directly from the receiver and works fine. Both units were b-stock but work perfectly.



Yeah I can't understand it at all, I've had three UPA-1's, UPA-700, ERC-3 and a Sherbourn 7-350 amp all trigger as normal off the XMC-1 but two 7000X amps that will not, crossed my fingers and ordered the ET-3 trigger box and works as should, so the XMC-1 is triggering the ET-3 fine as well ?? it will remain a mystery for all of time hahaha, so I will say the ET-3 is worth a shot if you can't get the 7000X to trigger properly.


Cheers :)
 

·
Registered
Joined
·
1,335 Posts
Yeah I can't understand it at all, I've had three UPA-1's, UPA-700, ERC-3 and a Sherbourn 7-350 amp all trigger as normal off the XMC-1 but two 7000X amps that will not, crossed my fingers and ordered the ET-3 trigger box and works as should, so the XMC-1 is triggering the ET-3 fine as well ?? it will remain a mystery for all of time hahaha, so I will say the ET-3 is worth a shot if you can't get the 7000X to trigger properly.


Cheers :)
Very strange.
 

·
Registered
Joined
·
729 Posts
Outlaw Web site

Is anyone else having problems with the Outlaw web site? I have tried two browsers and can't get in.
 

·
Registered
Joined
·
2,432 Posts

Attachments

·
Registered
Joined
·
1,856 Posts
Their server responds to ping requests, but the site is down.
 
901 - 920 of 971 Posts
Top