AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter · #1 ·
So there was some sort of power fluctuation and while watching my 55st30 the screen just shrank into the middle of the screen and it turned off at which point it started to blink 7 times.


I called panasonic as I am under warranty and the service guy looked at it and determined that the SU and SD boards needed replacing (7 blinks). Panasonic refused to repair/replace the tv and wanted to cut me a check for what I paid for the tv ($450). Since I didnt pay much there is no point in me taking the check since a replacement tv would cost quite abit more.


I am pretty skilled when it comes to computer building and tinkering. I ordered the SU and SD boards on ebay for $20 and then replaced them today. I am getting the same 7 blinks. I downloaded a repair manual and it says that if there is 7 blinks to check the SU and SD boards.


Any ideas what I can do now?
 

·
Registered
Joined
·
988 Posts
You should be careful with buying SU/SD boards on eBay.


On a popular repair forum, Badcaps.net, we've found about 25~35% of SU/SD boards and equivalent boards from other plasmas (Samsung & LG call them Y-buffer boards) are dead on arrival when bought from sellers on eBay who have "tested" them. Most are damaged when the plasma panel is cracked (they are removed from cracked screen TVs.) We're not sure what their testing method is (if there is one...), but it is missing a large number of these boards.


There are some tests you can do on the buffer boards.


First, follow this video (mine) about output shorts. On your board, you want to use the points marked HV DANGER -- where it connects to the SC board.
https://www.youtube.com/watch?v=51SZsfH60EY


Then, see this post by another user who fixes quite a lot G20/G25 plasmas with this common fault
http://www.badcaps.net/forum/showpost.php?p=332420&postcount=58

(In particular the attachments are useful, if you can't see them without logging in let me know and I'll put them up here)


Also, try running the set with SU/SD disconnected and jumper on SC50 -- should power up with no blinking light, which tells you the SC is probably OK.
 

·
Registered
Joined
·
1 Posts
Hello Guys,

Can someone post a link to Service Manual for P50ST30?

I digged inet for it without any success!


Thanks!
 
1 - 3 of 3 Posts
Top