AVS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
On Sunday my projector was making a knocking sound during football.I shut the iris and the sound went away.

Last night I tried the projector and it went on for about 1 minute and then there was no picture.The fan was still going.I powered down and the same thing happened(I did this a few times).It goes on for about a minute and then no picture.It has about 120 hours on it.

Good thing it wasn't during a Super Bowl party.

I do not know which projector to get next.I had no issues until now.

Anybody with similar issues?I may try another AX100.

Quality control?
 

·
Registered
Joined
·
556 Posts
Coastal, sorry to know about your projector. I am still considering this projector even though the number of problems reported are exceedingly high. The only place I would want to get this is from Costco because of their return policy as I am hoping I will get lucky with the one I get.


I can't find a better projector to do CIH for a 12' wide screen as AX100 has enough lumens and vertical stretch feature to do CIH the cheapest way possible with just the use of Anamorphic lens.


Please can you tell us where you got your projector from? Maybe, certain range of production units have these problems and probably got shipped to few retailers.


Thanks.
 

·
Registered
Joined
·
1,392 Posts
Exchange it at Costco if you like it that much. If the 2nd one goes bad, return it for a refund and get something else.


As much talk as there is on here about probs with this pj, I was surprised to see that it's back to the #1 spot at PP. Must be alot of people out there who don't read this forum.
 

·
Registered
Joined
·
2,731 Posts
Actually, you usually won't hear much from users that are having NO problems.
 

·
Registered
Joined
·
556 Posts

Quote:
Originally Posted by HeyNow^ /forum/post/0


Actually, you usually won't hear much from users that are having NO problems.

I've seen users who just live with those if it's their projector as they think front projectors are like that.


I have a friend whose AE700 has problems with picture showing green. He had it still under warranty but was lazy to deal with it as it went way when he turned the pj on and off couple of times.


Now after 2 years, it's almost staying always but it doesn't seem to bother them as they used to it. There might be lot of AX100 buyers who got it as their first projector.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top