AVS Forum banner
Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I've got a one week old TH-42PD25 that I have viewed in utter amazement for seven days straight now! Just an incredible picture - very happy with the choice of ED over HD - and my big fear of poor SD was totally unfounded with this display - the standard images look great.


However, I am having trouble getting the front inputs (INPUT3) to work. I've tried plugging in a digital camera and my older TiVo box (and tested both of these using the front panel on my old 4:3 Sony) and cannot even get the TV to switch to VIDEO3.


The only inputs into the Panny are my three component cables coming out of my HD TiVo (via my Denon 1705). So, with my camera on and the composite video cable plugged into the front INPUT3 jack, and a valid signal coming in from my TiVo on COMPONENT1, I press the TV/Video button: the display switches over to Antenna A (which I assume is the TV input mode) where I just get snow (as I mentioned, there is no antenna plugged in). The next press of the button takes me back to COMPONENT1 - it blew right by the VIDEO3 mode which is where I would have expected to see the INPUT3 signal coming from my camera. According to the manual, the inputs should go between TV->COMP1->COMP2->HDMI->VIDEO1->VIDEO2->VIDEO3->PC->TV->...


I did the same thing with my old TiVo box. I plugged it into the S-Video on the front panel as well as the L-R audio cables. Again, all I can bring up on the set are COMPONENT1 and Antenna A - cannot get to VIDEO3.


I also tried this exercise after setting the Panny to 4:3 and 480i but still get nothing.


Any thoughts?


Thanks,

Pup


------------


EDITED: Sorry for the premature post. I just happened to read something in another post about the Captions menu giving you the abililty to skip inputs - which in fact, it was doing for INPUT3. Kind of an odd place to put the skip inputs option, but there ya go. Can't complain about much more with this TV.


Now, back to Miss Hawaiian Tropic in HD.....
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top