AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I own a Panasonic 50PX20 plasma, it's about 5-6yrs old; It worked great until recently. When watching any HD channel, the picture will randomly go to a white snow screen. If I turn the TV off and on, it may come back on, but usually I need to let it sit about 30 minutes. Also, I have let it sit overnight and then I turn it on in the morning and it may still encounter the same problem, so I don't think it's heat related. Also, the power to the TV stays on, so I don't believe it's power related either. Is there a specific board that controls the HDMI functionality? Can this board be replaced? Thanks for any help out there.

Dean
 

·
Registered
Joined
·
1,224 Posts

Quote:
Originally Posted by dzarriello /forum/post/16974495


I own a Panasonic 50PX20 plasma, it's about 5-6yrs old; It worked great until recently. When watching any HD channel, the picture will randomly go to a white snow screen. If I turn the TV off and on, it may come back on, but usually I need to let it sit about 30 minutes. Also, I have let it sit overnight and then I turn it on in the morning and it may still encounter the same problem, so I don't think it's heat related. Also, the power to the TV stays on, so I don't believe it's power related either. Is there a specific board that controls the HDMI functionality? Can this board be replaced? Thanks for any help out there.

Dean

I'll assume SD channels are OK ? How about 720p signals ? Can you substitute another source ?


Generally, if lo res is OK but HDMI gags at 1080, the cable may be suspect, especially if it has been moved lately or bent or bitten by the cat etc.


OTOH, The STB may have had an "upgrade" from the provider which now makes it finicky - some upgrade go figure.


Try a known good upconverting DVD at 480, 720, and 1080 for testing.


TW
 
1 - 3 of 3 Posts
Top