AVS Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Can somebody please help me get the 4.15i firmware upgrade accomplished on my new Q50?


I ordered it last week knowing I would probably need to upgrade it. I got it and am having problems getting the upgrade on.


I downloaded several different zip files from sites I learned about within this forum, 4.15i, 4.15N, 4.15O, and even one from Korea that I don't know the level. I think I should go with 4.15i.


But my problem is I can not get the burned CD-R to work. The Q50 displays "Disk Error" within 10 seconds of inserting the disk. I've wasted about 10 CD-R's trying diiferent things (leave seesion open, reverse the copy order of the two files, ...). I've read in this forum that other had the problem too & gotten around it, but I can't seem to get it.


I think I'm doing the burn right. I'm using EZ-CD-Creator Platinum for Windows XP. I've burned many CD-R's and CD-RW's in the past for data and music use with no problem. But somehow I'm just not getting it right on this one.


Any ideas?


Or I'd be very happy to pay someone to mail me a 4.15i CD-R they know should work.


email me at [email protected] if you can send me a CD-R.


Thanks.


Dudeymon
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Hi pschia & kwokyan,


Thanks for the prompt response.


Yes, I did follow the instructions in johnlau's website. That's where I got the 4.15i upgrade too.


I have tried both leaving the session open and closing it. When I close it, I choose the option to allow the CD-R to be read by most other CD drives. I also verified in other PC's in my house that the CD-R can be read. There is an option to protect the CD-R from being updated further, and I've tried that option both ways. I always still get the disk error when I put the CD-R into the Q50. I'm sure I'm not doing something right, but I just can't figure what it is.


My Q50 firmware level is now displayed as 4.13f, which is the common level throughout these threads that seems to have the most problems.


Thanks.


Dudeymon
 

·
Registered
Joined
·
93 Posts
Hi dudeymon,


I would suggest then that you not use the DirectCD method. Instead, try creating the data disk by compiling from your EZ CD-Creator. I had used Nero to create my firmware upgrade disk this way without any problem:


(1) When the 'New Compilation' window is up, highlight CDROM [ISO]


(2) Click on the ISO TAB


(3) File needs to be ISO level 1


(4) Format needs to be Mode 2 /XA


(5) Leave everything else the same


(6) Drag and drop the files to the compilation window


(7) Select 'Close Disk'


(8) Burn it.


With EZ CD-Creator, you should also have similar options available.


Good Luck !
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Thanks pschia.


I'll try it later today and let you know what happens.


I appreciate your help!


Dudeymon:)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Pschia, you are golden!


Your instructions were spot on. I was just using Explorer to drag the files to the CD after formating with Direct CD, and the format was not ISO Level 1.


Using EZ CD Creator to create a CD project, I was able to change the options to your specs, and the CD updated just fine.


The Q50 now displays 4.15.I. And the picture and sound both seem crisper and cleaner. With Toy Story 2, I can really tell a difference. Still some minor chroma problems, but I guess I can live with that.


I simply can't believe a company like Philips-USA would put out a product with such a defect as 4.13f firmware, and not own up to it and provide the fix in an easy to get way for their customers.


Well, now I need to decide if I should mess with 4.15N or 4.15O.


I wonder what the general views are on those firmware levels? Also, can I install them and go back to 4.15I by replaying the firmware CD? In other words, will it backlevel the firmware?


Anyway, thanks again Pschia.


Dudeymon:)
 

·
Registered
Joined
·
93 Posts
dudeymon:


Yes, you can revert back by loading the 4.15i firmware again. Quite a few have done that already after they tried out the 4.15O and found that the picture quality actually deteriorated. That in itself should say something about the value of 'upgrading' to 4.15O, don't you think?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
I agree 100%. I'm staying with 4.15.I until I see in this forum of a clearly better level.


Thanks again pschia - your assistance is greatly appreciated.


Dudeymon
 

·
Registered
Joined
·
1 Posts
Hi Dudeymon - I am having the same problems that you had (with the same version Q50, US model).


I have EZ-CD Creator 5 Platinum - could you tell me the exact steps that you used to burn your 4.15i firmware-updater CD-R?


There isn't a specific selection for ISO Level 1 and the CD I burned with CDRWIN didn't work. I downloaded the straight 4.15i zip file from johnlau.com


I really appreciate any advice you can give me...


Plptine
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top