AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,

Anyone had experience with the Pioneer Elite 510 and the Sony HD-100? I have a 510, but don't have an HDTV receiver yet. Is this a good match? Does the HD-100 come with the proper cable for the 510? Thanks, John
 

·
Registered
Joined
·
34 Posts
John,

I currently have a Pioneer Elite 510 with Sony HD-100 and am quite happy with the setup. The Sony unit has a lot of good features. But, before you buy the HD-100, you may want to check out other postings on problems with the unit (i.e. fan noise). I use the component output of the HD-100 to connect to the Elite. It does come with a component cable, but I had to buy a longer component cable because it's too short for my setup. If you place the HD-100 right on top of the Elite, it'll be just enough length. I have read that the VGA output of the HD-100 is not compatible with the Elite. I have never tried it personally.


Ming
 

·
Registered
Joined
·
40 Posts
John - The setup works well. I've had it since Friday 6/8 along with a Terk TV55 for local HDTV. Very nice. Still tweaking it a bit. The fan is a bit loud but I can live with it until there is a fix. Sure does make you fell better about dropping that cash on the 510!

I'm using monster cable for component cable to the TV and monster cable Toslink (optical) to the integrated amp.

If you take the plunge, be prepared, all other channels are pale in comparison to the HD channels!
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top