AVS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1

Hello everyone! I am new to this forum, and actually figured out everything(or just about) everything about this receiver.

 

I have had a few problems, but nothing that required service.

 

Now I know that this unit is aging, but there are many out there in HT setups.

 

Does anyone have a problem with the LCD screen?

 

Mine no longer works, and only displays a complete white screen and blinks sometimes.

 

I have not seen anything anywhere on the net about a user having a problems with the screen.

 

Please help, as this unit is FULLY connected to my HT system, and requires HOURS to remove it and take it to a PIONEER certified service center.

 

Thanks, and any and all help is greatly appreciated!
 

·
Registered
Joined
·
1 Posts
Sorry to rez a dead thread, but I'm having the same issue (minus the blinking). Just a blank white LCD screen. Is there a quick fix (or any self-fix) or is this something that must go to a repair shop?


jhautos, did you have any luck fixing it without having to remove it from your system?


This thread is quite literally the only place I've seen anyone else with this issue which is why I asked here, in lieu of starting a new thread for the same issue.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Sorry to rez a dead thread, but I'm having the same issue (minus the blinking). Just a blank white LCD screen. Is there a quick fix (or any self-fix) or is this something that must go to a repair shop?


jhautos, did you have any luck fixing it without having to remove it from your system?


This thread is quite literally the only place I've seen anyone else with this issue which is why I asked here, in lieu of starting a new thread for the same issue.
Hello there! I knew someone would have this problem eventually. You are the first response I have received. You just made the thread come alive!

Unfortunately, I never did fix it. No quick fix. I took it to a Pioneer authorized repair center, and they couldn't repair it, saying that they lost support from Pioneer because of the merge with Onkyo. I'm not very happy about that, but another Pioneer service center said that place was not authorized. Who knows. I will take it to them within a week, now that you have caught my attention!

I'm sure it's really an easy fix, for the serviceman, such as a driver board replacement or something. I just hope it won't cost an arm and a leg.

Really stinks, doesn't it? It's not usable, really, without the screen. And I was hoping it would last a very, very long time.

I will let you know as soon as I receive an answer from the repair center.

Meanwhile, if you hear anything, please let me know.
 

·
Registered
Joined
·
1 Posts
Hello there! I knew someone would have this problem eventually. You are the first response I have received. You just made the thread come alive!

Unfortunately, I never did fix it. No quick fix. I took it to a Pioneer authorized repair center, and they couldn't repair it, saying that they lost support from Pioneer because of the merge with Onkyo. I'm not very happy about that, but another Pioneer service center said that place was not authorized. Who knows. I will take it to them within a week, now that you have caught my attention!

I'm sure it's really an easy fix, for the serviceman, such as a driver board replacement or something. I just hope it won't cost an arm and a leg.

Really stinks, doesn't it? It's not usable, really, without the screen. And I was hoping it would last a very, very long time.

I will let you know as soon as I receive an answer from the repair center.

Meanwhile, if you hear anything, please let me know.
Hi there,

I have also had this issue with mine about 1 to 2 years now and of course I lost total control of the sound mode settings and options as I cannot see what I'm doing, can't see any status shown on the Receiver's LCD display including volume!! I did take it to a Pioneer authorized service center near my home in Forest Hills, Queens NY and the Technician informed me 24 hours later that the only way to remedy this problem is to replace the entire section which controls the LCD . I forgot the exact tech terminology but he said it is a complete board with the display unit needed and has to be replaced in total and not just a driver issue or transistor etc ...and that it will cost about $1050 for part plus labor so I just took it back home and decided to not bother repairing unless I miraculously see a used unit somewhere that perhaps has a working part (and even that might be a risk because who knows how much life these things have left in them if coming from another used equipment!!) I am so shocked that such an expensive piece of equipment was not built with an optional way to see all of the important controls on an external optional screen or onscreen on the TV it's connected to! Only deeper controls are available onscreen the TV set. It really sucks.
If anyone has this part (I forgot the part # but if anyone has it to sell please let me know)
If anyone has any other remedy please reach out to me as well.
thanks
 
1 - 5 of 5 Posts
Top