AVS Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello

I got some problems with getting HDMI from my computers to working on my new vsx-922 . When I connect it, I get something like the attached image.

I have no problem with my blu-ray player, chromecast etc. and the cables got High speed written on them.

But if I use a RJ45 HDMI extender between the pc and receiver, then I'm able to get image. But then i have the problem of the pc only seeing the extender and not giving me the option to use surround in windows sound configuration?

I not even able to get it working with my laptop and the 0.5m cable that I used with the hdmi extenders..


Anyone know what the problem is? crappy cables or something?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Green image on TV when PC connected?

I am trying to connect my HTPC to my Pioneer VSX-922 and then to my TV using HDMI cable, but I only get sound and on the TV I get a green static image.

I've tried using my laptop, HTPC and my main pc, and they all do the same.

But I have no problem using my Chromecast, AppleTV and Blu-ray player.

Can anyone tell me what the problem is?
 

·
Registered
Joined
·
15,080 Posts
I am trying to connect my HTPC to my Pioneer VSX-922 and then to my TV using HDMI cable, but I only get sound and on the TV I get a green static image.

I've tried using my laptop, HTPC and my main pc, and they all do the same.

But I have no problem using my Chromecast, AppleTV and Blu-ray player.

Can anyone tell me what the problem is?
Do your computer outputs work if you plug them directly into your TV?
The problem might be in the receiver or in the TV.

What image resolution is your computer's graphics card generating?
Receivers usually require that their input signals be one of the entertainment resolutions, preferably 1920x1080 @ 60 Hz.

Your symptoms are consistent with either your receiver or your TV not supporting video signals with RGB encoding (which is what your computer generates) even though this is a requirement of the HDMI standard.

Most home entertainment devices (like AppleTV) generate YCbCr video encoding.

If you haven't already, you can try doing a "soft reset": unplug both your TV and your receiver from wall power for about 10 minutes. Then plug in the TV, wait until it finishes booting, then plug in the receiver. Sometimes this will fix strange problems like what you are reporting.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Do your computer outputs work if you plug them directly into your TV?
The problem might be in the receiver or in the TV.

What image resolution is your computer's graphics card generating?
Receivers usually require that their input signals be one of the entertainment resolutions, preferably 1920x1080 @ 60 Hz.

Your symptoms are consistent with either your receiver or your TV not supporting video signals with RGB encoding (which is what your computer generates) even though this is a requirement of the HDMI standard.

Most home entertainment devices (like AppleTV) generate YCbCr video encoding.

If you haven't already, you can try doing a "soft reset": unplug both your TV and your receiver from wall power for about 10 minutes. Then plug in the TV, wait until it finishes booting, then plug in the receiver. Sometimes this will fix strange problems like what you are reporting.
It works if I connect the pc directly to TV and I'm using 1080P 60Hz. But I just found out if I set the TV screen device to 25Hz interlaced on the PC then I get a correct image with the AVR it looks like.

Soft reset did not help.

So could this be my hdmi cable? they are not anything expensive but is has High speed HDMI written as the AVR manual says is required written on them.
 

·
Registered
Joined
·
15,080 Posts
It works if I connect the pc directly to TV and I'm using 1080P 60Hz. But I just found out if I set the TV screen device to 25Hz interlaced on the PC then I get a correct image with the AVR it looks like.

Soft reset did not help.

So could this be my hdmi cable? they are not anything expensive but is has High speed HDMI written as the AVR manual says is required written on them.
It could be the cable.

Unfortunately, AVR manuals tend to be optimistic when they say what types of cables will work. From all the reports I've seen, 4K-capable A/V equipment tend to be much more sensitive to the quality of the cables than 1080P A/V equipment even when handling 1080p signals. In other words, they're more reliable if you use "Certified Premium" cables, not just "Certified High Speed" cables.
Certified Premium cables have much less dispersion and attenuation than High Speed cables have, so they're better able to handle both 1080p and UHD (18 Gigabit/sec) data.

Certified Premium 18 Gb/s cables come with a special tag (see the thumbnail below) but are no more expensive than the older High Speed cables. Many people on AVS get them either from Monoprice or from Blue Jeans Cables.
 

Attachments

·
Registered
Joined
·
916 Posts
What TV do you have? Many TVs won't get a proper signal unless the TV itself is set to PC Mode. They'll get some resolutions correct and/or some refresh rates correct, but not all of them. Samsungs' are notorious for this as only 16:9 aspect ratio resolutions that the TV itself acknowledged in the EDID data field work properly when in standard TV mode or game mode. If you are using game mode, be aware that is not the same as PC mode as far as the AVR/PC are concerned. The benefit of PC mode is also that for most TVs it disables the hideous chroma subsampling, which is what causes all colored text to be blurry on TVs connected to PCs. PC Mode also allows TVs with 10-bit panels to accept proper 30-bit ARGB2101010 signals.

Edit: If your VSX-922 has a type of "monitor/display check" function, disable it. I couldn't find any info in the manual, but all I could find for the manual was the EU version, and Pioneer's manuals sadly are fairly lacking in details.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
It could be the cable.
Sorry for the late reply..

I just got me some new certified premium cables, and replaced the one between the TV and AVR and the 5M cable running to my HTPC..

But same problem, no change :(

But it looks like I'm only able to get correct image, if I pick a refresh rate 50Hz or below on the PC.. Anyone know why?


Squishy Tia.. I'm using an old Plasma TV LG 50PK760.. I have not seen any pc mode or anything like that in the menus.. And I'm still learning AVR, so i have look through the manual see what HDMI settings I can do..
 

·
Registered
Joined
·
916 Posts
Sorry for the late reply..

I just got me some new certified premium cables, and replaced the one between the TV and AVR and the 5M cable running to my HTPC..

But same problem, no change :(

But it looks like I'm only able to get correct image, if I pick a refresh rate 50Hz or below on the PC.. Anyone know why?


Squishy Tia.. I'm using an old Plasma TV LG 50PK760.. I have not seen any pc mode or anything like that in the menus.. And I'm still learning AVR, so i have look through the manual see what HDMI settings I can do..
Looks like your TV's actual refresh rate is 50 Hz, indicating it's a PAL model. You're going to need a newer TV if you intend to run 60 Hz content on it.
 

·
Registered
Joined
·
15,080 Posts
I don't understand then.. If I connect a pc directly to the screen using HDMI, i'm able to run 1080P 60Hz like in the attached screenshot..
That's very strange.

You might try using EnTech's MonInfo utility to find out exactly what EDID capabilities the computer is detecting when it's connected to the receiver.

For it to work, you might have to (temporarily) set your computer's secondary output to a low resolution that both the receiver and the TV are guaranteed to work with, e.g. 640x480 @ 30 (or 60) fps.
 

·
Registered
Joined
·
916 Posts
I don't understand then.. If I connect a pc directly to the screen using HDMI, i'm able to run 1080P 60Hz like in the attached screenshot..
Your VSX-922 has a mode called Pure in the Video Parameters settings menu. Select that and then check again. I suspect your receiver is intercepting the signal and setting it to a specific output, either because it is set to "Auto" or one of the predefined resolutions. Setting it to "Pure" should be Pioneer's equivalant to "Through" mode on other manufacturers' AVRs. You'll find the procedure to do this on page 59/60 of your manual.

! When set to a resolution with which the TV (monitor) is not compatible, no picture is output. Also, in some cases no picture will be output due to copyright protection signals. In this case, change the setting.
! When AUTO is selected, the resolution is selected automatically according to the capacity of the TV (monitor) connected by HDMI. When PURE is selected, the signals are output with the same resolution as when input (see About the video converter on page 21).
This is directly from the manual.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
Your VSX-922 has a mode called Pure in the Video Parameters settings menu. Select that and then check again. I suspect your receiver is intercepting the signal and setting it to a specific output, either because it is set to "Auto" or one of the predefined resolutions. Setting it to "Pure" should be Pioneer's equivalant to "Through" mode on other manufacturers' AVRs. You'll find the procedure to do this on page 59/60 of your manual.



This is directly from the manual.
Thank you, thank you!

It did not help changing RES to "pure" But I tried changing some of the other settings like disabling "V.CONV" and IT WORKS NOW!

I have searched alot on this and found like 10 topics on forums, with people that have the same problem.. And no one mention anything about those settings in any of the topics.. I wonder if any of them ever fixed the problem..

Thank you again..
 

·
Registered
Joined
·
916 Posts
Thank you, thank you!

It did not help changing RES to "pure" But I tried changing some of the other settings like disabling "V.CONV" and IT WORKS NOW!

I have searched alot on this and found like 10 topics on forums, with people that have the same problem.. And no one mention anything about those settings in any of the topics.. I wonder if any of them ever fixed the problem..

Thank you again..
Yeah, V.CONV is video conversion, meaning the receiver was intercepting the signal and altering it to match only what it was set to output. That would definitely screw with the PC connection. With that disabled and set to "Pure", you should be able to use any resolution on the PC you want, meaning even low res games like Diablo 2 would work now. :)
 
1 - 14 of 14 Posts
Top