AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
353 Posts
Discussion Starter · #1 ·
I have noticed that on my Sony 55HX820 I MAY have a tiny stuck/dead pixel. Or I should say, what I believe is stuck or dead. I can't really discern any specific color although it's not all black and seems to be mostly gone on a red screen. Which is what led me to believe its a stuck red pixel.


What's strange is that this tiny pixel variation is only visible looking from certain angles. Directly in front of the screen you can't really tell it's there. Move above the image and you still can't see it. Move to the right and it's not there. But if you move below (which I do because I'm mounted high) and to the left its there. I have tried all the methods for removing stuck pixels and nothing works.


What makes it even odder is that when I push on the screen, it will turn into a very noticeable teeny tiny dark spot for a second, almost like a dead pixel that's visible from all angles and sort of pops away going back to the way it was before, only visible from certain angles.


Anyone know what this is? I'd take a picture but I'm not sure you'd even be able to see it.
 

·
Registered
Joined
·
218 Posts
I wouldn't worry about it. If you've wiped the screen with a microfiber cloth and it's still there, I wouldn't sweat it. It's not covered by warranty, and if you can't see it normally, then there's not really anything to worry about.
 

·
Registered
Joined
·
353 Posts
Discussion Starter · #4 ·
Tried that, no dice.
And when I push on it, it kind of sticks on the screen and is VERY visible or a second or two, then fades away only being slightly visible again. Weird. Maybe its truly stuck, but that new glass panel across the front really helps minimize the visibility of pixel issues.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top