AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1,089 Posts
Discussion Starter · #1 ·
Have any plasma owners experienced any dead pixels on their panels ?


Is this even an issue with PDPs ? What does a dead pixel look like on a plasma display ?


If so....how did your retailer take care of it ?


Some say it is up to the manufacturer on how many equals a defective unit....where would you even find that number out ?
 

·
Registered
Joined
·
794 Posts
I have never seen a dead pixel on my panel. However, I never looked for them. Maybe there is one somewhere, maybe not. If there is one (or more) I certainly have not been able to notice them during regular viewing. And, to me, that's the bottom line. I don't watch static mono-color screens from 3 inches.


Andrzej
 

·
Registered
Joined
·
1,520 Posts
I have never seen a dead pixel on my Pioneer 503cmx. As Andrzej illududed to I dont' really want to know. I did a quick look up close at a white screen when I bought my plasma and did not see any dead. I didn't look any further - as if a found one it would drive me nuts.


Really, if you've got a couple dead you are never going to see them. There are 2 types (Dead, Stuck). Dead is going to be just a black pixel out. Stuck is when the pixel is always lit to one color - like a single red pixel.


I have not heard any reports of pixels actually going bad after the plasma is received - it is primarily a defect at time of manufacture.


Retailers are different and you would probably want to get there policy before buying. Companies like Dell will take a return for even a single dead pixel within 30 days. Some companies may require 3 or more dead pixels before allowing a return. I'd say if they will allow a return for 3 pixels they are being reasonable.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top