AVS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
867 Posts
Discussion Starter · #1 ·
I would like to play .mkv files with DTS using Windows 7 (64 bit) Media Center, and be able to output DTS to my receiver. So far I have been unsuccessful - audio is sent to the reciever decoded to stereo. I tried ffdshow, AC3 Filter, DivX codecs, SPDIFer. I can play the same file using Windows 7 Media Player, and DTS is sent to the receiver.


If someone has a definite answer, please let me know the formula to DTS for .mkv in Media Center 7.
 

·
Registered
Joined
·
1,213 Posts
remove/uninstall ALL of the haphazzardly installed codecs on your system.

(AC3Filter, anything DivX, FFDshow, MatroskaSplitter, Haali, manually registered ax files, etc)

Install the Shark007 Win7codecs along with the x64Components addon.

Check Control panel | Sound, under your spdif output, and set the speaker configuration to stereo


Open both of the Settings Application(s) (32bit and 64bit) and choose to use the SUGGESTED settings checkbox.

Go to the Audio TAB and set 'passthrough' on the right. The speaker configuration shoulds be set to 'Same as input'


Do the Audio TAB again (in both apps), but this time, do not use Adinistrative priveleges to open it.


If you have problems with MP4 files with this configuration, go to the SWAP TAB and re-enable Media Foundation.
 

·
Registered
Joined
·
867 Posts
Discussion Starter · #4 ·
I have a problem with one particular .mkv - it does not play on my HTPC, but it plays on my desktop. Both PCs are Windows 7 Ultimate 64bit, and both have been configured as per Shark007 instructions. The HTPS uses SPDIF passthrough, while the desktop PC uses analog 2 channel to speakers. What could be the issue? Media info shows the following information:


General

Unique ID : 180987559557867926855068338549773304416 (0x8828EFA110A2C5388BF7F3E8A8700260)

Complete name : \\\\LG-NAS\\movies\\Cloudy\\Cloudy.mkv

Format : Matroska

File size : 7.05 GiB

Duration : 1h 29mn

Overall bit rate : 11.2 Mbps

Encoded date : UTC 2010-01-04 19:17:46

Writing application : mkvmerge v3.0.0 ('Hang up your Hang-Ups') built on Dec 12 2009 15:20:35

Writing library : libebml v0.7.9 + libmatroska v0.8.1


Video

ID : 1

Format : AVC

Format/Info : Advanced Video Codec

Format profile : [email protected]

Format settings, CABAC : Yes

Format settings, ReFrames : 4 frames

Format settings, GOP : M=5, N=20

Codec ID : V_MPEG4/ISO/AVC

Duration : 1h 29mn

Bit rate : 8 249 Kbps

Width : 1 920 pixels

Height : 816 pixels

Display aspect ratio : 2.35:1

Frame rate : 23.976 fps

Color space : YUV

Chroma subsampling : 4:2:0

Bit depth : 8 bits

Scan type : Progressive

Bits/(Pixel*Frame) : 0.220

Stream size : 5.07 GiB (72%)

Title : FraMeSToR's "Cloudy with a Chance of Meatballs"

Writing library : x264 core 80 r1376M 3feaec2

Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=10 / psy=1 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=64 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / mbaff=0 / constrained_intra=0 / bframes=5 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=2 / wpredb=1 / wpredp=2 / keyint=250 / keyint_min=25 / scenecut=40 / rc_lookahead=60 / rc=2pass / mbtree=1 / bitrate=8249 / ratetol=2.0 / qcomp=0.70 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=50000 / vbv_bufsize=50000 / ip_ratio=1.40 / aq=1:0.80

Language : English


Audio

ID : 2

Format : DTS

Format/Info : Digital Theater Systems

Format profile : MA / Core

Codec ID : A_DTS

Duration : 1h 29mn

Bit rate mode : Variable

Bit rate : 2 929 Kbps / 1 510 Kbps

Channel(s) : 6 channels

Channel positions : Front: L C R, Side: L R, LFE

Sampling rate : 48.0 KHz

Bit depth : 24 bits

Compression mode : Lossless / Lossy

Title : DTS-HD track

Language : English


Text #1

ID : 3

Format : UTF-8

Codec ID : S_TEXT/UTF8

Codec ID/Info : UTF-8 Plain Text

Title : Dutch Subtitle Track

Language : Dutch


Text #2

ID : 4

Format : UTF-8

Codec ID : S_TEXT/UTF8

Codec ID/Info : UTF-8 Plain Text

Title : English Subtitle Track

Language : English


Menu

00:00:00.000 : en:00:00:00.000

00:04:28.184 : en:00:04:28.184

00:04:38.194 : en:00:04:38.194

00:04:47.620 : en:00:04:47.620

00:08:56.577 : en:00:08:56.577

00:14:33.163 : en:00:14:33.163

00:20:30.228 : en:00:20:30.228

00:24:25.589 : en:00:24:25.589

00:30:43.174 : en:00:30:43.174

00:36:29.604 : en:00:36:29.604

00:42:50.109 : en:00:42:50.109

00:46:36.793 : en:00:46:36.793

00:52:43.827 : en:00:52:43.827

00:55:07.429 : en:00:55:07.429

01:00:42.764 : en:01:00:42.764

01:05:43.397 : en:01:05:43.397

01:13:03.754 : en:01:13:03.754

01:17:45.369 : en:01:17:45.369
 

·
Registered
Joined
·
1,213 Posts
Quote:
Originally Posted by vddobrev
Both PCs are Windows 7 Ultimate 64bit, and both have been configured as per Shark007 instructions. The HTPS uses SPDIF passthrough, while the desktop PC uses analog 2 channel to speakers. What could be the issue?
The PC using anolog should not be set to 'passthrough' in the Shark007 Audio TAB.

go to the Audio TAB in both settings applications (as an admin, and without admin rights) and 'turn off' passthrough.


The leftside speaker configuration of the Audio TAB will detect what you have set for speakers in Control Panel | Sound,

and will automatically set the speaker configuration in the Shark007 Audio TAB.
 

·
Registered
Joined
·
867 Posts
Discussion Starter · #6 ·

Quote:
Originally Posted by Shark007 /forum/post/19718975


The PC using anolog should not be set to 'passthrough' in the Shark007 Audio TAB.

go to the Audio TAB in both settings applications (as an admin, and without admin rights) and 'turn off' passthrough.


The leftside speaker configuration of the Audio TAB will detect what you have set for speakers in Control Panel | Sound,

and will automatically set the speaker configuration in the Shark007 Audio TAB.

Right, and it is not set to 'passthrough'. Sorry if I didn't make it clear - the PC using analog plays the file fine, while the HTPC that is set to 'passthrough' has problem playing this only one file, out of 200+.
 

·
Registered
Joined
·
1,213 Posts

Quote:
Originally Posted by vddobrev /forum/post/19720754


while the HTPC that is set to 'passthrough' has problem playing this only one file, out of 200+.

If ONE file out of over 200 is exhibitting an issue, simple deduction analysis would lead anyone to the conclussion that the file itself is faulty. Delete it. Enjoy you HTPC without the hassle.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top