AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
I'm still tinkering with my HTPC, and everything is working great other than blu-ray disc playback - it's HORRIBLE. It's very choppy, then freezes altogether.


Currently I'm using a stock C2D 4300 (1.8 GHz), on a MSI G43 board (graphics disabled I think), with an MSI 5570 graphics card, 2 GB of RAM, and a LITE-ON iHOS104 blu-ray drive. I just installed the Gfx card last night thinking that would solve the problem and really help the CPU, but I get the same choppy results. THE CPU usage used to go up very high (90%), but now is between 40-60%, but the video is still extremely bad.


As I don't think it's hardware, it's either the software or the system settings. The blu-ray drive came with a basic version of PowerDVD 8 BD. I know that it won't play HD audio, but I at least thought it would play BD video fine. Do I need to upgrade this to PowerDVD 10 or something else to get flawless playback? Am I missing some setting somewhere?


Any help would be GREATLY appreciated!!
 

·
Registered
Joined
·
1,650 Posts
Uninstall all video drivers.

Download and install the latest CCC package from ATI.

Open the file and select 'Custom' install. Make sure you select all available drivers and software. Disable game trial if you wish.

After install, reboot the computer.

Open PDVD and under 'Video' settings, check the box that says 'Enable Hardware Acceleration'.


What OS do you have?

You will need Vista or Win 7 for proper hardware acceleration and video decoding by the GPU.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #3 ·
Thanks for the reply!


When installing the Gfx card last night, I downloaded and installed the most recent driver directly from ATI, and rebooted. Also, no matter if I check or uncheck the hardware acceleration box, it will check itself and then gray itself out during playback.


Oh, and I have 64 bit Windows 7.


I'll tinker with it some more tonight, I finally figured out how to slightly stretch the image on my 55" TV as the HTPC was only using about 90% of the screen real estate.
 

·
Registered
Joined
·
187 Posts

Quote:
Originally Posted by matttyl315 /forum/post/19570121


Thanks for the reply!


When installing the Gfx card last night, I downloaded and installed the most recent driver directly from ATI, and rebooted. Also, no matter if I check or uncheck the hardware acceleration box, it will check itself and then gray itself out during playback.


Oh, and I have 64 bit Windows 7.


I'll tinker with it some more tonight, I finally figured out how to slightly stretch the image on my 55" TV as the HTPC was only using about 90% of the screen real estate.

You may want to check in your sound device to see if the 'Give exclusive mode applications priority' check box is selected. I had a problem with that on PowerDVD 9 Ultra once on my dearly departed X1200. Once I selected it all of my choppiness and stuttering went away. It should be on the 'Advanced' tab of your sound device's 'Properties'.
 
1 - 5 of 5 Posts
Top