AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
I have had my Pioneer Elite PRO-710 for almost a year now and have really enjoyed it. For the past week or so I have had a problem in that it suddenly clicks off and I have to turn it back on using the manual power switch on the front panel. It sometimes takes me a time or two to get it to come back on, but so far it has worked. I am thinking that this must have something to do with the power supply or something. Has anyone else had this kind of problem?
 

·
Registered
Joined
·
75 Posts
Had a customer w/ the same problem; does involve a service technician replacing a board (power supply control, I think). Not a big deal though, he was able to get the right part w/o looking at the TV first.
 

·
Registered
Joined
·
1,839 Posts
The brief answer is that unless you are an Elite service technician you will probably have to call someone for service no matter what the problem is.


It could be a short of some sort. If the short is externally-generated then it could be an external fix. I had a problem recently with my Elite receiver shutting down whenever a particularly loud noise occurred in what we were watching. I tracked it down to a small short between the two connections to my left front speaker. Apparently the receiver is smart enough to just quit if this happens (instead of blow up or something). Maybe your 710 is having a similar problem?....
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top