AVS Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
I have a problem with my new 65TWX20B (had it one week). After the set warms up, I get a Green Flickering Effect. Its kind of like a Green lightning flash…not that bright but definitely not subtle!! It happens on all inputs: component HDTV, SVideo DVD, DSS, and Ant – A Cable.


I called the Hitachi service center, unfortunately the only authorized repair center for my area is about 1 ½ hour away. They come out and pick your TV up and only do repair work in their shop(Arrgh!!) This thing is a 310lb MONSTER-- I can’t imagine what its gonna look like after a couple trips on the truck.


Has any one ever experienced this problem or have a guess as to what might be wrong?


Thanks, John


PS - Bought from UECWEB.com (Hitachi refurb site... so repair is my only option)
 

·
Registered
Joined
·
1,417 Posts
I have many problems with performance quality of my 65XWX but it was general picture not being 3d and other qualitative issue's, but I did not have anything where it was just doing some strange thing like that.


When you say it is a green flicker, does that mean you are seeing green lines, or is the green just too high, and the flicker is just independent of that, so possibly 2 problems?


I hope whatever it is you get it taken care of, even though you chose to go to that continuation program in College station. I heard Reggie is looking pretty awesome in camp. Our QB stud on the other hand is showing that he is raw, and is apparently going to get beat out by Mock to start.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top