AVS Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
I just got that PS3 for my home theater. I'm having some issues I hope an audiophile can help me out with. On the BD I have two options: PCM Linear or Bitstream. I always thought bitstream was better but when I select it it says that I may not get all the audio during playback.


On my receiver which is a Panasonic SA-HE 100 (it doesn't have TrueHD audio, just 6.1 dolby), when I have Spider Man playing back on PCM Linear it's saying it's only getting a 2 channel input (just showing L and R speakers). When I hit display on my PS3, it says it's playing in TrueHD Dolby. Now if I switch to bitstream, my receiver shows 5.1 audio, but it sounds like it's just 2.0 audio -- nothing comes out of the surround speakers. I'm stumped. Please don't tell me I have to buy a new receiver too. My Toshiba HDDVD player doesn't have this problem -- I'm hoping it's a PS3 issue that's easily fixed
.




Not sure if i Should post in the bd section or the receiver section, but the panasonic works fine..thanks!
 

·
Registered
Joined
·
513 Posts
how is your PS3 connected to your receiver?


Jorge
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
First off, I will say when I posted, I hadn't RTFM on the sticky thread which really helps me to understand what's going on.


Apparently, if you're using TOSLINK cables (optical) to your receiver, you MUST use bitstream because of a bandwidth issue.


HOWEVER...when I use this option, even though my SA100 shows 5.1 audio going in, it sure doesn't sound like the surround speakers are working at all with a BD movie (all I have right now is the Spider man movie which came with this PS3).


So anyway, right now I have a PS3 connected to a Monoprice 2.1 switch via HDMI which then goes directly to the TV (Samsung Kirk 50" model) and then a TOSLINK cable to my audio receiver a Panasonic SAHE100.


When I play games and the receiver shows 5.1 it sure sounds like 5.1. So this is why I'm confused. Maybe I can tell using a standard DVD and see how that is.
 

·
Registered
Joined
·
513 Posts
I cannot confirm if when you have bitstream on the Toslink and you choose TrueHD if it decodes but only sends two channels out but I have seen some threads to that effect. Another thing is and I don't really know when it is that happens as my setup is via HDMI that if you cannot decode TrueHD on the Spiderman3 BD it defaults to a hidden Doby Digital Track on the Disc. Do a search and you should be able to find out more info on the Spiderman 3 BD.


Jorge
 

·
Registered
Joined
·
88 Posts
when you hit "display" it says "Dolby Digital" and then a sampling rate, which I don't recall, maybe 640? I can't remember


I thought Dolby Digital was 5.1? I will try with another regular DVD and report back.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #6
Boy, I'm an idiot.


I was using a new input on my receiver and the optical wasn't set up correctly -- it was setup as "stereo" instead of "surround"...


So now I have 5.1 audio and officially confirmed I'm an idiot. Thanks very much for the help from the group...
 
1 - 6 of 6 Posts
Top