AVS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1

Hello,

 

First of all, apologies if I have posted this in the wrong place (it seemed a logical location...)

I have just set up my first AV receiver (Denon AVR-X2000) and have run into an issue with the HDMI output to my screen (screen flickering on and off).

MY SETUP: I am using a Sony BluRay player (BDP-S780) and a Sony screen (KDL55-HX820), which I have had for just under 2 years. Both have been working fine but I decided I needed better sound so I purchased the Denon and a couple of floor standing speakers (Q Acoustics 2050i). I also have an Xbox360 connected.


THE PROBLEM: The flickering of the screen (every second or so and quite irregular) happens when I am playing a DVD or CD on my BluRay player. The screen even blinks when I am using the BluRay player's menu (while a DVD is inserted). Sometimes the flickering starts immediately, other times it takes about half a minute to start. The flickering will also happen when the receiver is on stand-by passthrough. 

THE STRANGE THING: When I play a Blu-Ray disc (instead of a DVD) using the exact same player everything seems to work fine. Also there doesn't seem to be an issue with the sound at any stage. Playing a DVD through my much older Xbox 360 seems to work fine as well (not desirable as the Xbox is a noisy player).

QUESTION: Any ideas of what could be wrong?

 

- I have read about HDMI "handshake" issues. Not sure if this is it as the BluRay disc works fine while a DVD causes problems.

- Wondering if it is something in the signal processing (e.g. DVD upscaling by both the BluRay player and receiver).

- Perhaps the cable length, type or quality. The components are connected using 1.5m HDMI cable (not sure about quality), while the receiver is connected to the screen with a 3m HDMI. Again doesn't seem an issue as both BluRay and Xbox are fine.

 

Any ideas, recommendation etc; much appreciated (as this issue is driving me nuts!)

 

Thanks!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3

I think I found the solution. As suggested I turned deep colour output off and switched the DVD up-conversion output from 1080p to 1080i. Seems to have fixed it, no blinking on and off and even the Blu-ray player menu is stable (when a CD or DVD is inserted). Will need to check what did the trick of course, deep colour setting or p vs. i. Won't touch it for now though... :)
 
1 - 4 of 4 Posts
Top