AVS Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
Hello all.....


If you could lend a hand with any advice it would be much appreciated. I have my HTPC connected to my Mitsubishi 1080p DLP through a Denon 3808CI receiver. Running Windows 7 x64, Geforce GTX 275 w/latest drivers. My TV never had any trouble displaying various resolutions before the Denon.


Anyhow, when I attempt to play any game that does not have a config option outside the main menu screen, all I get is a blue screen with sound. When I'm able to configure the video options before entering the game and set them to 1080p, everything works fine. Many games, however, make you adjust video options in-game, and therein lies my problem. Some of them have a config file you can edit to get around this, but many don't - and many don't even have video options. For some reason, however, a few older games that run at only 800x600 work fine?


Obviously the HDMI connection on the Denon isn't liking the PC resolutions. Running the HDMI straight to the TV isn't an option. I've tried starting the programs in 640x480 through the properties menu, but that doesn't seem to work either. I've tried turning on and off the A-H and H-H conversion options in the Denon menu, but again, no luck. I've tried adjusting the desktop resolution to various PC levels - which the Denon DOES display, but when the game starts it goes blank. Strange it displays strange resolutions on the desktop but not in-game. You would think with conversion ON it would upconvert any signal and work fine......or with it off it would just pass the signal through, but this doesn't seem to be the case. It's maddening, since I didn't build an HTPC and buy all this equipment so I could play games on my laptop. The Denon has the latest firmware, btw.


Any ideas or suggestions other than hooking up a second monitor or running straight to the TV?
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #2 ·
Oh, and I searched and found similar threads, but none that addressed my specific problem - they just dealt with the receiver not wanting to display at ALL. Just FYI..
 

·
Registered
Joined
·
408 Posts
I have the exact same receiver as you, and the exact same problem. I've only found 2 ways to solve the problem:


Temporarily change my desktop resolution in order to play a game. I own a few games that I couldn't get to play at 1080p. I would just get a blank screen on my TV. So I changed my graphic card's resolution to 1280x720p, and I was able to play the game.


I have also altered config files, so that games can open in the proper resolution. But what do you do when there is no config file? You open your game in windowed mode. Then change the resolution to 1080p. Then switch back to full screen mode.


But how do I open a game in windowed mode? Well, I'm glad you asked.
There are two ways to do this:

Open your game. Now click "ALT" and "Enter" at the same time. Just make sure you use the ALT key on the right side of the keyboard, not the left side.

or

Find the exe file that launches your game. (If you have Steam, go to your Steam folder, steamapps, common, then find the folder for your game. If you have more than 1 exe file, look for one with the word "launcher" in its name. Or just try each one.) Once you find the exe file, right click it, and "Create Shortcut." Now right click the shortcut you just made, and select "Properties." Under the "Shortcut" tab, it should say "Target." Right next to the word "Target," will be a box with the file pathway for the shortcut. Go to the end of the text and add " -w" without the parenthesis. Click OK. Now open your game using the shortcut, and it should open in a window. Change the resolution to 1920 by 1080p. Close your game. Delete the shortcut.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #4 ·
Thank you for the advice - very helpful and I appreciate you taking the time to respond. I tried changing the desktop resolution to 1280x720p with one or two games that wouldn't work (among other resolutions) and still got the blank screen, but since I know it works for you I'll play around with it some more and let you know how it goes.


I attempted to open one of the first games I had the problem with in windowed mode like you advised (Alternativa or Sinking Island - I forget which) and it kept crashing, so I kind of forgot about trying it on the others. Thank you for reminding me of the option. I'll let you know how it works on some of the others.


Strange how some of the old games I have played (Gabriel Knight, Broken Sword, Black Mirror, etc) that only give the option for 800x600x32 display fine while newer ones won't display at 800x600. Anyhow, thanks again and I'll let you know how it goes...
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #5 ·
Well I'm still having issues with this - 99% of the games I try won't display - they just start to audio but a blue screen. I've tried forcing them to start in window mode, changing the desktop resolution, etc. No luck. The strange thing is that several OLD games will play just fine - and they're 800x600. But others that use that resolution won't. And I can't set my desktop to that res either - it blue screens.


I'm at a loss and this is defeating the purpose of having an HTPC in the first place. Anyone have any ideas?
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #6 ·
Problem finally solved. I installed the latest Nvidia drivers, then set scaling to be performed by GPU instead of display in my Nvidia control panel and checked "override scaling mode set by games and programs". ALL games are working now........VERY happy.
 

·
Registered
Joined
·
11,443 Posts
Talk about a long and frustrating time to solve this.. Wow!
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #8 ·

Quote:
Originally Posted by Sammy2 /forum/post/21975778


Talk about a long and frustrating time to solve this.. Wow!

Yeah, you're not kidding. Hopefully it helps someone else with similar problems......
 
1 - 8 of 8 Posts
Top