AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Have been watching several Blu Ray movies lately, and just for a minute second the video seems to catch and then return to normal image. and the slight hitch is driving me nuts. Just noticed it with the newer titles

(10,000 BC and Rambo). Is it my ps3 or just he newer titles. Would appreciate feedback.

Thanks for a reply.

Wayne B.
 

·
Registered
Joined
·
47 Posts
I have the new MGS4 combo PS3, and I haven't recieved any glitches so far. I have the new Rambo, and it played flawlessly. Have you updated to version 2.35 yet?
 

·
Read the FAQ!
Joined
·
36,027 Posts

Quote:
Originally Posted by waynebruce /forum/post/14186892


Have been watching several Blu Ray movies lately, and just for a minute second the video seems to catch and then return to normal image. and the slight hitch is driving me nuts. Just noticed it with the newer titles

(10,000 BC and Rambo). Is it my ps3 or just he newer titles. Would appreciate feedback.

Thanks for a reply.

Wayne B.

That sounds like the HDMI connection is having a problem when it periodically rechecks to make sure the copy protection stuff is still active on that connection. You may need to upgrade your HDMI cable. Or it may be that the cable you have now has come just a little bit loose at one end or the other -- reseat it.


If not that, then double check that you don't have any fingerprints on your discs. You may be seeing the player trying to recover from a disc read problem. This is particularly likely if you rent your discs.

--Bob
 
1 - 3 of 3 Posts
Top