AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
I've read all the threads about this flicker issue but no one seems to have a definite answer as to what the cause of the flicker problem is. My PJ is 2.5 years old with about 1700 hours on bulb and I've always ran it in normal mode. I had the stuck iris problem and I lubed that up the other day to get it unstuck. So now my only major issues are the flicker problem and the purple horizontal interference lines that appear for a split second from time to time (fixed with firmware update but that will cost me about $150 to have that done) and the HDMI signal sometime drops and needs some cable massaging to get it back.


I'd be content with buying a new bulb if I knew for sure it will fix the flicker problem but anything more than the cost of a new bulb seems to be too much to spend on this clunker PJ.


Anyone know what the actual cause of the flicker problem is? Thank you for the help!!
 

·
Registered
Joined
·
1,765 Posts
It's most likely the lamp, but it could also be a lamp ballast or power supply issue as well. Unfortunately the only way to find out for sure is to try a new lamp.


EDIT: It's also possible the iris could be causing it...not likely since you said you just relubricated it, but still possible.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #4 ·
I'm just not sure its worth the $300+ on a new lamp for the chance it fixes the problem. Seems like it might be wiser to cut my losses and just get a new PJ but I've been reading up on the new models (Epson 8100/8500, Panasonic AE4000, and Viewsonic Pro8100) and they all seem to have their problems. Hard to know what a guy should do.
 
1 - 4 of 4 Posts
Top