AVS Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
4,351 Posts
Discussion Starter #1
My HTPC is also my main computer, so for most of the time I have a regular monitor attached to it.


When I use it as an HTPC, I unplug the monitor and plug in the projector.


If I accidentally leave the projector connected when I reboot the PC, it redetects the monitor on bootup. Since its connected with an RGBHV cable, no valid projector is detected and it defaults to a Generic Plug and Play projector. In this configuration, no refresh rates above 60Hz are supported.


How can I disable the monitor autodetect, and force the monitor settings to remain as my normal monitor? (A Viewsonic PT775) Or is there any better way to solve this very annoying problem?


Thanks,


Andy K.
 

·
Registered
Joined
·
2,151 Posts
"it defaults to a Generic Plug and Play projector."


Andy, do you mean P & P "monitor"?


Have you tried using the standard Windows(you don't mention which OS) 1600 x 1200 Super VGA driver?


For me, my G11 and VE on ME, that driver passes all tests.


Chris
 

·
Registered
Joined
·
4,321 Posts
Andy,


Check "Display Properties>Settings>Advanced>Monitor" while your Viewsonic is connected, and uncheck the "Automatically detect plug and play monitors" box. This will force the system to find the Viewsonic everytime you boot.


Kei Clark

Digital Connection
 

·
Registered
Joined
·
4,351 Posts
Discussion Starter #4
Sorry, I should have mentioned that I'm running Windows2000.


Kei, thanks for the info but that option is not available on Win2K (at least, not in that panel, do you know somewhere else it may be?)


I'll try forcing the generic 1600x1200 driver and see if that fixes it.


Thanks,


Andy K.
 

·
Registered
Joined
·
4,310 Posts
Hi Kromkamp:


___I haven’t used Windows 2000 in quite some time for HTPC use so I simply pulled an old post to a member named “Atom†that gave me the ability to run a GeForce custom T&R to my HD RPTV under Windows 2000 …

If you are using Windows 2000, then you Right click on the desktop --> Properties --> Settings Tab --> and look at the “Display†listed. If it doesn’t mention the monitor you had previously setup, than let’s change it to the Sony W900. Click on Advanced --> Monitor Tab --> Click on Properties --> Driver Tab --> Update Driver --> Next --> Display a list of Known drivers … --> Next --> Show all HW of this device class --> Select “Sony†on the left and scroll down until you see the “Sony GDM-W900†on the right and highlight --> Next --> Next --> Yes --> Finish. After your new monitor inf is in place, than try the new custom T&R from Power Strip and reboot. You should now be able to use the 1440X960 Custom T&R.


___Good Luck


___Wayne R. Gerdes

___Hunt Club Farms Landscaping Ltd.

___ [email protected]
 

·
Registered
Joined
·
4,351 Posts
Discussion Starter #7
Hi Wayne,


Yes, I know how to install the driver for my monitor, what I want to find out is how to keep Windows 2000 from changing it if I reboot with by Projector plugged in. I can always change it back but its a real PITA :)


Andy K.
 

·
Registered
Joined
·
551 Posts
Hi Andy,


ATi is continuously changing their way how to disable P&P. It's their problem. Anyway, here are the ways. Yes, ways. Because they changed the way to disable it at latest driver again.


Win2k, WinXP drivers before 3276: advanced display tab>monitor>attributes>disable DCC. After that you can set the maximum refresh rate by hand.


Win2k, WinXP driver after 3276: first connect ATi card to P&P monitor with HDB15. advanced display tab>attributes>disable DCC. If you didn't connect P&P monitor, attributes tab become disabled. You can go that tab, but all options are grayed and cannot change. Then, you can set the maximum refresh rate by hand. However, this driver sometimes forgot what I set. So, you might need set the refresh rate again and again. At least their driver remember what I disabled, so I can use HDB15-BNC cable without cable switching anymore for better quality.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top