AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Well first thing I want to say is that my equipment is about 10 years old. LOL now that that's out of the way. I have a Onkyo TX-DS575 5.1 channel receiver and i have a HTS -10 infinity surround sound system. Everything was fine until a couple of days ago when my wife came home with the kids. She heard this loud buzzing or humming noise when she was outside the door. She came in and the sub was making that noise. So she unplugged it from the wall. I got home and i powered it back on and sure enough it was loud, even when i turned the volume down on the sub. So i unplugged the the cables from my receiver to it and it still made the noise. So, there are no cables going to it and it is only plugged into the wall. It has a built in crossover in it also. I took it apart to look inside and there was only like one board with a power supply and transformer on it, and the rest i assume was to control the crossover and such. So you guys think the sub is toast or what? Thanks in advance.
 

·
Registered
Joined
·
4,771 Posts
The sub driver is not toast, but that amp has seen better days. Sorry I'm only part way through my BSEE so I can't trouble shoot it, but if you buy another amp you'll be up and running again.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yeah i am contemplating on just buying a new sub and not worry about this one. It is 10 years old. LOL So i have been looking around and thinking about piecing together a new system. The thing that sucks is that everything else still works great!!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top