AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
For about a month now, almost all of my Cable TV Channels have at one time or another been messed up. I think the term to explain it is "Pixilated". It has gotten so bad that the stations are unwatchable. I have cable service from Comcast and also have Comcast High Speed Internet. I haven't noticed any difference in the Internet speed, but I usually don't do much downloading or other things where I would notice. Getting back to the Picture Quality. I have five TV's with four of them connected to Set Top Boxes. (They are NOT HD) The one without works perfectly and all of the other's are experiencing "Pixilation". I have tried disconnecting the Cable from the "Boxes" and running the Cable directly to the TV's and when connected this way, all of them have good quality pictures. I haven't changed anything in years and haven't had any problems during that time until recently. I know in my heart that when I contact "Comcast" about this problem, they will undoubtedly tell me that the problem is on my end and not theirs. I would like to have an idea as to what could be causing this problem before I talk with them. Thanks for any information that anyone can supply.


Jay
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
"PROBLEM SOLVED" I had installed a Radio Shack Signal Amplifier years ago. I removed it to see if that was the problem, and it appears that it was as all TV Channels are now working properly. Either Comcast has recently changed their signal or the Signal Amplifier has gone bad or both. Anyway everything is now back to normal.



Jay
 
1 - 2 of 2 Posts
Top