AVS Forum banner

681 - 700 of 1086 Posts

·
Registered
Joined
·
366 Posts
Anyone in this thread got their rebate bulb yet? What was your timeline?

Originally my rebate showed as "Submit Date" Jul 11 - later it changed to "Date Processed" - July 25th and Current Status" shows as In Process. Thats where its been stuck for the last few weeks.

Oddly, I noticed that the Offer shows as EA987 HC5040B/UBE LAMP DEC-JAN where as I had submitted using July rebate form :confused:
 

·
Registered
Joined
·
11,842 Posts
Anyone in this thread got their rebate bulb yet? What was your timeline?

Originally my rebate showed as "Submit Date" Jul 11 - later it changed to "Date Processed" - July 25th and Current Status" shows as In Process. Thats where its been stuck for the last few weeks.

Oddly, I noticed that the Offer shows as EA987 HC5040B/UBE LAMP DEC-JAN where as I had submitted using July rebate form :confused:
where do you check rebate status?
 

·
Registered
Joined
·
25 Posts
Anyone in this thread got their rebate bulb yet? What was your timeline?

Originally my rebate showed as "Submit Date" Jul 11 - later it changed to "Date Processed" - July 25th and Current Status" shows as In Process. Thats where its been stuck for the last few weeks.

Oddly, I noticed that the Offer shows as EA987 HC5040B/UBE LAMP DEC-JAN where as I had submitted using July rebate form :confused:
In Canada, I received my free lamp a couple of weeks ago. Submitted early June and got my confirmation of receipt email June 24. Received the lamp 2nd week of August.

You definitely get it.
 

·
Registered
Joined
·
60 Posts
In Canada, I received my free lamp a couple of weeks ago. Submitted early June and got my confirmation of receipt email June 24. Received the lamp 2nd week of August.

You definitely get it.
i submitted my rebate late June they got it on July 10 still haven't received lamp but im not worried.
 

·
Registered
Joined
·
25 Posts
Btw, this projector kicks ass. Being my first projector, I didn't know what to expect. I haven't really used it yet as I am in process of finishing the basement, but I tested on my living room wall and it blew me away.

Can't wait for hockey season!!
 

·
Registered
Joined
·
54 Posts
Btw, this projector kicks ass. Being my first projector, I didn't know what to expect. I haven't really used it yet as I am in process of finishing the basement, but I tested on my living room wall and it blew me away.

Can't wait for hockey season!!
Hope you're right, Rick...I just bought a 5040UB refurb on the Epson clearance site for $1,497.00 CDN.

I've had an Epson HC3020 for 7 years now, and the other night we had a lightning storm that knocked out the power, blew out one of the HDMI ports and I suddenly started seeing a growing Blue "stain" growing from the top right hand corner. Epson Tech Support informed me they couldn't do anything, and the local Epson repair guy told me the old projector needed a main board and a new light engine...a $ 1,200.00 touch, so a refurb for a couple of hundred more and I have a "newer" projector. Epson tells me it'll be here in a few days.
 

·
Registered
Joined
·
20 Posts
Btw, this projector kicks ass. Being my first projector, I didn't know what to expect. I haven't really used it yet as I am in process of finishing the basement, but I tested on my living room wall and it blew me away.

Can't wait for hockey season!!
Hope you're right, Rich...I just bought a 5040UB refurb on the Epson clearance site for $1,497.00 CDN.

I've had an Epson HC3020 for 7 years now, and the other night we had a lightning storm that knocked out the power, blew out one of the HDMI ports and I suddenly started seeing a growing Blue "stain" growing from the top right hand corner. Epson Tech Support informed me they couldn't do anything, and the local Epson repair guy told me the old projector needed a main board and a new light engine...a $ 1,200.00 touch, so a refurb for a couple of hundred more and I have a "newer" projector. Epson tells me it'll be here in a few days.

Just got mine last week. If you live in Ontario it'll be there next day. I got a perfect one I think here and it looks phenomenal. I used to have an ht1070A benq and this one blows it out of the water.
 

·
Registered
Joined
·
2,001 Posts
Hope you're right, Rich...I just bought a 5040UB refurb on the Epson clearance site for $1,497.00 CDN.
........

Well as they say "all goods things come to those that wait" ;) ... hope you get a good one.
My Cinema Pro 4030 is still looking great but I lost count of how many times I've had one of the 5040s in my Epson basket...lol....:D
 

·
Registered
Joined
·
54 Posts
Well as they say "all goods things come to those that wait" ;) ... hope you get a good one.
My Cinema Pro 4030 is still looking great but I lost count of how many times I've had one of the 5040s in my Epson basket...lol....:D
Ouch...Is the 5040 that bad? By the way, Rob...Never did get the good deal on a 4030 like we talked about earlier...However, I thought this might be a good alternative. I have seen lots of complaints about power supplies on UK 5040's, and I have seen complaints about refurbs being delivered scratched, or without remotes or similar, but again, people tend to complain more than they praise...however, since we've had positive interactions before, I value yiour opinion. Doesn't sound like you're happy about 5040's...
 

·
Registered
Joined
·
54 Posts
Just got mine last week. If you live in Ontario it'll be there next day. I got a perfect one I think here and it looks phenomenal. I used to have an ht1070A benq and this one blows it out of the water.
Thanks Pearcebud...
I'm in rural central Alberta, and I understand I'll see the unit in 4 or 5 days, according to my purchase confirmation.
 

·
Registered
Joined
·
2,001 Posts
Ouch...Is the 5040 that bad? ....

Not at all...IMHO it's a great deal and with a 2 year exchange warranty a no brainer...
As my 4030 is new it's hard to justify another projector so soon...even though it would be a nice upgrade :rolleyes:....so I give myself all kinds of "lame" excuses for not pushing that "buy" bottom. ... lol
 

·
Registered
Joined
·
54 Posts
Not at all...IMHO it's a great deal and with a 2 year exchange warranty a no brainer...
As my 4030 is new it's hard to justify another projector so soon...even though it would be a nice upgrade :rolleyes:....so I give myself all kinds of "lame" excuses for not pushing that "buy" bottom. ... lol
OK, thanks, Rob...You had me scared for a minute, since I went ahead with the purchase. We'll see in about a week, according to my purchase confirmation. I didn't order on line, but from a human being at Epson. I'm looking forward to increased resolution, increased brightness and the lens shift on the Fujinon, which would help, as my current setup has some "environmental" issues (Can't hang the projector high enough due to a beam on my ceiling right where the projector needs to be). We'll see. Thanks again for the response. I can sleep now (until the unit arrives).
 

·
Registered
Joined
·
25 Posts
Hope you're right, Rick...I just bought a 5040UB refurb on the Epson clearance site for $1,497.00 CDN.

I've had an Epson HC3020 for 7 years now, and the other night we had a lightning storm that knocked out the power, blew out one of the HDMI ports and I suddenly started seeing a growing Blue "stain" growing from the top right hand corner. Epson Tech Support informed me they couldn't do anything, and the local Epson repair guy told me the old projector needed a main board and a new light engine...a $ 1,200.00 touch, so a refurb for a couple of hundred more and I have a "newer" projector. Epson tells me it'll be here in a few days.
That sucks about the old unit. I wonder if a surge protector would have kept it safe? I was thinking about getting one for all my components. Hopefully you get a good 5040 on the first try. I did. Looks brand new and no issues with the picture. With the quantity they have now on Epson.ca, it seems like a lot of good units are going out, maybe even new ones marked as refurbs. 🤞. Let us know how it goes....
 

·
Registered
Joined
·
2 Posts
So I just received mine and it has that pink shade in the corners. Honestly it's not that bad unless the screen is mostly white. Anyone know what causes it? Would a new lamp fix it? If not I guess I'll try rolling the dice again.
 

·
Registered
Joined
·
20 Posts
Hope you're right, Rick...I just bought a 5040UB refurb on the Epson clearance site for $1,497.00 CDN.

I've had an Epson HC3020 for 7 years now, and the other night we had a lightning storm that knocked out the power, blew out one of the HDMI ports and I suddenly started seeing a growing Blue "stain" growing from the top right hand corner. Epson Tech Support informed me they couldn't do anything, and the local Epson repair guy told me the old projector needed a main board and a new light engine...a $ 1,200.00 touch, so a refurb for a couple of hundred more and I have a "newer" projector. Epson tells me it'll be here in a few days.
That sucks about the old unit. I wonder if a surge protector would have kept it safe? I was thinking about getting one for all my components. Hopefully you get a good 5040 on the first try. I did. Looks brand new and no issues with the picture. With the quantity they have now on Epson.ca, it seems like a lot of good units are going out, maybe even new ones marked as refurbs. 🤞. Let us know how it goes....
Im hoping by end of 2021 they wont have any 5040 refurb units left. Ethier we get new ones or 5050 recurbs.
 

·
Registered
Joined
·
17 Posts
It was delivered today. Took a quick look and no evidence of it being ceiling mounted previously. Also, it indeed has the original stickers on it. Not that these are any indication of getting a good unit though...but at least the unit seems to be in 'like new' physical condition. :D

I suppose I should at least do a preliminary power on test before ceiling mounting it. Seems like the built in test pattern is the best way to do this? It looks like people have been observing color gradient issues in the test pattern ( see posts above ). That will probably be my first test.
UPDATE :

I have my refurb 5040UB all set up now. It did have a slight LCD alignment issue. When using the PC, I could see a green horizontal line on the bottom of an all white window in WIN10. I did the 'panel alignment' process via the projector settings and after messing with it a couple hours, the green line no longer appears and I am now happy with it.

I tried a few of the calibration setting posted on the main 5040UB thread and then tried out a few 4K NON-HDR videos on YouTube. The picture is absolutely amazing! :D Coming from a midrange 1080p DLP projector, I now understand what I was missing out on till now. :eek:

I then tried switching HDR on in the WIN10 settings...and started having problems. The same 4K videos that worked fine in non-HDR mode now stutter when viewed in HDR mode. It looks to me like this is a common problem. Frankly, HDR in general seems like a mess on the PC side. I did find the following discussion on HDR, etc...that was quite educational for me :

https://forum.kodi.tv/showthread.php?tid=259188&pid=2238949#pid2238949

There are lots of options as far as HDR is concerned...I would encourage other newbies like me to go to the discussion above and read up.

I may try to set things up in the discussion above to see if I can solve my 4K HDR stutter on PC issue. If anyone has any other ideas, please let me know! :D

EDIT :

Well crud...I figured it out. According to the chart below, my Nvidia GTX 1070 won't handle 10bit VP9...which YouTube apparently uses for HDR content. Interestingly enough, the Nvidia GTX 1050 *does* support it...probably because the 1050 was released after the 1070 and has an improved decode chipset (?) Gee, confusing enough? :confused:

https://developer.nvidia.com/video-encode-decode-gpu-support-matrix#Decoder

I guess a new graphics card is in my future at some point....:rolleyes:
 
681 - 700 of 1086 Posts
Top